summaryrefslogtreecommitdiffhomepage
path: root/libs
diff options
context:
space:
mode:
Diffstat (limited to 'libs')
-rw-r--r--libs/nixio/Makefile12
-rw-r--r--libs/nixio/docsrc/CHANGELOG.lua8
2 files changed, 16 insertions, 4 deletions
diff --git a/libs/nixio/Makefile b/libs/nixio/Makefile
index 044764e92..f70f75421 100644
--- a/libs/nixio/Makefile
+++ b/libs/nixio/Makefile
@@ -87,6 +87,18 @@ $(AXTLS_DIR)/.prepared:
src/libaxtls.a: $(AXTLS_DIR)/.prepared
$(MAKE) -C $(AXTLS_DIR) CC="$(CC)" CFLAGS="$(CFLAGS) $(EXTRA_CFLAGS) $(FPIC) -Wall -pedantic -I../config -I../ssl -I../crypto" LDFLAGS="$(LDFLAGS)" OS="$(OS)" clean all
cp -p $(AXTLS_DIR)/_stage/libaxtls.a src
+ # *************************************************************************
+ #
+ #
+ #
+ # *** WARNING ***
+ # The use of the axTLS cryptographical provider is discouraged!
+ # Please switch to either CyaSSL or OpenSSL.
+ # Support for axTLS might be removed in the near future.
+ #
+ #
+ #
+ #**************************************************************************
clean: luaclean
rm -f src/*.o src/*.so src/*.a src/*.dll
diff --git a/libs/nixio/docsrc/CHANGELOG.lua b/libs/nixio/docsrc/CHANGELOG.lua
index f73e96632..fb1cf160b 100644
--- a/libs/nixio/docsrc/CHANGELOG.lua
+++ b/libs/nixio/docsrc/CHANGELOG.lua
@@ -1,7 +1,7 @@
--- Changes and improvements.
module "CHANGELOG"
---- Nixio 0.3
+--- Service Release.
-- <ul>
-- <li>Added getifaddrs() function.</li>
-- <li>Added getsockopt(), setsockopt(), getsockname() and getpeername()
@@ -14,13 +14,13 @@ module "CHANGELOG"
-- <li>Fixed usage of signed datatype breaking Base64 decoding.</li>
-- <li>Fixed namespace clashes for nixio.fs.</li>
-- <li>Fixed splice() support for some exotic C libraries.</li>
--- <li>Reconfigure axTLS cryptographical provider.</li>
+-- <li>Reconfigure axTLS cryptographical provider and mark it as obsolete.</li>
-- </ul>
-- @class table
--- @name 0.2
+-- @name 0.3
-- @return !
---- Nixio 0.2
+--- Initial Release.
-- <ul>
-- <li>Initial Release</li>
-- </ul>