summaryrefslogtreecommitdiffhomepage
path: root/libs/web/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'libs/web/Makefile')
-rw-r--r--libs/web/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/libs/web/Makefile b/libs/web/Makefile
index cc3bc96fc1..d9f9700c1c 100644
--- a/libs/web/Makefile
+++ b/libs/web/Makefile
@@ -5,11 +5,11 @@ include ../../build/gccconfig.mk
TPL_LDFLAGS =
TPL_CFLAGS =
TPL_SO = parser.so
-TPL_COMMON_OBJ = src/template_parser.o
+TPL_COMMON_OBJ = src/template_parser.o src/template_utils.o
TPL_LUALIB_OBJ = src/template_lualib.o
%.o: %.c
- $(COMPILE) $(TPL_CFLAGS) $(LUA_CFLAGS) $(FPIC) -c -o $@ $<
+ $(COMPILE) $(TPL_CFLAGS) $(LUA_CFLAGS) $(FPIC) -c -o $@ $<
compile: build-clean $(TPL_COMMON_OBJ) $(TPL_LUALIB_OBJ)
$(LINK) $(SHLIB_FLAGS) $(TPL_LDFLAGS) -o src/$(TPL_SO) \
@@ -24,5 +24,3 @@ clean: build-clean
build-clean:
rm -f src/*.o src/$(TPL_SO)
-
-