summaryrefslogtreecommitdiffhomepage
path: root/libs/luci-lib-luaneightbl/src
diff options
context:
space:
mode:
Diffstat (limited to 'libs/luci-lib-luaneightbl/src')
-rw-r--r--libs/luci-lib-luaneightbl/src/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/libs/luci-lib-luaneightbl/src/Makefile b/libs/luci-lib-luaneightbl/src/Makefile
new file mode 100644
index 000000000..f856d2fa2
--- /dev/null
+++ b/libs/luci-lib-luaneightbl/src/Makefile
@@ -0,0 +1,17 @@
+NEIGHTBL_CFLAGS = -std=gnu99
+NEIGHTBL_LDFLAGS = -llua -lm
+NEIGHTBL_OBJ = neightbl.o
+NEIGHTBL_LIB = neightbl.so
+
+%.o: %.c
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(LUA_CFLAGS) $(NEIGHTBL_CFLAGS) $(FPIC) -c -o $@ $<
+
+compile: $(NEIGHTBL_OBJ)
+ $(CC) $(LDFLAGS) -shared -o $(NEIGHTBL_LIB) $(NEIGHTBL_OBJ) $(NEIGHTBL_LDFLAGS)
+
+install: compile
+ mkdir -p $(DESTDIR)/usr/lib/lua
+ cp $(NEIGHTBL_LIB) $(DESTDIR)/usr/lib/lua/$(NEIGHTBL_LIB)
+
+clean:
+ rm -f *.o *.so