summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
Diffstat (limited to 'contrib')
-rw-r--r--contrib/uhttpd/patches/001-pass-env.patch4
-rw-r--r--contrib/uhttpd/patches/002-link-order.patch11
-rw-r--r--contrib/uhttpd/patches/series1
3 files changed, 14 insertions, 2 deletions
diff --git a/contrib/uhttpd/patches/001-pass-env.patch b/contrib/uhttpd/patches/001-pass-env.patch
index b69ff1765..ab607dbf2 100644
--- a/contrib/uhttpd/patches/001-pass-env.patch
+++ b/contrib/uhttpd/patches/001-pass-env.patch
@@ -1,7 +1,7 @@
--- a/uhttpd-cgi.c
+++ b/uhttpd-cgi.c
-@@ -204,7 +204,7 @@ void uh_cgi_request(struct client *cl, s
- (pi->stat.st_mode & S_IXOTH)
+@@ -216,7 +216,7 @@ void uh_cgi_request(
+ (pi->stat.st_mode & S_IXOTH)) || (ip != NULL)
) {
/* build environment */
- clearenv();
diff --git a/contrib/uhttpd/patches/002-link-order.patch b/contrib/uhttpd/patches/002-link-order.patch
new file mode 100644
index 000000000..8bdd3353e
--- /dev/null
+++ b/contrib/uhttpd/patches/002-link-order.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -70,7 +70,7 @@ endif
+ $(CC) $(CFLAGS) -c -o $@ $<
+
+ compile: $(OBJ) $(TLSLIB) $(LUALIB)
+- $(CC) -o uhttpd $(LDFLAGS) $(LIB) $(OBJ)
++ $(CC) -o uhttpd $(LDFLAGS) $(OBJ) $(LIB)
+
+ clean:
+ rm -f *.o *.so uhttpd
diff --git a/contrib/uhttpd/patches/series b/contrib/uhttpd/patches/series
index dc852df8b..8a1834ecf 100644
--- a/contrib/uhttpd/patches/series
+++ b/contrib/uhttpd/patches/series
@@ -1 +1,2 @@
001-pass-env.patch
+002-link-order.patch