summaryrefslogtreecommitdiffhomepage
path: root/contrib/uci/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/uci/Makefile')
-rw-r--r--contrib/uci/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/contrib/uci/Makefile b/contrib/uci/Makefile
index 04aa38b3a..b39278789 100644
--- a/contrib/uci/Makefile
+++ b/contrib/uci/Makefile
@@ -20,12 +20,10 @@ include ../../build/module.mk
$(UCI_FILE):
wget -O $@ "$(UCI_URL)" || rm -f $@
-$(UCI_PATCHDIR)/series:
- (cd $(UCI_PATCHDIR); ls *.patch | sort > series)
-
-$(UCI_DIR)/.prepared: $(UCI_PATCHDIR)/series $(UCI_FILE)
+$(UCI_DIR)/.prepared: $(UCI_FILE)
rm -rf $(UCI_DIR)
tar xvfz $(UCI_FILE)
+ (cd $(UCI_PATCHDIR); ls *.patch | sort > series) || true
[ -f "$(UCI_PATCHDIR)/series" ] && while read patch; do \
patch -d $(UCI_DIR) -p1 < $(UCI_PATCHDIR)/$$patch; \
done < $(UCI_PATCHDIR)/series || true