summaryrefslogtreecommitdiffhomepage
path: root/contrib/uci/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/uci/Makefile')
-rw-r--r--contrib/uci/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/contrib/uci/Makefile b/contrib/uci/Makefile
index 19625aa72..98e5ed439 100644
--- a/contrib/uci/Makefile
+++ b/contrib/uci/Makefile
@@ -23,9 +23,12 @@ $(UCI_FILE):
$(UCI_PATCHDIR)/series:
(cd $(UCI_PATCHDIR); ls *.patch | sort > series)
-$(UCI_DIR)/.prepared: $(UCI_FILE)
+$(UCI_DIR)/.prepared: $(UCI_PATCHDIR)/series $(UCI_FILE)
rm -rf $(UCI_DIR)
tar xvfz $(UCI_FILE)
+ while read patch; do \
+ patch -d $(UCI_DIR) -p1 < $(UCI_PATCHDIR)/$$patch; \
+ done < $(UCI_PATCHDIR)/series
touch $@
compile: $(UCI_DIR)/.prepared