summaryrefslogtreecommitdiffhomepage
path: root/contrib/package
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/package')
-rw-r--r--contrib/package/luci/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 3016adf738..06ec7c8022 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -106,6 +106,11 @@ endef
define Package/luci-core/install
$(call Package/luci/install/template,$(1),libs/core)
+ $(PKG_BUILD_DIR)/build/mkversion.sh $(1)/usr/lib/lua/luci/version.lua \
+ "OpenWrt Firmware" \
+ "$(OPENWRTVERSION)" \
+ "$(PKG_BRANCH)" \
+ "$(PKG_VERSION)"
endef
define Package/luci-core/config