summaryrefslogtreecommitdiffhomepage
path: root/contrib/package
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/package')
-rw-r--r--contrib/package/luci/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 044eca6ae..ec1a52a17 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -127,6 +127,9 @@ define Package/luci-core/config
config PACKAGE_luci-core_source
bool "Full Source"
+ config PACKAGE_luci-core_zipped
+ bool "Precompiled and compressed"
+
endchoice
endef
@@ -138,6 +141,10 @@ ifneq ($(CONFIG_PACKAGE_luci-core_stripped),)
LUA_TARGET:=strip
endif
+ifneq ($(CONFIG_PACKAGE_luci-core_zipped),)
+ LUA_TARGET:=gzip
+endif
+
### Libraries ###
define Package/luci-cbi