summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/px5g/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/package/px5g/Makefile')
-rw-r--r--contrib/package/px5g/Makefile39
1 files changed, 0 insertions, 39 deletions
diff --git a/contrib/package/px5g/Makefile b/contrib/package/px5g/Makefile
deleted file mode 100644
index 638f8c0c4..000000000
--- a/contrib/package/px5g/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-#
-# Copyright (C) 2010 Jo-Philipp Wich <xm@subsignal.org>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=px5g
-PKG_RELEASE:=1
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/px5g
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=Standalone X.509 certificate generator
-endef
-
-define Package/px5g/description
- Px5g is a tiny standalone X.509 certificate generator.
- It suitable to create key files and certificates in DER
- and PEM format for use with stunnel, uhttpd and others.
-endef
-
-define Build/Prepare
- mkdir -p $(PKG_BUILD_DIR)
- $(CP) ./src/* $(PKG_BUILD_DIR)/
-endef
-
-define Package/px5g/install
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/px5g $(1)/usr/sbin/px5g
-endef
-
-$(eval $(call BuildPackage,px5g))