summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/haserl-lua
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/package/haserl-lua')
-rw-r--r--contrib/package/haserl-lua/Makefile40
-rw-r--r--contrib/package/haserl-lua/patches/200-bytecode-header-luci12
2 files changed, 52 insertions, 0 deletions
diff --git a/contrib/package/haserl-lua/Makefile b/contrib/package/haserl-lua/Makefile
new file mode 100644
index 0000000000..ed4279bfdd
--- /dev/null
+++ b/contrib/package/haserl-lua/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=haserl-lua
+PKG_VERSION:=0.9.24
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://dev.leipzig.freifunk.net/svn/ff-luci/trunk/contrib/package-source/ \
+ http://firmware.freifunk-halle.net/ffluci/package-source/
+PKG_MD5SUM:=b004005594b84e35839b1d5c330f8e03
+
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/haserl-lua
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=A CGI wrapper to embed shell scripts in HTML documents
+ URL:=http://haserl.sourceforge.net/
+ DEPENDS:=+liblua-luci
+endef
+
+CONFIGURE_ARGS += \
+ --with-lua
+
+define Package/haserl-lua/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(STRIP) $(PKG_BUILD_DIR)/src/haserl
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/haserl $(1)/usr/bin/
+ echo "Replaces: haserl" >> $(1)/CONTROL/control
+ echo "Conflicts: haserl" >> $(1)/CONTROL/control
+endef
+
+$(eval $(call BuildPackage,haserl-lua))
diff --git a/contrib/package/haserl-lua/patches/200-bytecode-header-luci b/contrib/package/haserl-lua/patches/200-bytecode-header-luci
new file mode 100644
index 0000000000..c93fe7ae66
--- /dev/null
+++ b/contrib/package/haserl-lua/patches/200-bytecode-header-luci
@@ -0,0 +1,12 @@
+diff -ur haserl-0.9.23.orig/src/haserl_lualib.inc haserl-0.9.23/src/haserl_lualib.inc
+--- haserl-0.9.23.orig/src/haserl_lualib.inc 2008-04-05 16:40:35.000000000 +0200
++++ haserl-0.9.23/src/haserl_lualib.inc 2008-04-05 16:41:37.000000000 +0200
+@@ -1,7 +1,7 @@
+ /* This file was automatically generated from haserl_lualib.lua. DO NOT EDIT */
+
+ static const unsigned char haserl_lualib[] = {
+- 27, 76,117, 97, 81, 0, 1, 4, 4, 4, 8, 0, 19, 0, 0, 0,
++ 27, 76,117, 97, 81, 0, 1, 4, 4, 4, 8, 4, 19, 0, 0, 0,
+ 64,104, 97,115,101,114,108, 95,108,117, 97,108,105, 98, 46,108,
+ 117, 97, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 2, 3, 16,
+ 0, 0, 0, 10, 0, 0, 0, 74, 0, 0, 0,138, 0, 0, 0,135,