summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/freifunk-policyrouting/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/package/freifunk-policyrouting/Makefile')
-rw-r--r--contrib/package/freifunk-policyrouting/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/contrib/package/freifunk-policyrouting/Makefile b/contrib/package/freifunk-policyrouting/Makefile
new file mode 100644
index 000000000..7ff0b07d6
--- /dev/null
+++ b/contrib/package/freifunk-policyrouting/Makefile
@@ -0,0 +1,39 @@
+# Copyright (C) 2011 Manuel Munz <freifunk at somakoma de>
+# This is free software, licensed under the Apache 2.0 license.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=freifunk-policyrouting
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/freifunk-policyrouting
+ SECTION:=luci
+ CATEGORY:=LuCI
+ SUBMENU:=Freifunk
+ TITLE:=Freifunk policy routing addon
+ DEPENDS:=+firewall +ip
+endef
+
+define Package/freifunk-policyrouting/description
+ Allows you to send your own traffic via your own default gateway while sending traffic received from the mesh to a gateway in the mesh.
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/freifunk-policyrouting/install
+ $(CP) ./files/* $(1)/
+endef
+
+$(eval $(call BuildPackage,freifunk-policyrouting))