summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/freifunk-mapupdate/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/package/freifunk-mapupdate/Makefile')
-rw-r--r--contrib/package/freifunk-mapupdate/Makefile39
1 files changed, 0 insertions, 39 deletions
diff --git a/contrib/package/freifunk-mapupdate/Makefile b/contrib/package/freifunk-mapupdate/Makefile
deleted file mode 100644
index a9281ca20a..0000000000
--- a/contrib/package/freifunk-mapupdate/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright (C) 2011 Manuel Munz <freifunk at somakoma de>
-# This is free software, licensed under the Apache 2.0 license.
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=freifunk-mapupdate
-PKG_RELEASE:=1
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/freifunk-mapupdate
- SECTION:=luci
- CATEGORY:=LuCI
- SUBMENU:=9. Freifunk
- TITLE:=Update script for freifunkmap
- DEPENDS:=+olsrd-mod-nameservice
-endef
-
-define Package/freifunk-mapupdate/description
- This script updates the freifunkmap (also known as the global map, see http://map.berlin.freifunk.net) every hour. Config file is /etc/config/freifunk-mapupdate.
-endef
-
-define Build/Prepare
- mkdir -p $(PKG_BUILD_DIR)
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-endef
-
-define Package/freifunk-mapupdate/install
- $(CP) ./files/* $(1)/
-endef
-
-$(eval $(call BuildPackage,freifunk-mapupdate))