summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/freifunk-common
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/package/freifunk-common')
-rw-r--r--contrib/package/freifunk-common/Makefile2
-rwxr-xr-xcontrib/package/freifunk-common/files/usr/bin/neigh.sh3
2 files changed, 3 insertions, 2 deletions
diff --git a/contrib/package/freifunk-common/Makefile b/contrib/package/freifunk-common/Makefile
index c15f02dcf6..d9bbd994a1 100644
--- a/contrib/package/freifunk-common/Makefile
+++ b/contrib/package/freifunk-common/Makefile
@@ -4,7 +4,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=freifunk-common
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
diff --git a/contrib/package/freifunk-common/files/usr/bin/neigh.sh b/contrib/package/freifunk-common/files/usr/bin/neigh.sh
index b1dc01a77e..468ed7a3e0 100755
--- a/contrib/package/freifunk-common/files/usr/bin/neigh.sh
+++ b/contrib/package/freifunk-common/files/usr/bin/neigh.sh
@@ -66,7 +66,8 @@ VARS="$VARS neighborLinkQuality:NLQ linkCost:Cost remoteHostname:Host"
for HOST in '127.0.0.1' '::1';do
json_init
- json_load "$(echo /links|nc ${HOST} 9090)"
+ json_load "$( echo /links | nc $HOST 9090 | sed -n '/^[}{ ]/p' )" # remove header/non-json
+
if json_is_a links array;then
json_select links
for v in ${VARS};do