summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/community-profiles/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/package/community-profiles/Makefile')
-rw-r--r--contrib/package/community-profiles/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/contrib/package/community-profiles/Makefile b/contrib/package/community-profiles/Makefile
new file mode 100644
index 000000000..439b6837b
--- /dev/null
+++ b/contrib/package/community-profiles/Makefile
@@ -0,0 +1,39 @@
+# Copyright (C) 2011 Manuel Munz <freifunk at somakoma de>
+# This is free software, licensed under the Apache 2.0 license.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=community-profiles
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/community-profiles
+ SECTION:=luci
+ CATEGORY:=LuCI
+ SUBMENU:=Freifunk
+ TITLE:=Community profiles
+ DEPENDS:=freifunk-common
+endef
+
+define Package/community-profiles/description
+ These community profiles set defaults for various free network/freifunk communities and are used by wizards like ffwizard and meshwizard.
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/community-profiles/install
+ $(CP) ./files/* $(1)/
+endef
+
+$(eval $(call BuildPackage,community-profiles))