summaryrefslogtreecommitdiffhomepage
path: root/contrib/luaposix/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/luaposix/Makefile')
-rw-r--r--contrib/luaposix/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/contrib/luaposix/Makefile b/contrib/luaposix/Makefile
index ec832cc2d7..c357f5d2c2 100644
--- a/contrib/luaposix/Makefile
+++ b/contrib/luaposix/Makefile
@@ -34,8 +34,8 @@ $(LUAPOSIX_DIR)/.patched: $(LUAPOSIX_DIR)/.prepared $(LUAPOSIX_PATCHDIR)/series
compile: $(LUAPOSIX_DIR)/.patched
$(MAKE) -C $(LUAPOSIX_DIR) CC=$(CC) CFLAGS="$(CFLAGS) $(LUA_CFLAGS)" LDFLAGS="$(LDFLAGS) $(LUA_SHLIBS)" OS="$(OS)"
- mkdir -p dist/usr/lib/lua
- cp $(LUAPOSIX_DIR)/posix.so dist/usr/lib/lua/
+ mkdir -p dist$(LUA_LIBRARYDIR)
+ cp $(LUAPOSIX_DIR)/posix.so dist$(LUA_LIBRARYDIR)
luasource:
compile-all: compile