summaryrefslogtreecommitdiffhomepage
path: root/contrib/luaposix/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/luaposix/Makefile')
-rw-r--r--contrib/luaposix/Makefile20
1 files changed, 3 insertions, 17 deletions
diff --git a/contrib/luaposix/Makefile b/contrib/luaposix/Makefile
index a91138de8..70d3c9c4c 100644
--- a/contrib/luaposix/Makefile
+++ b/contrib/luaposix/Makefile
@@ -1,10 +1,10 @@
include ../../build/config.mk
include ../../build/gccconfig.mk
-LUAPOSIX_VERSION = 5.1.3
+LUAPOSIX_VERSION = 5.1.4
LUAPOSIX_SITE = http://dev.luci.freifunk-halle.net/sources/
LUAPOSIX_DIR = luaposix-$(LUAPOSIX_VERSION)
-LUAPOSIX_FILE = $(LUAPOSIX_DIR).tar.gz
+LUAPOSIX_FILE = lua-posix_5.1.4.orig.tar.gz
LUAPOSIX_URL = $(LUAPOSIX_SITE)/$(LUAPOSIX_FILE)
LUAPOSIX_PATCHDIR = patches
@@ -15,26 +15,12 @@ include ../../build/module.mk
$(LUAPOSIX_FILE):
wget -O $@ $(LUAPOSIX_URL) || rm -f $@
-$(LUAPOSIX_PATCHDIR)/series:
- (cd $(LUAPOSIX_PATCHDIR); ls *.patch | sort > series)
-
$(LUAPOSIX_DIR)/.prepared: $(LUAPOSIX_FILE)
rm -rf $(LUAPOSIX_DIR)
tar xvfz $(LUAPOSIX_FILE)
- ln -s ../$(LUAPOSIX_PATCHDIR) $(LUAPOSIX_DIR)/patches
- touch $@
-
-$(LUAPOSIX_DIR)/.patched: $(LUAPOSIX_DIR)/.prepared $(LUAPOSIX_PATCHDIR)/series
- (cd $(LUAPOSIX_DIR); \
- if [ -x "$$(which quilt 2>/dev/null)" ]; then \
- quilt push -a; \
- else \
- cat patches/*.patch | patch -p1; \
- fi; \
- )
touch $@
-compile: $(LUAPOSIX_DIR)/.patched
+compile: $(LUAPOSIX_DIR)/.prepared
$(MAKE) -C $(LUAPOSIX_DIR) CC=$(CC) CFLAGS="$(CFLAGS) $(LUA_CFLAGS)" LDFLAGS="$(LDFLAGS) $(LUA_SHLIBS)" OS="$(OS)"
mkdir -p dist$(LUA_LIBRARYDIR)
cp $(LUAPOSIX_DIR)/posix.so dist$(LUA_LIBRARYDIR)