summaryrefslogtreecommitdiffhomepage
path: root/contrib/axtls/patches/001-ld-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/axtls/patches/001-ld-fix.patch')
-rw-r--r--contrib/axtls/patches/001-ld-fix.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/contrib/axtls/patches/001-ld-fix.patch b/contrib/axtls/patches/001-ld-fix.patch
new file mode 100644
index 000000000..245600705
--- /dev/null
+++ b/contrib/axtls/patches/001-ld-fix.patch
@@ -0,0 +1,12 @@
+diff -urb axTLS.orig/ssl/Makefile axTLS/ssl/Makefile
+--- axTLS.orig/ssl/Makefile 2008-11-09 00:58:43.000000000 +0000
++++ axTLS/ssl/Makefile 2008-11-09 00:58:57.000000000 +0000
+@@ -96,7 +96,7 @@
+
+ $(TARGET2) : $(OBJ)
+ ifndef CONFIG_PLATFORM_CYGWIN
+- $(LD) $(LDFLAGS) $(LDSHARED) -Wl,-soname,$(LIBMAJOR) -o $(AXTLS_HOME)/$(STAGE)/$(LIBMINOR) $(CRYPTO_OBJ) $(OBJ)
++ $(LD) $(LDFLAGS) $(LDSHARED) -o $(AXTLS_HOME)/$(STAGE)/$(LIBMINOR) $(CRYPTO_OBJ) $(OBJ)
+ cd $(AXTLS_HOME)/$(STAGE); ln -sf $(LIBMINOR) $(LIBMAJOR); ln -sf $(LIBMAJOR) $(BASETARGET); cd -
+ else
+ $(LD) $(LDFLAGS) $(LDSHARED) -o $(AXTLS_HOME)/$(STAGE)/cygaxtls.dll \