summaryrefslogtreecommitdiffhomepage
path: root/collections
diff options
context:
space:
mode:
Diffstat (limited to 'collections')
-rw-r--r--collections/luci-light/Makefile17
-rw-r--r--collections/luci-ssl/Makefile17
-rw-r--r--collections/luci/Makefile19
3 files changed, 53 insertions, 0 deletions
diff --git a/collections/luci-light/Makefile b/collections/luci-light/Makefile
new file mode 100644
index 000000000..9eee97bf9
--- /dev/null
+++ b/collections/luci-light/Makefile
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2008-2014 The LuCI Team <luci@lists.subsignal.org>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TYPE:=col
+LUCI_BASENAME:=light
+
+LUCI_TITLE:=Minimum package set using only admin mini and the standard theme
+LUCI_DEPENDS:=+uhttpd +luci-mod-admin-mini +luci-theme-openwrt @BROKEN
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/collections/luci-ssl/Makefile b/collections/luci-ssl/Makefile
new file mode 100644
index 000000000..07c9c5068
--- /dev/null
+++ b/collections/luci-ssl/Makefile
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2008-2014 The LuCI Team <luci@lists.subsignal.org>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TYPE:=col
+LUCI_BASENAME:=ssl
+
+LUCI_TITLE:=Standard OpenWrt set with HTTPS support
+LUCI_DEPENDS:=+luci +libustream-polarssl +px5g
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/collections/luci/Makefile b/collections/luci/Makefile
new file mode 100644
index 000000000..dff5be67f
--- /dev/null
+++ b/collections/luci/Makefile
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2008-2014 The LuCI Team <luci@lists.subsignal.org>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TYPE:=col
+LUCI_BASENAME:=luci
+
+LUCI_TITLE:=Standard OpenWrt set including full admin with ppp support and the default Bootstrap theme
+LUCI_DEPENDS:= \
+ +uhttpd +uhttpd-mod-ubus +luci-mod-admin-full +luci-theme-bootstrap \
+ +luci-app-firewall +luci-proto-ppp +libiwinfo-lua +luci-lib-nixio
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature