summaryrefslogtreecommitdiffhomepage
path: root/collections/luci-ssl-openssl-nginx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'collections/luci-ssl-openssl-nginx/Makefile')
-rw-r--r--collections/luci-ssl-openssl-nginx/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/collections/luci-ssl-openssl-nginx/Makefile b/collections/luci-ssl-openssl-nginx/Makefile
new file mode 100644
index 000000000..f0e9b31c8
--- /dev/null
+++ b/collections/luci-ssl-openssl-nginx/Makefile
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2016 The LuCI Team
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TYPE:=col
+LUCI_BASENAME:=ssl-openssl
+
+LUCI_TITLE:=LuCI with HTTPS support (OpenSSL as SSL backend)
+LUCI_DESCRIPTION:=LuCI with OpenSSL as the SSL backend (libustream-openssl). \
+ OpenSSL cmd tools (openssl-util) are used by uhttpd for SSL key generation \
+ instead of the default px5g. (If px5g is installed, uhttpd will prefer that.)
+
+LUCI_DEPENDS:=+luci-nginx +libustream-openssl +openssl-util
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature