summaryrefslogtreecommitdiffhomepage
path: root/build
diff options
context:
space:
mode:
Diffstat (limited to 'build')
-rw-r--r--build/config.mk3
-rw-r--r--build/module.mk15
2 files changed, 18 insertions, 0 deletions
diff --git a/build/config.mk b/build/config.mk
new file mode 100644
index 000000000..af0b443d5
--- /dev/null
+++ b/build/config.mk
@@ -0,0 +1,3 @@
+LUAC = luac
+LUAC_OPTIONS = -s
+LUCI_INSTALLDIR = /usr/lib/lua/ffluci \ No newline at end of file
diff --git a/build/module.mk b/build/module.mk
new file mode 100644
index 000000000..286927436
--- /dev/null
+++ b/build/module.mk
@@ -0,0 +1,15 @@
+.PHONY: all compile source clean
+
+all: compile
+
+source:
+ mkdir -p dist$(LUCI_INSTALLDIR)
+ cp root dist -R
+ cp src dist$(LUCI_INSTALLDIR) -R
+ for i in $$(find dist -name .svn); do rm $$i -rf; done
+
+compile: source
+ for i in $$(find dist -name *.lua); do $(LUAC) $(LUAC_OPTIONS) -o $$i $$i; done
+
+clean:
+ rm dist -rf \ No newline at end of file