summaryrefslogtreecommitdiffhomepage
path: root/applications
diff options
context:
space:
mode:
Diffstat (limited to 'applications')
-rw-r--r--applications/luci-app-advanced-reboot/Makefile2
-rw-r--r--applications/luci-app-advanced-reboot/README.md2
-rw-r--r--applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-e4200v2.lua14
-rw-r--r--applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea3500.lua2
-rw-r--r--applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea4500.lua14
-rw-r--r--applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm10
-rw-r--r--applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/alternative_reboot.htm4
-rw-r--r--applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/power_off.htm4
8 files changed, 41 insertions, 11 deletions
diff --git a/applications/luci-app-advanced-reboot/Makefile b/applications/luci-app-advanced-reboot/Makefile
index 79197c43b..7be53efcb 100644
--- a/applications/luci-app-advanced-reboot/Makefile
+++ b/applications/luci-app-advanced-reboot/Makefile
@@ -12,7 +12,7 @@ LUCI_DESCRIPTION:=Provides Web UI (found under System/Advanced Reboot) to reboot
routers are listed at https://github.com/openwrt/luci/blob/master/applications/luci-app-advanced-reboot/README.md
LUCI_DEPENDS:=+luci-compat +luci-mod-admin-full
LUCI_PKGARCH:=all
-PKG_RELEASE:=54
+PKG_RELEASE:=55
include ../../luci.mk
diff --git a/applications/luci-app-advanced-reboot/README.md b/applications/luci-app-advanced-reboot/README.md
index 85c10fcc1..35b2d32d7 100644
--- a/applications/luci-app-advanced-reboot/README.md
+++ b/applications/luci-app-advanced-reboot/README.md
@@ -1,5 +1,7 @@
# Advanced Reboot Web UI (luci-app-advanced-reboot)
+[![HitCount](http://hits.dwyl.com/stangri/openwrt/luci-app-advanced-reboot.svg)](http://hits.dwyl.com/stangri/openwrt/luci-app-advanced-reboot)
+
## Description
This package allows you to reboot to an alternative partition on the supported (dual-partition) routers and to power off (power down) your OpenWrt device.
diff --git a/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-e4200v2.lua b/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-e4200v2.lua
new file mode 100644
index 000000000..50c4970ed
--- /dev/null
+++ b/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-e4200v2.lua
@@ -0,0 +1,14 @@
+return {
+ vendorName = "Linksys",
+ deviceName = "E4200v2",
+ boardNames = { "linksys-e4200v2", "linksys,e4200v2" },
+ partition1MTD = "mtd3",
+ partition2MTD = "mtd5",
+ labelOffset = 32,
+ bootEnv1 = "boot_part",
+ bootEnv1Partition1Value = 1,
+ bootEnv1Partition2Value = 2,
+ bootEnv2 = "bootcmd",
+ bootEnv2Partition1Value = "run nandboot",
+ bootEnv2Partition2Value = "run altnandboot"
+}
diff --git a/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea3500.lua b/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea3500.lua
index 553788fd5..2b72cd4b7 100644
--- a/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea3500.lua
+++ b/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea3500.lua
@@ -1,7 +1,7 @@
return {
vendorName = "Linksys",
deviceName = "EA3500",
- boardNames = { "linksys-audi", "linksys,audi" },
+ boardNames = { "linksys-audi", "linksys,audi", "linksys-ea3500", "linksys,ea3500" },
partition1MTD = "mtd3",
partition2MTD = "mtd5",
labelOffset = 32,
diff --git a/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea4500.lua b/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea4500.lua
new file mode 100644
index 000000000..10f53d1d7
--- /dev/null
+++ b/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea4500.lua
@@ -0,0 +1,14 @@
+return {
+ vendorName = "Linksys",
+ deviceName = "EA4500",
+ boardNames = { "linksys-e4500", "linksys,e4500" },
+ partition1MTD = "mtd3",
+ partition2MTD = "mtd5",
+ labelOffset = 32,
+ bootEnv1 = "boot_part",
+ bootEnv1Partition1Value = 1,
+ bootEnv1Partition2Value = 2,
+ bootEnv2 = "bootcmd",
+ bootEnv2Partition1Value = "run nandboot",
+ bootEnv2Partition2Value = "run altnandboot"
+}
diff --git a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm
index 49985b32c..a28418cc5 100644
--- a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm
+++ b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm
@@ -42,12 +42,12 @@
<%- if bev1p1 == current_partition then -%>
<form method="post" action="<%=url('admin/system/advanced_reboot/reboot')%>">
<input type="hidden" name="token" value="<%=token%>" />
- <input id="reboot-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Reboot to current partition%>" />
+ <input id="reboot-button" type="submit" class="btn cbi-button cbi-button-apply important" value="<%:Reboot to current partition%>" />
</form>
<%- else -%>
<form method="post" action="<%=url('admin/system/advanced_reboot/alternative_reboot')%>">
<input type="hidden" name="token" value="<%=token%>" />
- <input id="altreboot-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Reboot to alternative partition...%>" />
+ <input id="altreboot-button" type="submit" class="btn cbi-button cbi-button-apply important" value="<%:Reboot to alternative partition...%>" />
</form>
<%- end -%>
</div>
@@ -66,12 +66,12 @@
<%- if bev1p2 == current_partition then -%>
<form method="post" action="<%=url('admin/system/advanced_reboot/reboot')%>">
<input type="hidden" name="token" value="<%=token%>" />
- <input id="reboot-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Reboot to current partition%>" />
+ <input id="reboot-button" type="submit" class="btn cbi-button cbi-button-apply important" value="<%:Reboot to current partition%>" />
</form>
<%- else -%>
<form method="post" action="<%=url('admin/system/advanced_reboot/alternative_reboot')%>">
<input type="hidden" name="token" value="<%=token%>" />
- <input id="altreboot-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Reboot to alternative partition...%>" />
+ <input id="altreboot-button" type="submit" class="btn cbi-button cbi-button-apply important" value="<%:Reboot to alternative partition...%>" />
</form>
<%- end -%>
</div>
@@ -91,7 +91,7 @@
<%- if nixio.fs.access("/sbin/poweroff") then -%>
<form method="post" action="<%=url('admin/system/advanced_reboot/power_off')%>">
<input type="hidden" name="token" value="<%=token%>" />
- <input id="poweroff-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Perform power off...%>" />
+ <input id="poweroff-button" type="submit" class="btn cbi-button cbi-button-apply important" value="<%:Perform power off...%>" />
</form>
<%- else -%>
<p class="alert-message warning"><%:Warning: This system does not support powering off!%></p>
diff --git a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/alternative_reboot.htm b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/alternative_reboot.htm
index db1102062..b81aaf455 100644
--- a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/alternative_reboot.htm
+++ b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/alternative_reboot.htm
@@ -21,8 +21,8 @@
<form class="inline" action="<%=REQUEST_URI%>" method="post">
<input type="hidden" name="token" value="<%=token%>" />
<input type="hidden" name="step" value="2" />
- <input class="cbi-button cbi-button-reset important" name="cancel" type="submit" value="<%:Cancel%>" />
- <input class="cbi-button cbi-button-apply important" type="submit" value="<%:Proceed%>" />
+ <input class="btn cbi-button cbi-button-reset important" name="cancel" type="submit" value="<%:Cancel%>" />
+ <input class="btn cbi-button cbi-button-apply important" type="submit" value="<%:Proceed%>" />
</form>
</div>
diff --git a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/power_off.htm b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/power_off.htm
index 1acf01b99..56200a4c1 100644
--- a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/power_off.htm
+++ b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/power_off.htm
@@ -17,8 +17,8 @@
<form class="inline" action="<%=REQUEST_URI%>" method="post">
<input type="hidden" name="token" value="<%=token%>" />
<input type="hidden" name="step" value="2" />
- <input class="cbi-button cbi-button-reset important" name="cancel" type="submit" value="<%:Cancel%>" />
- <input class="cbi-button cbi-button-apply important" type="submit" value="<%:Proceed%>" />
+ <input class="btn cbi-button cbi-button-reset important" name="cancel" type="submit" value="<%:Cancel%>" />
+ <input class="btn cbi-button cbi-button-apply important" type="submit" value="<%:Proceed%>" />
</form>
</div>