summaryrefslogtreecommitdiffhomepage
path: root/applications
diff options
context:
space:
mode:
Diffstat (limited to 'applications')
-rw-r--r--applications/luci-app-advanced-reboot/Makefile2
-rw-r--r--applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/dlink-fgs1210-28.json14
-rw-r--r--applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-ea8100v1.json14
-rw-r--r--applications/luci-app-pbr/Makefile2
-rwxr-xr-xapplications/luci-app-pbr/root/usr/libexec/rpcd/luci.pbr32
5 files changed, 44 insertions, 20 deletions
diff --git a/applications/luci-app-advanced-reboot/Makefile b/applications/luci-app-advanced-reboot/Makefile
index 11697f3b0d..172cb9c96c 100644
--- a/applications/luci-app-advanced-reboot/Makefile
+++ b/applications/luci-app-advanced-reboot/Makefile
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
-PKG_VERSION:=1.0.1-9
+PKG_VERSION:=1.0.1-r10
LUCI_TITLE:=Advanced Linksys Reboot Web UI
LUCI_URL:=https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
diff --git a/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/dlink-fgs1210-28.json b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/dlink-fgs1210-28.json
new file mode 100644
index 0000000000..d5e468215a
--- /dev/null
+++ b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/dlink-fgs1210-28.json
@@ -0,0 +1,14 @@
+{
+ "vendorName": "D-Link",
+ "deviceName": "DGS-1210-28",
+ "boardNames": [ "d-link,dgs-1210-28" ],
+ "partition1MTD": "mtd5",
+ "partition2MTD": "mtd9",
+ "labelOffset": null,
+ "bootEnv1": "bootcmd",
+ "bootEnv1Partition1Value": null,
+ "bootEnv1Partition2Value": "run addargs\\; bootm 0xb4e80000",
+ "bootEnv2": "image",
+ "bootEnv2Partition1Value": null,
+ "bootEnv2Partition2Value": "/dev/mtdblock7"
+}
diff --git a/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-ea8100v1.json b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-ea8100v1.json
new file mode 100644
index 0000000000..e50941921d
--- /dev/null
+++ b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-ea8100v1.json
@@ -0,0 +1,14 @@
+{
+ "vendorName": "Linksys",
+ "deviceName": "EA8100v1",
+ "boardNames": [ "linksys,ea8100-v1" ],
+ "partition1MTD": "mtd5",
+ "partition2MTD": "mtd7",
+ "labelOffset": 32,
+ "bootEnv1": "boot_part",
+ "bootEnv1Partition1Value": 1,
+ "bootEnv1Partition2Value": 2,
+ "bootEnv2": null,
+ "bootEnv2Partition1Value": null,
+ "bootEnv2Partition2Value": null
+}
diff --git a/applications/luci-app-pbr/Makefile b/applications/luci-app-pbr/Makefile
index 6eee45f9bb..7a1c510883 100644
--- a/applications/luci-app-pbr/Makefile
+++ b/applications/luci-app-pbr/Makefile
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
-PKG_VERSION:=1.1.4-5
+PKG_VERSION:=1.1.4-r7
LUCI_TITLE:=Policy Based Routing Service Web UI
LUCI_DESCRIPTION:=Provides Web UI for Policy Based Routing Service.
diff --git a/applications/luci-app-pbr/root/usr/libexec/rpcd/luci.pbr b/applications/luci-app-pbr/root/usr/libexec/rpcd/luci.pbr
index 8412b0c4bc..8cd02c58f4 100755
--- a/applications/luci-app-pbr/root/usr/libexec/rpcd/luci.pbr
+++ b/applications/luci-app-pbr/root/usr/libexec/rpcd/luci.pbr
@@ -69,10 +69,7 @@ get_init_status() {
local name
name="$(basename "$1")"
name="${name:-$packageName}"
- local version gateways warnings errors
- [ -z "$version" ] && version="$(opkg_get_version "${name}")"
- [ -z "$version" ] && version="$(opkg_get_version "${name}-iptables")"
- [ -z "$version" ] && version="$(opkg_get_version "${name}-netifd")"
+ local gateways warnings errors
gateways="$(ubus_get_status gateways | sed "s|\\\n|<br />|g;s|\(\\\033[^<]*\)|✓|g;")"
warnings="$(ubus_get_status warnings)"
errors="$(ubus_get_status errors)"
@@ -99,7 +96,7 @@ get_init_status() {
else
json_add_boolean 'running_nft_file' '0'
fi
- json_add_string 'version' "$version"
+ json_add_string 'version' "$PKG_VERSION"
json_add_string 'gateways' "$gateways"
json_add_array 'errors'
if [ -n "$errors" ]; then
@@ -138,12 +135,12 @@ EOF
$(echo "$warnings" | tr \# \\n)
EOF
fi
- if is_greater "$(opkg_get_version "${name}")" "$(opkg_get_version "luci-app-${name}")"; then
- json_add_object
- json_add_string 'id' 'warningOutdatedWebUIApp'
- json_add_string 'extra' "$(opkg_get_version "luci-app-${name}")"
- json_close_object
- fi
+# if is_greater "$(opkg_get_version "${name}")" "$(opkg_get_version "luci-app-${name}")"; then
+# json_add_object
+# json_add_string 'id' 'warningOutdatedWebUIApp'
+# json_add_string 'extra' "$(opkg_get_version "luci-app-${name}")"
+# json_close_object
+# fi
json_close_array
json_close_object
json_dump
@@ -209,12 +206,11 @@ get_gateways() {
}
get_supported_interfaces() {
- _find_firewall_wan_zone() { [ "$(uci_get 'firewall' "$1" 'name')" = "wan" ] && firewallWanZone="$1"; }
- _build_ifaces_all() { ifacesAll="${ifacesAll}${1} "; }
_build_ifaces_supported() { is_supported_interface "$1" && ! str_contains "$ifacesSupported" "$1" && ifacesSupported="${ifacesSupported}${1} "; }
+ _find_firewall_wan_zone() { [ "$(uci_get 'firewall' "$1" 'name')" = "wan" ] && firewallWanZone="$1"; }
local i
local firewallWanZone
- local ifacesAll ifacesSupported
+ local ifacesSupported
local webui_show_ignore_target
local ignored_interface supported_interface
local wanIface4 wanIface6
@@ -222,11 +218,11 @@ get_supported_interfaces() {
config_get_bool webui_show_ignore_target 'config' 'webui_show_ignore_target' '0'
config_get ignored_interface 'config' 'ignored_interface'
config_get supported_interface 'config' 'supported_interface'
+ config_get procd_wan_interface 'config' 'procd_wan_interface' 'wan'
+ config_get procd_wan6_interface 'config' 'procd_wan6_interface' 'wan6'
local i
- config_load 'network'
- config_foreach _build_ifaces_all 'interface'
- pbr_find_iface wanIface4 'wan'
- pbr_find_iface wanIface6 'wan6'
+ wanIface4="$procd_wan_interface"
+ wanIface6="$procd_wan6_interface"
config_load 'firewall'
config_foreach _find_firewall_wan_zone 'zone'
for i in $(uci_get 'firewall' "$firewallWanZone" 'network'); do