summaryrefslogtreecommitdiffhomepage
path: root/applications
diff options
context:
space:
mode:
Diffstat (limited to 'applications')
-rw-r--r--applications/luci-app-bcp38/Makefile2
-rw-r--r--applications/luci-app-bcp38/htdocs/luci-static/resources/view/bcp38/form.js50
-rw-r--r--applications/luci-app-bcp38/luasrc/model/cbi/bcp38.lua68
-rw-r--r--applications/luci-app-bcp38/root/usr/share/luci/menu.d/luci-app-bcp38.json5
-rw-r--r--applications/luci-app-dump1090/po/ru/dump1090.po64
-rw-r--r--applications/luci-app-https-dns-proxy/Makefile4
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns-family.lua8
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns.lua8
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua2
-rw-r--r--applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot16
-rw-r--r--applications/luci-app-ttyd/po/ru/ttyd.po54
11 files changed, 140 insertions, 141 deletions
diff --git a/applications/luci-app-bcp38/Makefile b/applications/luci-app-bcp38/Makefile
index a8a6e7402e..b1aeaf4bf4 100644
--- a/applications/luci-app-bcp38/Makefile
+++ b/applications/luci-app-bcp38/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=BCP38 LuCI interface
-LUCI_DEPENDS:=+luci-compat +luci-mod-admin-full +bcp38
+LUCI_DEPENDS:=+luci-base +bcp38
PKG_MAINTAINER:=Toke Høiland-Jørgensen <toke@toke.dk>
PKG_LICENSE:=Apache-2.0
diff --git a/applications/luci-app-bcp38/htdocs/luci-static/resources/view/bcp38/form.js b/applications/luci-app-bcp38/htdocs/luci-static/resources/view/bcp38/form.js
new file mode 100644
index 0000000000..9e14047698
--- /dev/null
+++ b/applications/luci-app-bcp38/htdocs/luci-static/resources/view/bcp38/form.js
@@ -0,0 +1,50 @@
+'use strict';
+'require view';
+'require form';
+'require tools.widgets as widgets';
+
+return view.extend({
+ render: function() {
+ var m, s, o;
+
+ m = new form.Map('bcp38', _('BCP38'),
+ _('This function blocks packets with private address destinations ' +
+ 'from going out onto the internet as per ' +
+ '<a href="http://tools.ietf.org/html/bcp38">BCP 38</a>. ' +
+ 'For IPv6, only source specific default routes are installed, so ' +
+ 'no BCP38 firewall routes are needed.'));
+
+
+ s = m.section(form.TypedSection, 'bcp38', _('BCP38 config'));
+ s.anonymous = true;
+
+ o = s.option(form.Flag, 'enabled', _('Enable'));
+ o.default = '0';
+ o.rmempty = false;
+
+ o = s.option(form.Flag, 'detect_upstream', _('Auto-detect upstream IP'),
+ _('Attempt to automatically detect if the upstream IP ' +
+ 'will be blocked by the configuration, and add an exception if it will. ' +
+ 'If this does not work correctly, you can add exceptions manually below.'));
+ o.rmempty = false;
+
+ o = s.option(widgets.DeviceSelect, 'interface', _('Interface name'),
+ _('Interface to apply the blocking to should be the upstream WAN interface).'));
+ o.modalonly = true;
+ o.noaliases = true;
+ o.multiple = false;
+ o.rmempty = false;
+
+ o = s.option(form.DynamicList, 'match', _('Blocked IP ranges'));
+ o.datatype = 'ip4addr';
+
+ o = s.option(form.DynamicList, 'nomatch', _('Allowed IP ranges'),
+ _('Takes precedence over blocked ranges. ' +
+ 'Use to whitelist your upstream network if you\'re behind a double NAT ' +
+ 'and the auto-detection doesn\'t work.'));
+ o.datatype = 'ip4addr';
+
+ return m.render();
+ },
+});
+
diff --git a/applications/luci-app-bcp38/luasrc/model/cbi/bcp38.lua b/applications/luci-app-bcp38/luasrc/model/cbi/bcp38.lua
deleted file mode 100644
index 731c3350eb..0000000000
--- a/applications/luci-app-bcp38/luasrc/model/cbi/bcp38.lua
+++ /dev/null
@@ -1,68 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2014 Toke Høiland-Jørgensen <toke@toke.dk>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-]]--
-
-local wa = require "luci.tools.webadmin"
-local net = require "luci.model.network".init()
-local sys = require "luci.sys"
-local ifaces = sys.net:devices()
-
-m = Map("bcp38", translate("BCP38"),
- translate("This function blocks packets with private address destinations " ..
- "from going out onto the internet as per " ..
- "<a href=\"http://tools.ietf.org/html/bcp38\">BCP 38</a>. " ..
- "For IPv6, only source specific default routes are installed, so " ..
- "no BCP38 firewall routes are needed."))
-
-s = m:section(TypedSection, "bcp38", translate("BCP38 config"))
-s.anonymous = true
--- BASIC
-e = s:option(Flag, "enabled", translate("Enable"))
-e.rmempty = false
-
-a = s:option(Flag, "detect_upstream", translate("Auto-detect upstream IP"),
- translate("Attempt to automatically detect if the upstream IP " ..
- "will be blocked by the configuration, and add an exception if it will. " ..
- "If this does not work correctly, you can add exceptions manually below."))
-a.rmempty = false
-
-n = s:option(ListValue, "interface", translate("Interface name"), translate("Interface to apply the blocking to " ..
- "(should be the upstream WAN interface)."))
-
-for _, iface in ipairs(ifaces) do
- if not (iface == "lo" or iface:match("^ifb.*")) then
- local nets = net:get_interface(iface)
- nets = nets and nets:get_networks() or {}
- for k, v in pairs(nets) do
- nets[k] = nets[k].sid
- end
- nets = table.concat(nets, ",")
- n:value(iface, ((#nets > 0) and "%s (%s)" % {iface, nets} or iface))
- end
-end
-n.rmempty = false
-
-ma = s:option(DynamicList, "match",
- translate("Blocked IP ranges"))
-
-ma.datatype = "ip4addr"
-
-nm = s:option(DynamicList, "nomatch",
- translate("Allowed IP ranges"), translate("Takes precedence over blocked ranges. "..
- "Use to whitelist your upstream network if you're behind a double NAT " ..
- "and the auto-detection doesn't work."))
-
-nm.datatype = "ip4addr"
-
-
-return m
diff --git a/applications/luci-app-bcp38/root/usr/share/luci/menu.d/luci-app-bcp38.json b/applications/luci-app-bcp38/root/usr/share/luci/menu.d/luci-app-bcp38.json
index e83ad69b3c..2a41ed6c66 100644
--- a/applications/luci-app-bcp38/root/usr/share/luci/menu.d/luci-app-bcp38.json
+++ b/applications/luci-app-bcp38/root/usr/share/luci/menu.d/luci-app-bcp38.json
@@ -3,9 +3,8 @@
"title": "BCP38",
"order": 50,
"action": {
- "type": "cbi",
- "path": "bcp38",
- "post": { "cbi.submit": true }
+ "type": "view",
+ "path": "bcp38/form"
},
"depends": {
"acl": [ "luci-app-bcp38" ]
diff --git a/applications/luci-app-dump1090/po/ru/dump1090.po b/applications/luci-app-dump1090/po/ru/dump1090.po
index 29b8a7b350..a4777c78ff 100644
--- a/applications/luci-app-dump1090/po/ru/dump1090.po
+++ b/applications/luci-app-dump1090/po/ru/dump1090.po
@@ -1,15 +1,15 @@
msgid ""
msgstr ""
-"PO-Revision-Date: 2021-10-30 16:38+0000\n"
-"Last-Translator: masta0f1eave <lomskoff.dima@gmail.com>\n"
+"PO-Revision-Date: 2023-02-11 09:07+0000\n"
+"Last-Translator: st7105 <st7105@gmail.com>\n"
"Language-Team: Russian <https://hosted.weblate.org/projects/openwrt/"
"luciapplicationsdump1090/ru/>\n"
"Language: ru\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
-"Plural-Forms: nplurals=3; plural=n%10==1 && n%100!=11 ? 0 : n%10>=2 && n"
-"%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2;\n"
-"X-Generator: Weblate 4.9-dev\n"
+"Plural-Forms: nplurals=3; plural=n%10==1 && n%100!=11 ? 0 : n%10>=2 && "
+"n%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2;\n"
+"X-Generator: Weblate 4.16-dev\n"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:123
msgid "Absolute maximum range for position decoding"
@@ -122,7 +122,7 @@ msgstr "Измерить уровень шума"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:139
msgid "More CPU for more messages"
-msgstr ""
+msgstr "Больше процессора для большего количества сообщений"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:176
msgid "Periodically write json output to a directory"
@@ -130,19 +130,19 @@ msgstr "Периодически записывать вывод json в кат
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:145
msgid "Print stats at exit"
-msgstr ""
+msgstr "Печать статистики при выходе"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:19
msgid "RTL device index"
-msgstr ""
+msgstr "Индекс RTL-устройства"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:115
msgid "Reference/receiver latitude for surface posn"
-msgstr ""
+msgstr "Опорная/приемная широта для положения на поверхности"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:119
msgid "Reference/receiver longitude for surface posn"
-msgstr ""
+msgstr "Опорная/приемная долгота для положения на поверхности"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:16
msgid "Respawn"
@@ -150,90 +150,94 @@ msgstr "Перезапуск при сбое"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:38
msgid "Sample format for data file"
-msgstr ""
+msgstr "Образец формата файла данных"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:168
msgid "Set receiver error in parts per million"
-msgstr ""
+msgstr "Погрешность настройки приемника в частях на миллион"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:151
msgid "Show and reset stats every seconds"
-msgstr ""
+msgstr "Показывать и сбрасывать статистику каждые несколько секунд"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:155
msgid "Show only ICAO addresses"
-msgstr ""
+msgstr "Показать только адреса ICAO"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:47
msgid "Show only messages hex values"
-msgstr ""
+msgstr "Показать только шестнадцатеричные значения сообщений"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:161
msgid "Strip IQ file removing samples"
-msgstr ""
+msgstr "Удаление образцов из файла IQ"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:77
msgid "TCP BaseStation output listen port"
-msgstr ""
+msgstr "Порт прослушивания выходного сигнала TCP BaseStation"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:81
msgid "TCP Beast input listen port"
-msgstr ""
+msgstr "Входной порт прослушивания TCP Beast"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:85
msgid "TCP Beast output listen port"
-msgstr ""
+msgstr "Порт прослушивания выходного сигнала TCP Beast"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:105
msgid "TCP buffer size 64Kb * (2^n)"
-msgstr ""
+msgstr "Размер буфера TCP 64Kb * (2^n)"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:101
msgid "TCP heartbeat rate in seconds"
-msgstr ""
+msgstr "Частота пульса TCP в секундах"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:69
msgid "TCP raw input listen port"
-msgstr ""
+msgstr "Порт прослушивания необработанного входного сигнала TCP"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:55
msgid "TCP raw output in Beast binary format"
-msgstr ""
+msgstr "Необработанный вывод TCP в двоичном формате Beast"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:73
msgid "TCP raw output listen port"
-msgstr ""
+msgstr "Порт прослушивания необработанного вывода TCP"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:97
msgid "TCP raw output memory flush rate in seconds"
-msgstr ""
+msgstr "Скорость очистки выходной памяти TCP в секунду"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:93
msgid "TCP raw output minimum size"
-msgstr ""
+msgstr "Минимальный размер необработанного вывода TCP"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:158
msgid "Use metric units"
-msgstr ""
+msgstr "Использование метрических единиц"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:190
msgid "Use the 2.4MHz demodulator"
-msgstr ""
+msgstr "Использование демодулятора 2,4 МГц"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:44
msgid "When reading from a file play back in realtime, not at max speed"
msgstr ""
+"При чтении из файла воспроизведение в реальном времени, а не на максимальной "
+"скорости"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:180
msgid "Write json output every t seconds"
-msgstr ""
+msgstr "Запись вывода json каждые t секунд"
#: applications/luci-app-dump1090/root/usr/share/luci/menu.d/luci-app-dump1090.json:3
msgid "dump1090"
-msgstr ""
+msgstr "dump1090"
#: applications/luci-app-dump1090/luasrc/model/cbi/dump1090.lua:4
msgid ""
"dump1090 is a Mode S decoder specifically designed for RTLSDR devices, here "
"you can configure the settings."
msgstr ""
+"dump1090 - это декодер Mode S, специально разработанный для устройств "
+"RTLSDR, здесь вы можете настроить параметры."
diff --git a/applications/luci-app-https-dns-proxy/Makefile b/applications/luci-app-https-dns-proxy/Makefile
index ddaee4f49d..e2e0a49c9d 100644
--- a/applications/luci-app-https-dns-proxy/Makefile
+++ b/applications/luci-app-https-dns-proxy/Makefile
@@ -5,11 +5,11 @@ include $(TOPDIR)/rules.mk
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
-PKG_VERSION:=2021-11-22-7
+PKG_VERSION:=2022-10-15-11
LUCI_TITLE:=DNS Over HTTPS Proxy Web UI
LUCI_DESCRIPTION:=Provides Web UI for DNS Over HTTPS Proxy
-LUCI_DEPENDS:=+luci-compat +luci-mod-admin-full +https-dns-proxy
+LUCI_DEPENDS:=+luci-compat +luci-base +https-dns-proxy
LUCI_PKGARCH:=all
include ../../luci.mk
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns-family.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns-family.lua
new file mode 100644
index 0000000000..0c2a4d8156
--- /dev/null
+++ b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns-family.lua
@@ -0,0 +1,8 @@
+return {
+ name = "dns-family.adguard.com",
+ label = _("AdGuard (Family Protection)"),
+ resolver_url = "https://dns-family.adguard.com/dns-query",
+ bootstrap_dns = "176.103.130.132,176.103.130.134",
+ help_link = "https://adguard.com/en/adguard-dns/overview.html",
+ help_link_text = "AdGuard.com"
+}
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns.lua
new file mode 100644
index 0000000000..79db2029dd
--- /dev/null
+++ b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns.lua
@@ -0,0 +1,8 @@
+return {
+ name = "dns.adguard.com",
+ label = _("AdGuard (Standard)"),
+ resolver_url = "https://dns.adguard.com/dns-query",
+ bootstrap_dns = "176.103.130.130,176.103.130.131",
+ help_link = "https://adguard.com/en/adguard-dns/overview.html",
+ help_link_text = "AdGuard.com"
+}
diff --git a/applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua b/applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua
index 1d7bcb0e8d..8396f46698 100644
--- a/applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua
+++ b/applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua
@@ -120,7 +120,7 @@ if packageStatusCode ~= -1 then
end
c = m:section(NamedSection, "config", "https-dns-proxy", translate("Configuration"))
-d1 = c:option(ListValue, "update_dnsmasq_config", translate("Update DNSMASQ Config on Start/Stop"), translatef("If update option is selected, the 'DNS forwardings' section of %sDHCP and DNS%s will be automatically updated to use selected DoH providers (%smore information%s).", "<a href=\"" .. dispatcher.build_url("admin/network/dhcp") .. "\">", "</a>", "<a href=\"" .. readmeURL .. "#default-settings" .. "\" target=\"_blank\">", "</a>"))
+d1 = c:option(ListValue, "dnsmasq_config_update", translate("Update DNSMASQ Config on Start/Stop"), translatef("If update option is selected, the 'DNS forwardings' section of %sDHCP and DNS%s will be automatically updated to use selected DoH providers (%smore information%s).", "<a href=\"" .. dispatcher.build_url("admin/network/dhcp") .. "\">", "</a>", "<a href=\"" .. readmeURL .. "#default-settings" .. "\" target=\"_blank\">", "</a>"))
d1:value('*', translate("Update all configs"))
local dnsmasq_num = 0
uci:foreach("dhcp", "dnsmasq", function(s)
diff --git a/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot b/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot
index b4c2232910..62da3aa641 100644
--- a/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot
+++ b/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot
@@ -13,15 +13,11 @@ msgstr ""
msgid "360 Secure DNS - CN"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/io.adguard-dns.dns-family.lua:3
+#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns-family.lua:3
msgid "AdGuard (Family Protection)"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/io.adguard-dns.dns-nonfiltering.lua:3
-msgid "AdGuard (Non-filtering)"
-msgstr ""
-
-#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/io.adguard-dns.dns.lua:3
+#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns.lua:3
msgid "AdGuard (Standard)"
msgstr ""
@@ -169,17 +165,14 @@ msgstr ""
msgid "Configuration"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.controld.freedns.malware-ads-social.lua:3
#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.controld.freedns.p3.lua:3
msgid "ControlD (Block Malware + Ads + Social)"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.controld.freedns.malware-ads.lua:3
#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.controld.freedns.p2.lua:3
msgid "ControlD (Block Malware + Ads)"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.controld.freedns.malware.lua:3
#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.controld.freedns.p1.lua:3
msgid "ControlD (Block Malware)"
msgstr ""
@@ -189,7 +182,6 @@ msgid "ControlD (Family)"
msgstr ""
#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.controld.freedns.p0.lua:3
-#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.controld.freedns.unfiltered.lua:3
msgid "ControlD (Unfiltered)"
msgstr ""
@@ -458,10 +450,6 @@ msgstr ""
msgid "Tiarap Public DNS - SG"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/cn.edu.tsinghua.tuna.dns.lua:3
-msgid "Tsinghua University Secure DNS - CN"
-msgstr ""
-
#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:65
msgid "Unknown Provider"
msgstr ""
diff --git a/applications/luci-app-ttyd/po/ru/ttyd.po b/applications/luci-app-ttyd/po/ru/ttyd.po
index cdd1d8cd7b..4db3cfb1b8 100644
--- a/applications/luci-app-ttyd/po/ru/ttyd.po
+++ b/applications/luci-app-ttyd/po/ru/ttyd.po
@@ -1,15 +1,15 @@
msgid ""
msgstr ""
-"PO-Revision-Date: 2022-07-25 17:15+0000\n"
-"Last-Translator: Alexey Carterline <consulive@live.com>\n"
+"PO-Revision-Date: 2023-02-11 09:07+0000\n"
+"Last-Translator: st7105 <st7105@gmail.com>\n"
"Language-Team: Russian <https://hosted.weblate.org/projects/openwrt/"
"luciapplicationsttyd/ru/>\n"
"Language: ru\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
-"Plural-Forms: nplurals=3; plural=n%10==1 && n%100!=11 ? 0 : n%10>=2 && n"
-"%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2;\n"
-"X-Generator: Weblate 4.14-dev\n"
+"Plural-Forms: nplurals=3; plural=n%10==1 && n%100!=11 ? 0 : n%10>=2 && "
+"n%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2;\n"
+"X-Generator: Weblate 4.16-dev\n"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:56
msgid "Accept only one client and exit on disconnection"
@@ -28,6 +28,8 @@ msgid ""
"Allow client to send command line arguments in URL (eg: http://"
"localhost:7681?arg=foo&arg=bar)"
msgstr ""
+"Разрешить клиенту отправлять аргументы командной строки в URL (например: "
+"http://localhost:7681?arg=foo&arg=bar)"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:50
msgid "Check origin"
@@ -51,11 +53,11 @@ msgstr "Учетные данные"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:28
msgid "Credential for Basic Authentication"
-msgstr ""
+msgstr "Учетные данные для базовой аутентификации"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:58
msgid "Custom index.html path"
-msgstr ""
+msgstr "Пользовательский путь к index.html"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:73
msgid "Debug"
@@ -63,11 +65,11 @@ msgstr "Отладка"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:42
msgid "Do not allow clients to write to the TTY"
-msgstr ""
+msgstr "Не разрешайте клиентам писать на TTY"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:50
msgid "Do not allow websocket connection from different origin"
-msgstr ""
+msgstr "Не разрешать подключение к вебсокету из другого источника"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:17
msgid "Enable"
@@ -91,11 +93,11 @@ msgstr "Предоставить UCI доступ для luci-app-ttyd"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:34
msgid "Group ID"
-msgstr ""
+msgstr "ID группы"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:34
msgid "Group id to run with"
-msgstr ""
+msgstr "Идентификатор группы для запуска"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:60
msgid "IPv6"
@@ -120,12 +122,16 @@ msgstr "Макс. кол-во обслуживаемых клиентов"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:52
msgid "Maximum clients to support (default: 0, no limit)"
msgstr ""
+"Максимальное количество поддерживаемых клиентов (по умолчанию: 0, без "
+"ограничений)"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:24
msgid ""
"Network interface to bind (eg: eth0), or UNIX domain socket path (eg: /var/"
"run/ttyd.sock)"
msgstr ""
+"Сетевой интерфейс для привязки (например: eth0), или путь к сокету домена "
+"UNIX (например: /var/run/ttyd.sock)"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:76
msgid "Notice"
@@ -142,12 +148,16 @@ msgstr "Порт"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:20
msgid "Port to listen (default: 7681, use `0` for random port)"
msgstr ""
+"Порт для прослушивания (по умолчанию: 7681, используйте `0` для "
+"произвольного порта)"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/term.js:14
msgid ""
"Random ttyd port (port=0) is not supported.<br />Change to a fixed port and "
"try again."
msgstr ""
+"Случайный порт ttyd (порт=0) не поддерживается.<br />Переключитесь на "
+"фиксированный порт и повторите попытку."
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:42
msgid "Read-only"
@@ -159,11 +169,11 @@ msgstr "SSL"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:70
msgid "SSL CA file path for client certificate verification"
-msgstr ""
+msgstr "Путь к файлу SSL CA для проверки сертификата клиента"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:70
msgid "SSL ca"
-msgstr ""
+msgstr "Корневой сертификат SSL"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:64
msgid "SSL cert"
@@ -171,7 +181,7 @@ msgstr "SSL-сертификат"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:64
msgid "SSL certificate file path"
-msgstr ""
+msgstr "Путь к файлу сертификата SSL"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:67
msgid "SSL key"
@@ -179,15 +189,15 @@ msgstr "SSL-ключ"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:67
msgid "SSL key file path"
-msgstr ""
+msgstr "Путь к файлу ключа SSL"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:44
msgid "Send option to client"
-msgstr ""
+msgstr "Отправить опцию клиенту"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:73
msgid "Set log level (default: 7)"
-msgstr ""
+msgstr "Установить уровень журнала (по умолчанию: 7)"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:37
msgid "Signal"
@@ -195,7 +205,7 @@ msgstr "Сигнал"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:37
msgid "Signal to send to the command when exit it (default: 1, SIGHUP)"
-msgstr ""
+msgstr "Сигнал, посылаемый команде при выходе из нее (по умолчанию: 1, SIGHUP)"
#: applications/luci-app-ttyd/root/usr/share/luci/menu.d/luci-app-ttyd.json:3
#: applications/luci-app-ttyd/root/usr/share/luci/menu.d/luci-app-ttyd.json:14
@@ -208,15 +218,15 @@ msgstr "Тип терминала"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:47
msgid "Terminal type to report (default: xterm-256color)"
-msgstr ""
+msgstr "Тип терминала для отчета (по умолчанию: xterm-256color)"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:31
msgid "User ID"
-msgstr ""
+msgstr "ID пользователя"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:31
msgid "User id to run with"
-msgstr ""
+msgstr "Идентификатор пользователя для запуска"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:75
msgid "Warning"
@@ -224,4 +234,4 @@ msgstr "Внимание"
#: applications/luci-app-ttyd/htdocs/luci-static/resources/view/ttyd/config.js:12
msgid "ttyd Instance"
-msgstr ""
+msgstr "Экземпляр ttyd"