summaryrefslogtreecommitdiffhomepage
path: root/applications
diff options
context:
space:
mode:
Diffstat (limited to 'applications')
-rw-r--r--applications/luci-app-adblock/luasrc/model/cbi/adblock/overview_tab.lua5
-rw-r--r--applications/luci-app-adblock/luasrc/view/adblock/runtime.htm14
-rw-r--r--applications/luci-app-radicale/Makefile4
-rw-r--r--applications/luci-app-travelmate/luasrc/controller/travelmate.lua2
-rw-r--r--applications/luci-app-travelmate/luasrc/model/cbi/travelmate/overview_tab.lua3
-rw-r--r--applications/luci-app-travelmate/luasrc/view/travelmate/runtime.htm9
6 files changed, 17 insertions, 20 deletions
diff --git a/applications/luci-app-adblock/luasrc/model/cbi/adblock/overview_tab.lua b/applications/luci-app-adblock/luasrc/model/cbi/adblock/overview_tab.lua
index 3bf739291..2ecaaab72 100644
--- a/applications/luci-app-adblock/luasrc/model/cbi/adblock/overview_tab.lua
+++ b/applications/luci-app-adblock/luasrc/model/cbi/adblock/overview_tab.lua
@@ -3,7 +3,6 @@
local fs = require("nixio.fs")
local uci = require("luci.model.uci").cursor()
-local sys = require("luci.sys")
local util = require("luci.util")
local dump = util.ubus("network.interface", "dump", {})
@@ -13,10 +12,6 @@ m = Map("adblock", translate("Adblock"),
.. "<a href=\"%s\" target=\"_blank\">"
.. "check the online documentation</a>", "https://github.com/openwrt/packages/blob/master/net/adblock/files/README.md"))
-function m.on_apply(self)
- luci.sys.call("/etc/init.d/adblock reload >/dev/null 2>&1")
-end
-
-- Main adblock options
s = m:section(NamedSection, "global", "adblock")
diff --git a/applications/luci-app-adblock/luasrc/view/adblock/runtime.htm b/applications/luci-app-adblock/luasrc/view/adblock/runtime.htm
index 05cdde73b..3f4d64259 100644
--- a/applications/luci-app-adblock/luasrc/view/adblock/runtime.htm
+++ b/applications/luci-app-adblock/luasrc/view/adblock/runtime.htm
@@ -6,7 +6,7 @@ This is free software, licensed under the Apache License, Version 2.0
<style type="text/css">
.runtime
{
- color: #0069d6;
+ color: #37c;
font-weight: bold;
display: inline-block;
width: 100%;
@@ -18,10 +18,12 @@ This is free software, licensed under the Apache License, Version 2.0
//<![CDATA[
function status_update(json)
{
- var view = document.getElementById("value_1");
- var btn1 = document.getElementById("btn1");
- var btn2 = document.getElementById("btn2");
- var input = json.data.adblock_status;
+ var view = document.getElementById("value_1");
+ var btn1 = document.getElementById("btn1");
+ var btn1_running = document.getElementById("btn1_running");
+ var btn2 = document.getElementById("btn2");
+ var btn2_running = document.getElementById("btn2_running");
+ var input = json.data.adblock_status;
view.innerHTML = input || "-";
if (input === "enabled")
@@ -126,7 +128,7 @@ This is free software, licensed under the Apache License, Version 2.0
btn2.value = "<%:Refresh%>";
btn2.name = "do_refresh";
btn1.disabled = true;
- btn2.disabled = false;
+ btn2.disabled = true;
return;
}
status_update(json_info)
diff --git a/applications/luci-app-radicale/Makefile b/applications/luci-app-radicale/Makefile
index 2b969ace5..87180e77d 100644
--- a/applications/luci-app-radicale/Makefile
+++ b/applications/luci-app-radicale/Makefile
@@ -14,10 +14,10 @@ PKG_VERSION:=1.1.0
# Release == build
# increase on changes of translation files
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=Apache-2.0
-PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
+PKG_MAINTAINER:=
# LuCI specific settings
LUCI_TITLE:=LuCI Support for Radicale CardDAV/CalDAV
diff --git a/applications/luci-app-travelmate/luasrc/controller/travelmate.lua b/applications/luci-app-travelmate/luasrc/controller/travelmate.lua
index 00969ffe7..775831d9d 100644
--- a/applications/luci-app-travelmate/luasrc/controller/travelmate.lua
+++ b/applications/luci-app-travelmate/luasrc/controller/travelmate.lua
@@ -39,7 +39,7 @@ function trm_action(name)
if name == "do_restart" then
luci.sys.call("/etc/init.d/travelmate restart >/dev/null 2>&1")
end
- luci.http.prepare_content("text/plain")
+ luci.http.prepare_content("text/plain")
luci.http.write("0")
end
diff --git a/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/overview_tab.lua b/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/overview_tab.lua
index ab39dab6b..a1a7ed72c 100644
--- a/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/overview_tab.lua
+++ b/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/overview_tab.lua
@@ -17,9 +17,10 @@ m = Map("travelmate", translate("Travelmate"),
.. "see online documentation</a>", "https://github.com/openwrt/packages/blob/master/net/travelmate/files/README.md"))
m:chain("network")
m:chain("firewall")
+m.apply_on_parse = true
function m.on_apply(self)
- luci.sys.call("env -i /etc/init.d/travelmate restart >/dev/null 2>&1")
+ luci.sys.call("/etc/init.d/travelmate restart >/dev/null 2>&1")
end
-- Interface Wizard
diff --git a/applications/luci-app-travelmate/luasrc/view/travelmate/runtime.htm b/applications/luci-app-travelmate/luasrc/view/travelmate/runtime.htm
index aba4a3201..272612600 100644
--- a/applications/luci-app-travelmate/luasrc/view/travelmate/runtime.htm
+++ b/applications/luci-app-travelmate/luasrc/view/travelmate/runtime.htm
@@ -7,7 +7,6 @@ This is free software, licensed under the Apache License, Version 2.0
.runtime
{
color: #37c;
- //#0069d6;
font-weight: bold;
display: inline-block;
width: 100%;
@@ -22,7 +21,7 @@ This is free software, licensed under the Apache License, Version 2.0
var btn1 = document.getElementById("btn1");
var view = document.getElementById("value_1");
var input = json.data.travelmate_status;
-
+
btn1.value = "<%:Restart%>";
btn1.name = "do_restart";
view.innerHTML = input || "-";
@@ -41,8 +40,6 @@ This is free software, licensed under the Apache License, Version 2.0
view = document.getElementById("value_6");
input = json.data.last_rundate;
view.innerHTML = input || "-";
- btn1.disabled = false;
- running(btn1_running, 0);
}
function btn_action(action)
@@ -60,6 +57,8 @@ This is free software, licensed under the Apache License, Version 2.0
{
return;
}
+ btn1.disabled = false;
+ running(btn1_running, 0);
});
}
@@ -139,7 +138,7 @@ This is free software, licensed under the Apache License, Version 2.0
<div class="cbi-value" id="button_1">
<label class="cbi-value-title" for="button_1"><%:Restart Travelmate%></label>
<div class="cbi-value-field">
- <input class="cbi-button cbi-button-reset" id="btn1" type="button" value="" onclick="btn_action(this)" />
+ <input class="cbi-button cbi-button-reset" id="btn1" type="button" name="do_restart" value="<%:Restart%>" onclick="btn_action(this)" />
<span id="btn1_running" style="display:inline-block; width:16px; height:16px; margin:0 5px"></span>
</div>
</div>