summaryrefslogtreecommitdiffhomepage
path: root/applications
diff options
context:
space:
mode:
Diffstat (limited to 'applications')
-rw-r--r--applications/luci-app-adblock/Makefile14
-rw-r--r--applications/luci-app-adblock/luasrc/controller/adblock.lua12
-rw-r--r--applications/luci-app-adblock/luasrc/model/cbi/adblock.lua60
-rwxr-xr-xapplications/luci-app-adblock/root/etc/uci-defaults/40_luci-adblock11
-rw-r--r--applications/luci-app-firewall/luasrc/view/firewall/cbi_addforward.htm26
-rw-r--r--applications/luci-app-firewall/luasrc/view/firewall/cbi_addsnat.htm25
6 files changed, 120 insertions, 28 deletions
diff --git a/applications/luci-app-adblock/Makefile b/applications/luci-app-adblock/Makefile
new file mode 100644
index 0000000000..8efe2d6048
--- /dev/null
+++ b/applications/luci-app-adblock/Makefile
@@ -0,0 +1,14 @@
+# Copyright (C) 2016 Openwrt.org
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=LuCI support for Adblock
+LUCI_DEPENDS:=+adblock
+LUCI_PKGARCH:=all
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/applications/luci-app-adblock/luasrc/controller/adblock.lua b/applications/luci-app-adblock/luasrc/controller/adblock.lua
new file mode 100644
index 0000000000..d8b471814f
--- /dev/null
+++ b/applications/luci-app-adblock/luasrc/controller/adblock.lua
@@ -0,0 +1,12 @@
+-- Copyright 2016 Openwrt.org
+-- Licensed to the public under the Apache License 2.0.
+
+module("luci.controller.adblock", package.seeall)
+
+function index()
+ if not nixio.fs.access("/etc/config/adblock") then
+ return
+ end
+
+ entry({"admin", "services", "adblock"}, cbi("adblock"), _("Adblock"), 40)
+end
diff --git a/applications/luci-app-adblock/luasrc/model/cbi/adblock.lua b/applications/luci-app-adblock/luasrc/model/cbi/adblock.lua
new file mode 100644
index 0000000000..1fd77b4ab3
--- /dev/null
+++ b/applications/luci-app-adblock/luasrc/model/cbi/adblock.lua
@@ -0,0 +1,60 @@
+-- Copyright 2016 Openwrt.org
+-- Licensed to the public under the Apache License 2.0.
+
+m = Map("adblock", translate("Adblock"),
+ translate("Configuration of the adblock package to block ad/abuse domains by using DNS."))
+
+-- General options
+
+s = m:section(NamedSection, "global", "adblock", translate("Global options"))
+
+o1 = s:option(Flag, "adb_enabled", translate("Enable"))
+o1.rmempty = false
+o1.default = 0
+
+o2 = s:option(Value, "adb_blacklist", translate("Blacklist file"),
+ translate("File with explicitly blacklisted hosts/domains."))
+o2.rmempty = false
+o2.datatype = "file"
+
+o3 = s:option(Value, "adb_whitelist", translate("Whitelist file"),
+ translate("File with whitelisted hosts/domains that are allowed despite being on a blocklist."))
+o3.rmempty = false
+o3.datatype = "file"
+
+s2 = m:section(NamedSection, "backup", "service", translate("Backup options"))
+
+o4 = s2:option(Flag, "enabled", translate("Enable blocklist backup"))
+o4.rmempty = false
+o4.default = 0
+
+o5 = s2:option(Value, "adb_backupdir", translate("Backup directory"))
+o5.rmempty = false
+o5.datatype = "directory"
+
+s3 = m:section(NamedSection, "debuglog", "service", translate("Debug log options"),
+ translate("Verbose log for debuging purposes."))
+
+o6 = s3:option(Flag, "enabled", translate("Enable debug log"))
+o6.rmempty = false
+o6.default = 0
+
+o7 = s3:option(Value, "adb_logfile", translate("Debug log file"))
+o7.rmempty = false
+o7.datatype = "string"
+
+-- Blocklist options
+
+s3 = m:section(TypedSection, "source", translate("Blocklist sources"),
+ translate("Available blocklist sources (")
+ .. [[<a href="https://github.com/openwrt/packages/blob/master/net/adblock/files/README.md#main-features" target="_blank">]]
+ .. translate("see list details")
+ .. [[</a>]]
+ .. translate("). Note that list URLs and Shallalist category selections are not configurable via Luci."))
+
+name = s3:option(Flag, "enabled", translate("Enabled"))
+name.rmempty = false
+
+
+return m
+
diff --git a/applications/luci-app-adblock/root/etc/uci-defaults/40_luci-adblock b/applications/luci-app-adblock/root/etc/uci-defaults/40_luci-adblock
new file mode 100755
index 0000000000..1f7fb1c0fb
--- /dev/null
+++ b/applications/luci-app-adblock/root/etc/uci-defaults/40_luci-adblock
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+uci -q batch <<-EOF >/dev/null
+ delete ucitrack.@adblock[-1]
+ add ucitrack adblock
+ set ucitrack.@adblock[-1].init=adblock
+ commit ucitrack
+EOF
+
+rm -f /tmp/luci-indexcache
+exit 0
diff --git a/applications/luci-app-firewall/luasrc/view/firewall/cbi_addforward.htm b/applications/luci-app-firewall/luasrc/view/firewall/cbi_addforward.htm
index 3c46e228f7..b3079f3a48 100644
--- a/applications/luci-app-firewall/luasrc/view/firewall/cbi_addforward.htm
+++ b/applications/luci-app-firewall/luasrc/view/firewall/cbi_addforward.htm
@@ -11,6 +11,12 @@
ezl[#ezl+1] = z
end
end
+
+ local keys, vals = { }, { }
+ luci.sys.net.ipv4_hints(function(ip, name)
+ keys[#keys+1] = ip
+ vals[#vals+1] = '%s (%s)' %{ ip, name }
+ end)
-%>
<div class="cbi-section-create cbi-tblsection-create">
<br />
@@ -46,7 +52,7 @@
</select>
</td>
<td class="cbi-section-table-cell" style="width:110px">
- <input type="text" class="cbi-input-text" id="_newfwd.extport" name="_newfwd.extport" />
+ <input type="text" class="cbi-input-text" id="_newfwd.extport" name="_newfwd.extport" data-type="portrange" data-optional="true" />
</td>
<td class="cbi-section-table-cell" style="width:55px">
<select class="cbi-input-select" id="_newfwd.intzone" name="_newfwd.intzone">
@@ -54,10 +60,12 @@
</select>
</td>
<td class="cbi-section-table-cell" style="width:110px">
- <input type="text" class="cbi-input-text" id="_newfwd.intaddr" name="_newfwd.intaddr" />
+ <input type="text" class="cbi-input-text" id="_newfwd.intaddr" name="_newfwd.intaddr" data-type="host" data-optional="true"<%=
+ ifattr(#keys > 0, "data-choices", {keys, vals})
+ %>/>
</td>
<td class="cbi-section-table-cell" style="width:110px">
- <input type="text" class="cbi-input-text" id="_newfwd.intport" name="_newfwd.intport" />
+ <input type="text" class="cbi-input-text" id="_newfwd.intport" name="_newfwd.intport" data-type="portrange" data-optional="true" />
</td>
<td class="cbi-section-table-cell">
<input type="submit" class="cbi-button cbi-button-add" name="cbi.cts.<%=self.config%>.<%=self.sectiontype%>.<%=section%>" value="<%:Add%>" />
@@ -66,15 +74,6 @@
</table>
<script type="text/javascript">//<![CDATA[
- cbi_validate_field('_newfwd.extport', true, 'portrange');
- cbi_validate_field('_newfwd.intaddr', true, 'host');
- cbi_validate_field('_newfwd.intport', true, 'portrange');
-
- cbi_combobox_init('_newfwd.intaddr', {
- <% first = true; luci.sys.net.ipv4_hints(function(ip, name) %>
- <%- if first then first = false else %>,<% end -%>'<%=ip%>': '<%=ip%> (<%=name%>)'
- <%- end) %> }, '', '<%: -- custom -- %>');
-
cbi_bind(document.getElementById('_newfwd.extport'), 'blur',
function() {
var n = document.getElementById('_newfwd.name');
@@ -109,8 +108,5 @@
}
}
});
-
-
- cbi_validate_field('cbi.cts.<%=self.config%>.<%=self.sectiontype%>.<%=section%>', true, 'uciname');
//]]></script>
</div>
diff --git a/applications/luci-app-firewall/luasrc/view/firewall/cbi_addsnat.htm b/applications/luci-app-firewall/luasrc/view/firewall/cbi_addsnat.htm
index 4e1681c11d..ce275111d8 100644
--- a/applications/luci-app-firewall/luasrc/view/firewall/cbi_addsnat.htm
+++ b/applications/luci-app-firewall/luasrc/view/firewall/cbi_addsnat.htm
@@ -3,6 +3,14 @@
local nw = require "luci.model.network".init()
local wz = fw:get_zone("wan")
local lz = fw:get_zone("lan")
+
+ local keys, vals, a, k, v = {}, {}
+ for k, v in ipairs(nw:get_interfaces()) do
+ for k, a in ipairs(v:ipaddrs()) do
+ keys[#keys+1] = a:host():string()
+ vals[#vals+1] = '%s (%s)' %{ a:host(), v:shortname() }
+ end
+ end
%>
<div class="cbi-section-create cbi-tblsection-create">
@@ -39,27 +47,18 @@
</select>
</td>
<td class="cbi-section-table-cell" style="width:110px">
- <input type="text" class="cbi-input-text" id="_newsnat.dip" name="_newsnat.dip" />
+ <input type="text" class="cbi-input-text" id="_newsnat.dip" name="_newsnat.dip" placeholder="<%:Do not rewrite%>" data-type="ip4addr" data-optional="true"<%=
+ ifattr(#keys > 0, "data-choices", { keys, vals })
+ %> />
</td>
<td class="cbi-section-table-cell" style="width:110px">
- <input type="text" class="cbi-input-text" id="_newsnat.dport" name="_newsnat.dport" placeholder="<%:Do not rewrite%>" />
+ <input type="text" class="cbi-input-text" id="_newsnat.dport" name="_newsnat.dport" placeholder="<%:Do not rewrite%>" data-type="portrange" data-optional="true" />
</td>
<td class="cbi-section-table-cell">
<input type="submit" class="cbi-button cbi-button-link" name="_newsnat.submit" value="<%:Add and edit...%>" />
</td>
</tr>
</table>
-
- <script type="text/javascript">//<![CDATA[
- cbi_validate_field('_newsnat.dport', true, 'portrange');
- cbi_validate_field('_newsnat.dip', true, 'ip4addr');
- cbi_combobox_init('_newsnat.dip', {
- <% local c, k, v = 0; for k, v in ipairs(nw:get_interfaces()) do -%>
- <%- local a; for k, a in ipairs(v:ipaddrs()) do c = c + 1 -%>
- <% if c > 1 then %>,<% end %>'<%=a:host():string()%>': '<%=a:host():string()%> (<%=v:shortname()%>)'
- <%- end %>
- <%- end %> }, '<%: -- Please choose -- %>', '<%: -- custom -- %>');
- //]]></script>
<% else %>
<input type="submit" class="cbi-button cbi-button-add" name="cbi.cts.<%=self.config%>.<%=self.sectiontype%>.<%=section%>" value="<%:Add%>" />
<% end %>