summaryrefslogtreecommitdiffhomepage
path: root/applications
diff options
context:
space:
mode:
Diffstat (limited to 'applications')
-rw-r--r--applications/luci-app-aria2/Makefile2
-rw-r--r--applications/luci-app-ddns/Makefile2
-rw-r--r--applications/luci-app-dynapoint/Makefile2
-rw-r--r--applications/luci-app-privoxy/Makefile2
-rw-r--r--applications/luci-app-radicale/Makefile2
-rw-r--r--applications/luci-app-transmission/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/applications/luci-app-aria2/Makefile b/applications/luci-app-aria2/Makefile
index f5b006c35..e957c436f 100644
--- a/applications/luci-app-aria2/Makefile
+++ b/applications/luci-app-aria2/Makefile
@@ -21,7 +21,7 @@ PKG_MAINTAINER:=Hsing-Wang Liao <kuoruan@gmail.com>
# LuCI specific settings
LUCI_TITLE:=LuCI Support for Aria2
-LUCI_DEPENDS:=+aria2
+LUCI_DEPENDS:=+luci-lib-ipkg +aria2
LUCI_PKGARCH:=all
define Package/$(PKG_NAME)/config
diff --git a/applications/luci-app-ddns/Makefile b/applications/luci-app-ddns/Makefile
index 9262afcf8..eb3a77aee 100644
--- a/applications/luci-app-ddns/Makefile
+++ b/applications/luci-app-ddns/Makefile
@@ -23,7 +23,7 @@ PKG_MAINTAINER:=Ansuel Smith <ansuelsmth@gmail.com>
# LuCI specific settings
LUCI_TITLE:=LuCI Support for Dynamic DNS Client (ddns-scripts)
-LUCI_DEPENDS:=+luci-mod-admin-full +ddns-scripts
+LUCI_DEPENDS:=+luci-lib-ipkg +luci-mod-admin-full +ddns-scripts
# LUCI_PKGARCH:=all
define Package/$(PKG_NAME)/config
diff --git a/applications/luci-app-dynapoint/Makefile b/applications/luci-app-dynapoint/Makefile
index 83512dba5..e405cc41f 100644
--- a/applications/luci-app-dynapoint/Makefile
+++ b/applications/luci-app-dynapoint/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI Support for DynaPoint
-LUCI_DEPENDS:=+dynapoint
+LUCI_DEPENDS:=+luci-lib-ipkg +dynapoint
PKG_LICENSE:=GPL-3.0+
PKG_MAINTAINER:=Tobias Ilte <tobias.ilte@campus.tu-berlin.de>
diff --git a/applications/luci-app-privoxy/Makefile b/applications/luci-app-privoxy/Makefile
index 486cf0ee7..672817283 100644
--- a/applications/luci-app-privoxy/Makefile
+++ b/applications/luci-app-privoxy/Makefile
@@ -21,7 +21,7 @@ PKG_MAINTAINER:=
# LuCI specific settings
LUCI_TITLE:=LuCI Support for Privoxy WEB proxy
-LUCI_DEPENDS:=+luci-mod-admin-full +privoxy
+LUCI_DEPENDS:=+luci-lib-ipkg +luci-mod-admin-full +privoxy
LUCI_PKGARCH:=all
define Package/$(PKG_NAME)/config
diff --git a/applications/luci-app-radicale/Makefile b/applications/luci-app-radicale/Makefile
index 87180e77d..90ef0deba 100644
--- a/applications/luci-app-radicale/Makefile
+++ b/applications/luci-app-radicale/Makefile
@@ -21,7 +21,7 @@ PKG_MAINTAINER:=
# LuCI specific settings
LUCI_TITLE:=LuCI Support for Radicale CardDAV/CalDAV
-LUCI_DEPENDS:=+luci-mod-admin-full
+LUCI_DEPENDS:=+luci-lib-ipkg +luci-mod-admin-full
LUCI_PKGARCH:=all
define Package/$(PKG_NAME)/config
diff --git a/applications/luci-app-transmission/Makefile b/applications/luci-app-transmission/Makefile
index 668c73185..42b29e9a4 100644
--- a/applications/luci-app-transmission/Makefile
+++ b/applications/luci-app-transmission/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI Support for Transmission
-LUCI_DEPENDS:=
+LUCI_DEPENDS:=+luci-lib-ipkg
include ../../luci.mk