summaryrefslogtreecommitdiffhomepage
path: root/applications
diff options
context:
space:
mode:
Diffstat (limited to 'applications')
-rw-r--r--applications/luci-app-adblock/Makefile2
-rw-r--r--applications/luci-app-ahcp/Makefile2
-rw-r--r--applications/luci-app-banip/Makefile2
-rw-r--r--applications/luci-app-bcp38/Makefile2
-rw-r--r--applications/luci-app-dcwapd/Makefile2
-rw-r--r--applications/luci-app-minidlna/Makefile2
-rw-r--r--applications/luci-app-mwan3/Makefile2
-rw-r--r--applications/luci-app-nlbwmon/Makefile2
-rw-r--r--applications/luci-app-ocserv/Makefile2
-rw-r--r--applications/luci-app-olsr/Makefile2
-rw-r--r--applications/luci-app-p910nd/Makefile2
-rw-r--r--applications/luci-app-rp-pppoe-server/Makefile2
-rw-r--r--applications/luci-app-shadowsocks-libev/Makefile2
-rw-r--r--applications/luci-app-statistics/Makefile2
-rw-r--r--applications/luci-app-travelmate/Makefile2
-rw-r--r--applications/luci-app-unbound/Makefile2
-rw-r--r--applications/luci-app-vnstat/Makefile2
17 files changed, 17 insertions, 17 deletions
diff --git a/applications/luci-app-adblock/Makefile b/applications/luci-app-adblock/Makefile
index 2de2ed862..c51b9d8ed 100644
--- a/applications/luci-app-adblock/Makefile
+++ b/applications/luci-app-adblock/Makefile
@@ -4,7 +4,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI support for Adblock
-LUCI_DEPENDS:=+adblock +luci-lib-jsonc
+LUCI_DEPENDS:=+luci-compat +adblock +luci-lib-jsonc
LUCI_PKGARCH:=all
include ../../luci.mk
diff --git a/applications/luci-app-ahcp/Makefile b/applications/luci-app-ahcp/Makefile
index bb4d4158d..10859345e 100644
--- a/applications/luci-app-ahcp/Makefile
+++ b/applications/luci-app-ahcp/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI Support for AHCPd
-LUCI_DEPENDS:=+ahcpd
+LUCI_DEPENDS:=+luci-compat +ahcpd
include ../../luci.mk
diff --git a/applications/luci-app-banip/Makefile b/applications/luci-app-banip/Makefile
index 1936bc36b..39712708b 100644
--- a/applications/luci-app-banip/Makefile
+++ b/applications/luci-app-banip/Makefile
@@ -4,7 +4,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI support for banIP
-LUCI_DEPENDS:=+banip +luci-lib-jsonc
+LUCI_DEPENDS:=+luci-compat +banip +luci-lib-jsonc
LUCI_PKGARCH:=all
include ../../luci.mk
diff --git a/applications/luci-app-bcp38/Makefile b/applications/luci-app-bcp38/Makefile
index 9ab5a6701..a8a6e7402 100644
--- a/applications/luci-app-bcp38/Makefile
+++ b/applications/luci-app-bcp38/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=BCP38 LuCI interface
-LUCI_DEPENDS:=+luci-mod-admin-full +bcp38
+LUCI_DEPENDS:=+luci-compat +luci-mod-admin-full +bcp38
PKG_MAINTAINER:=Toke Høiland-Jørgensen <toke@toke.dk>
PKG_LICENSE:=Apache-2.0
diff --git a/applications/luci-app-dcwapd/Makefile b/applications/luci-app-dcwapd/Makefile
index 3396bcd29..3def090a7 100644
--- a/applications/luci-app-dcwapd/Makefile
+++ b/applications/luci-app-dcwapd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=Dual Channel Wi-Fi AP Daemon configuration module
-LUCI_DEPENDS:=+dcwapd
+LUCI_DEPENDS:=+luci-compat +dcwapd
include ../../luci.mk
diff --git a/applications/luci-app-minidlna/Makefile b/applications/luci-app-minidlna/Makefile
index 4790aa32c..3d3ec4d52 100644
--- a/applications/luci-app-minidlna/Makefile
+++ b/applications/luci-app-minidlna/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI Support for miniDLNA
-LUCI_DEPENDS:=+minidlna
+LUCI_DEPENDS:=+luci-compat +minidlna
include ../../luci.mk
diff --git a/applications/luci-app-mwan3/Makefile b/applications/luci-app-mwan3/Makefile
index c719cb134..50f87cd84 100644
--- a/applications/luci-app-mwan3/Makefile
+++ b/applications/luci-app-mwan3/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI support for the MWAN3 multiwan hotplug script
-LUCI_DEPENDS:=+mwan3 +libuci-lua +luci-mod-admin-full +luci-app-firewall +luci-lib-nixio
+LUCI_DEPENDS:=+luci-compat +mwan3 +libuci-lua +luci-mod-admin-full +luci-app-firewall +luci-lib-nixio
LUCI_PKGARCH:=all
PKG_LICENSE:=GPLv2
diff --git a/applications/luci-app-nlbwmon/Makefile b/applications/luci-app-nlbwmon/Makefile
index a00177f2c..c4b83e807 100644
--- a/applications/luci-app-nlbwmon/Makefile
+++ b/applications/luci-app-nlbwmon/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=Netlink based bandwidth accounting
-LUCI_DEPENDS:=+nlbwmon
+LUCI_DEPENDS:=+luci-compat +nlbwmon
include ../../luci.mk
diff --git a/applications/luci-app-ocserv/Makefile b/applications/luci-app-ocserv/Makefile
index 3fbf4d2c1..2f2ea788e 100644
--- a/applications/luci-app-ocserv/Makefile
+++ b/applications/luci-app-ocserv/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI Support for OpenConnect VPN
-LUCI_DEPENDS:=+ocserv +certtool
+LUCI_DEPENDS:=+luci-compat +ocserv +certtool
include ../../luci.mk
diff --git a/applications/luci-app-olsr/Makefile b/applications/luci-app-olsr/Makefile
index 6ce1ac255..b6432e6ac 100644
--- a/applications/luci-app-olsr/Makefile
+++ b/applications/luci-app-olsr/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=OLSR configuration and status module
-LUCI_DEPENDS:=+olsrd +olsrd-mod-jsoninfo +luci-lib-json
+LUCI_DEPENDS:=+luci-compat +olsrd +olsrd-mod-jsoninfo +luci-lib-json
include ../../luci.mk
diff --git a/applications/luci-app-p910nd/Makefile b/applications/luci-app-p910nd/Makefile
index adb35bd47..8c73f372f 100644
--- a/applications/luci-app-p910nd/Makefile
+++ b/applications/luci-app-p910nd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=p910nd - Printer server module
-LUCI_DEPENDS:=+p910nd
+LUCI_DEPENDS:=+luci-compat +p910nd
include ../../luci.mk
diff --git a/applications/luci-app-rp-pppoe-server/Makefile b/applications/luci-app-rp-pppoe-server/Makefile
index aa3ae538c..b4edfc949 100644
--- a/applications/luci-app-rp-pppoe-server/Makefile
+++ b/applications/luci-app-rp-pppoe-server/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=Roaring Penguin PPPoE Server
-LUCI_DEPENDS:=+rp-pppoe-server
+LUCI_DEPENDS:=+luci-compat +rp-pppoe-server
include ../../luci.mk
diff --git a/applications/luci-app-shadowsocks-libev/Makefile b/applications/luci-app-shadowsocks-libev/Makefile
index d0923e07a..72195a711 100644
--- a/applications/luci-app-shadowsocks-libev/Makefile
+++ b/applications/luci-app-shadowsocks-libev/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI Support for shadowsocks-libev
-LUCI_DEPENDS:=
+LUCI_DEPENDS:=+luci-compat
PKG_LICENSE:=Apache-2.0
diff --git a/applications/luci-app-statistics/Makefile b/applications/luci-app-statistics/Makefile
index b552400fe..b38146c2c 100644
--- a/applications/luci-app-statistics/Makefile
+++ b/applications/luci-app-statistics/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI Statistics Application
LUCI_DEPENDS:= \
- +luci-lib-iptparser \
+ +luci-compat +luci-lib-iptparser \
+collectd +rrdtool1 +collectd-mod-rrdtool +collectd-mod-iwinfo \
+collectd-mod-cpu +collectd-mod-memory \
+collectd-mod-interface +collectd-mod-load +collectd-mod-network
diff --git a/applications/luci-app-travelmate/Makefile b/applications/luci-app-travelmate/Makefile
index 58d9bf37d..4115dadbe 100644
--- a/applications/luci-app-travelmate/Makefile
+++ b/applications/luci-app-travelmate/Makefile
@@ -5,7 +5,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI support for Travelmate
-LUCI_DEPENDS:=+travelmate +luci-lib-jsonc
+LUCI_DEPENDS:=+luci-compat +travelmate +luci-lib-jsonc
LUCI_PKGARCH:=all
include ../../luci.mk
diff --git a/applications/luci-app-unbound/Makefile b/applications/luci-app-unbound/Makefile
index 6b43adab3..9dd01ffed 100644
--- a/applications/luci-app-unbound/Makefile
+++ b/applications/luci-app-unbound/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=Unbound Recursive DNS Resolver Configuration
-LUCI_DEPENDS:=+unbound-daemon
+LUCI_DEPENDS:=+luci-compat +unbound-daemon
include ../../luci.mk
diff --git a/applications/luci-app-vnstat/Makefile b/applications/luci-app-vnstat/Makefile
index 6d98610d6..c2e930632 100644
--- a/applications/luci-app-vnstat/Makefile
+++ b/applications/luci-app-vnstat/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI Support for VnStat
-LUCI_DEPENDS:=+vnstat +vnstati
+LUCI_DEPENDS:=+luci-compat +vnstat +vnstati
include ../../luci.mk