summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-p910nd
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-p910nd')
-rw-r--r--applications/luci-p910nd/Makefile4
-rw-r--r--applications/luci-p910nd/ipkg/postinst6
-rw-r--r--applications/luci-p910nd/luasrc/controller/p910nd.lua27
-rw-r--r--applications/luci-p910nd/luasrc/model/cbi/p910nd.lua59
-rwxr-xr-xapplications/luci-p910nd/root/etc/uci-defaults/luci-p910nd11
5 files changed, 0 insertions, 107 deletions
diff --git a/applications/luci-p910nd/Makefile b/applications/luci-p910nd/Makefile
deleted file mode 100644
index 30073fbd5..000000000
--- a/applications/luci-p910nd/Makefile
+++ /dev/null
@@ -1,4 +0,0 @@
-PO = p910nd
-
-include ../../build/config.mk
-include ../../build/module.mk
diff --git a/applications/luci-p910nd/ipkg/postinst b/applications/luci-p910nd/ipkg/postinst
deleted file mode 100644
index 36a91e21b..000000000
--- a/applications/luci-p910nd/ipkg/postinst
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-[ -n "${IPKG_INSTROOT}" ] || {
- ( . /etc/uci-defaults/luci-p910nd ) && rm -f /etc/uci-defaults/luci-p910nd
- /etc/init.d/p910nd enabled || /etc/init.d/p910nd enable
- exit 0
-}
diff --git a/applications/luci-p910nd/luasrc/controller/p910nd.lua b/applications/luci-p910nd/luasrc/controller/p910nd.lua
deleted file mode 100644
index 4efaef8a1..000000000
--- a/applications/luci-p910nd/luasrc/controller/p910nd.lua
+++ /dev/null
@@ -1,27 +0,0 @@
---[[
-
-LuCI UVC Streamer
-(c) 2008 Yanira <forum-2008@email.de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-
-]]--
-
-module("luci.controller.p910nd", package.seeall)
-
-function index()
- if not nixio.fs.access("/etc/config/p910nd") then
- return
- end
-
- local page
-
- page = entry({"admin", "services", "p910nd"}, cbi("p910nd"), _("p910nd - Printer server"), 60)
- page.dependent = true
-end
diff --git a/applications/luci-p910nd/luasrc/model/cbi/p910nd.lua b/applications/luci-p910nd/luasrc/model/cbi/p910nd.lua
deleted file mode 100644
index 7580a3e74..000000000
--- a/applications/luci-p910nd/luasrc/model/cbi/p910nd.lua
+++ /dev/null
@@ -1,59 +0,0 @@
---[[
-
-LuCI p910nd
-(c) 2008 Yanira <forum-2008@email.de>
-(c) 2012 Jo-Philipp Wich <jow@openwrt.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-]]--
-
-local uci = luci.model.uci.cursor_state()
-local net = require "luci.model.network"
-local m, s, p, b
-
-m = Map("p910nd", translate("p910nd - Printer server"),
- translatef("First you have to install the packages to get support for USB (kmod-usb-printer) or parallel port (kmod-lp)."))
-
-net = net.init(m.uci)
-
-s = m:section(TypedSection, "p910nd", translate("Settings"))
-s.addremove = true
-s.anonymous = true
-
-s:option(Flag, "enabled", translate("enable"))
-
-s:option(Value, "device", translate("Device")).rmempty = true
-
-b = s:option(Value, "bind", translate("Interface"), translate("Specifies the interface to listen on."))
-b.template = "cbi/network_netlist"
-b.nocreate = true
-b.unspecified = true
-
-function b.cfgvalue(...)
- local v = Value.cfgvalue(...)
- if v then
- return (net:get_status_by_address(v))
- end
-end
-
-function b.write(self, section, value)
- local n = net:get_network(value)
- if n and n:ipaddr() then
- Value.write(self, section, n:ipaddr())
- end
-end
-
-p = s:option(ListValue, "port", translate("Port"), translate("TCP listener port."))
-p.rmempty = true
-for i=0,9 do
- p:value(i, 9100+i)
-end
-
-s:option(Flag, "bidirectional", translate("Bidirectional mode"))
-
-return m
diff --git a/applications/luci-p910nd/root/etc/uci-defaults/luci-p910nd b/applications/luci-p910nd/root/etc/uci-defaults/luci-p910nd
deleted file mode 100755
index 80f6d62fa..000000000
--- a/applications/luci-p910nd/root/etc/uci-defaults/luci-p910nd
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-
-uci -q batch <<-EOF >/dev/null
- delete ucitrack.@p910nd[-1]
- add ucitrack p910nd
- set ucitrack.@p910nd[-1].init=p910nd
- commit ucitrack
-EOF
-
-rm -f /tmp/luci-indexcache
-exit 0