summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-uhttpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-uhttpd/Makefile')
-rw-r--r--applications/luci-app-uhttpd/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/applications/luci-app-uhttpd/Makefile b/applications/luci-app-uhttpd/Makefile
new file mode 100644
index 0000000000..9a2cf462e5
--- /dev/null
+++ b/applications/luci-app-uhttpd/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=uHTTPd Webserver Configuration
+LUCI_DEPENDS:=+uhttpd
+LUCI_PKGARCH:=all
+
+PKG_NAME:=luci-app-uhttpd
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=1
+PKG_LICENSE:=Apache-2.0
+PKG_MAINTAINER:=Daniel Dickinson <openwrt@daniel.thecshore.com>
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+LUA_TARGET:=source
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature