summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-travelmate
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-travelmate')
-rw-r--r--applications/luci-app-travelmate/Makefile2
-rw-r--r--applications/luci-app-travelmate/luasrc/controller/travelmate.lua24
-rw-r--r--applications/luci-app-travelmate/luasrc/model/cbi/travelmate/overview_tab.lua81
-rw-r--r--applications/luci-app-travelmate/luasrc/model/cbi/travelmate/wifi_add.lua20
-rw-r--r--applications/luci-app-travelmate/luasrc/model/cbi/travelmate/wifi_delete.lua1
-rw-r--r--applications/luci-app-travelmate/luasrc/model/cbi/travelmate/wifi_edit.lua1
-rw-r--r--applications/luci-app-travelmate/luasrc/view/travelmate/ap_qr.htm9
-rw-r--r--applications/luci-app-travelmate/po/ja/travelmate.po68
-rw-r--r--applications/luci-app-travelmate/po/pt-br/travelmate.po41
-rw-r--r--applications/luci-app-travelmate/po/ru/travelmate.po73
-rw-r--r--applications/luci-app-travelmate/po/templates/travelmate.pot41
11 files changed, 194 insertions, 167 deletions
diff --git a/applications/luci-app-travelmate/Makefile b/applications/luci-app-travelmate/Makefile
index 2bd25bc171..58d9bf37d4 100644
--- a/applications/luci-app-travelmate/Makefile
+++ b/applications/luci-app-travelmate/Makefile
@@ -5,7 +5,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI support for Travelmate
-LUCI_DEPENDS:=+travelmate +luci-lib-jsonc +qrencode
+LUCI_DEPENDS:=+travelmate +luci-lib-jsonc
LUCI_PKGARCH:=all
include ../../luci.mk
diff --git a/applications/luci-app-travelmate/luasrc/controller/travelmate.lua b/applications/luci-app-travelmate/luasrc/controller/travelmate.lua
index 14b8d77ff6..493a387c3e 100644
--- a/applications/luci-app-travelmate/luasrc/controller/travelmate.lua
+++ b/applications/luci-app-travelmate/luasrc/controller/travelmate.lua
@@ -14,27 +14,27 @@ function index()
entry({"admin", "services", "travelmate"}, firstchild(), _("Travelmate"), 40).dependent = false
entry({"admin", "services", "travelmate", "tab_from_cbi"}, cbi("travelmate/overview_tab", {hideresetbtn=true, hidesavebtn=true}), _("Overview"), 10).leaf = true
entry({"admin", "services", "travelmate", "stations"}, template("travelmate/stations"), _("Wireless Stations"), 20).leaf = true
- entry({"admin", "services", "travelmate", "apqr"}, template("travelmate/ap_qr"), _("AP QR-Codes"), 30).leaf = true
- entry({"admin", "services", "travelmate", "logfile"}, call("logread"), _("View Logfile"), 40).leaf = true
+ entry({"admin", "services", "travelmate", "logfile"}, call("logread"), _("View Logfile"), 30).leaf = true
entry({"admin", "services", "travelmate", "advanced"}, firstchild(), _("Advanced"), 100)
- entry({"admin", "services", "travelmate", "advanced", "configuration"}, cbi("travelmate/configuration_tab"), _("Edit Travelmate Configuration"), 110).leaf = true
- entry({"admin", "services", "travelmate", "advanced", "cfg_wireless"}, cbi("travelmate/cfg_wireless_tab"), _("Edit Wireless Configuration"), 120).leaf = true
- entry({"admin", "services", "travelmate", "advanced", "cfg_network"}, cbi("travelmate/cfg_network_tab"), _("Edit Network Configuration"), 130).leaf = true
- entry({"admin", "services", "travelmate", "advanced", "cfg_firewall"}, cbi("travelmate/cfg_firewall_tab"), _("Edit Firewall Configuration"), 140).leaf = true
+ entry({"admin", "services", "travelmate", "advanced", "configuration"}, form("travelmate/configuration_tab"), _("Edit Travelmate Configuration"), 110).leaf = true
+ entry({"admin", "services", "travelmate", "advanced", "cfg_wireless"}, form("travelmate/cfg_wireless_tab"), _("Edit Wireless Configuration"), 120).leaf = true
+ entry({"admin", "services", "travelmate", "advanced", "cfg_network"}, form("travelmate/cfg_network_tab"), _("Edit Network Configuration"), 130).leaf = true
+ entry({"admin", "services", "travelmate", "advanced", "cfg_firewall"}, form("travelmate/cfg_firewall_tab"), _("Edit Firewall Configuration"), 140).leaf = true
+ entry({"admin", "services", "travelmate", "apqr"}, template("travelmate/ap_qr")).leaf = true
entry({"admin", "services", "travelmate", "wifiscan"}, template("travelmate/wifi_scan")).leaf = true
- entry({"admin", "services", "travelmate", "wifiadd"}, cbi("travelmate/wifi_add", {hideresetbtn=true, hidesavebtn=true})).leaf = true
- entry({"admin", "services", "travelmate", "wifiedit"}, cbi("travelmate/wifi_edit", {hideresetbtn=true, hidesavebtn=true})).leaf = true
- entry({"admin", "services", "travelmate", "wifidelete"}, cbi("travelmate/wifi_delete", {hideresetbtn=true, hidesavebtn=true})).leaf = true
- entry({"admin", "services", "travelmate", "wifiorder"}, cbi("travelmate/wifi_order", {hideresetbtn=true, hidesavebtn=true})).leaf = true
+ entry({"admin", "services", "travelmate", "wifiadd"}, form("travelmate/wifi_add", {hideresetbtn=true, hidesavebtn=true})).leaf = true
+ entry({"admin", "services", "travelmate", "wifiedit"}, form("travelmate/wifi_edit", {hideresetbtn=true, hidesavebtn=true})).leaf = true
+ entry({"admin", "services", "travelmate", "wifidelete"}, form("travelmate/wifi_delete", {hideresetbtn=true, hidesavebtn=true})).leaf = true
+ entry({"admin", "services", "travelmate", "wifiorder"}, form("travelmate/wifi_order", {hideresetbtn=true, hidesavebtn=true})).leaf = true
end
function logread()
- local logfile
+ local logfile = ""
if nixio.fs.access("/var/log/messages") then
logfile = util.trim(util.exec("grep -F 'travelmate-' /var/log/messages"))
- else
+ elseif nixio.fs.access("/sbin/logread") then
logfile = util.trim(util.exec("logread -e 'travelmate-'"))
end
templ.render("travelmate/logread", {title = i18n.translate("Travelmate Logfile"), content = logfile})
diff --git a/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/overview_tab.lua b/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/overview_tab.lua
index 860ce2295b..7b6b9658ca 100644
--- a/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/overview_tab.lua
+++ b/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/overview_tab.lua
@@ -73,45 +73,34 @@ o1 = s:option(Flag, "trm_enabled", translate("Enable travelmate"))
o1.default = o1.disabled
o1.rmempty = false
-o2 = s:option(Flag, "trm_automatic", translate("Enable 'automatic' mode"),
- translate("Keep travelmate in an active state. Check every n seconds the connection status, i.e. the uplink availability."))
+o2 = s:option(Flag, "trm_captive", translate("Captive Portal Detection"),
+ translate("Check the internet availability, log captive portal redirections and keep the uplink connection 'alive'."))
o2.default = o2.enabled
o2.rmempty = false
-o3 = s:option(Flag, "trm_captive", translate("Captive Portal Detection"),
- translate("Check the internet availability, log captive portal redirections and keep the uplink connection 'alive'."))
-o3.default = o3.enabled
-o3.rmempty = false
-
-o4 = s:option(ListValue, "trm_iface", translate("Uplink / Trigger interface"),
+o3 = s:option(ListValue, "trm_iface", translate("Uplink / Trigger interface"),
translate("Name of the used uplink interface."))
if dump then
local i, v
for i, v in ipairs(dump.interface) do
if v.interface ~= "loopback" and v.interface ~= "lan" then
- o4:value(v.interface)
+ o3:value(v.interface)
end
end
end
-o4.default = trmiface
-o4.rmempty = false
+o3.default = trmiface
+o3.rmempty = false
-o5 = s:option(Value, "trm_triggerdelay", translate("Trigger Delay"),
- translate("Additional trigger delay in seconds before travelmate processing begins."))
-o5.datatype = "range(1,60)"
-o5.default = 2
-o5.rmempty = false
-
-btn = s:option(Button, "", translate("Manual Rescan"),
- translate("Force a manual uplink rescan / reconnect in 'trigger' mode."))
-btn:depends("trm_automatic", "")
-btn.inputtitle = translate("Rescan")
-btn.inputstyle = "find"
-btn.disabled = false
-
-function btn.write()
- luci.sys.call("env -i /etc/init.d/travelmate start >/dev/null 2>&1")
- luci.http.redirect(luci.dispatcher.build_url("admin", "services", "travelmate"))
+if fs.access("/usr/bin/qrencode") then
+ btn = s:option(Button, "btn", translate("View AP QR-Codes"),
+ translate("Connect your Android or iOS devices to your router's WiFi using the shown QR code."))
+ btn.inputtitle = translate("QR-Codes")
+ btn.inputstyle = "apply"
+ btn.disabled = false
+
+ function btn.write()
+ luci.http.redirect(luci.dispatcher.build_url("admin", "services", "travelmate", "apqr"))
+ end
end
-- Runtime information
@@ -180,28 +169,34 @@ e2 = e:option(Value, "trm_radio", translate("Radio selection"),
e2.datatype = "and(uciname,rangelength(6,6))"
e2.rmempty = true
-e3 = e:option(Value, "trm_maxretry", translate("Connection Limit"),
- translate("Retry limit to connect to an uplink."))
-e3.default = 3
-e3.datatype = "range(1,10)"
+e3 = e:option(Value, "trm_triggerdelay", translate("Trigger Delay"),
+ translate("Additional trigger delay in seconds before travelmate processing begins."))
+e3.datatype = "range(1,60)"
+e3.default = 2
e3.rmempty = false
-e4 = e:option(Value, "trm_minquality", translate("Signal Quality Threshold"),
- translate("Minimum signal quality threshold as percent for conditional uplink (dis-) connections."))
-e4.default = 35
-e4.datatype = "range(20,80)"
+e4 = e:option(Value, "trm_maxretry", translate("Connection Limit"),
+ translate("Retry limit to connect to an uplink."))
+e4.default = 3
+e4.datatype = "range(1,10)"
e4.rmempty = false
-e5 = e:option(Value, "trm_maxwait", translate("Interface Timeout"),
- translate("How long should travelmate wait for a successful wlan uplink connection."))
-e5.default = 30
-e5.datatype = "range(20,40)"
+e5 = e:option(Value, "trm_minquality", translate("Signal Quality Threshold"),
+ translate("Minimum signal quality threshold as percent for conditional uplink (dis-) connections."))
+e5.default = 35
+e5.datatype = "range(20,80)"
e5.rmempty = false
-e6 = e:option(Value, "trm_timeout", translate("Overall Timeout"),
- translate("Timeout in seconds between retries in 'automatic' mode."))
-e6.default = 60
-e6.datatype = "range(30,300)"
+e6 = e:option(Value, "trm_maxwait", translate("Interface Timeout"),
+ translate("How long should travelmate wait for a successful wlan uplink connection."))
+e6.default = 30
+e6.datatype = "range(20,40)"
e6.rmempty = false
+e7 = e:option(Value, "trm_timeout", translate("Overall Timeout"),
+ translate("Overall retry timeout in seconds."))
+e7.default = 60
+e7.datatype = "range(30,300)"
+e7.rmempty = false
+
return m
diff --git a/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/wifi_add.lua b/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/wifi_add.lua
index 50edd17bb8..83011e9dd5 100644
--- a/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/wifi_add.lua
+++ b/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/wifi_add.lua
@@ -26,18 +26,23 @@ m.hidden = {
wpa_version = http.formvalue("wpa_version")
}
-if m.hidden.ssid ~= "" then
- wssid = m:field(Value, "ssid", translate("SSID"))
- wssid.datatype = "rangelength(1,32)"
- wssid.default = m.hidden.ssid or ""
-else
+if m.hidden.ssid == "" then
wssid = m:field(Value, "ssid", translate("SSID (hidden)"))
+else
+ wssid = m:field(Value, "ssid", translate("SSID"))
end
+wssid.datatype = "rangelength(1,32)"
+wssid.default = m.hidden.ssid or ""
nobssid = m:field(Flag, "no_bssid", translate("Ignore BSSID"))
-nobssid.default = nobssid.enabled
+if m.hidden.ssid == "" then
+ nobssid.default = nobssid.disabled
+else
+ nobssid.default = nobssid.enabled
+end
-bssid = m:field(Value, "bssid", translate("BSSID"))
+bssid = m:field(Value, "bssid", translate("BSSID"),
+ translatef("The BSSID information '%s' is optional and only required for hidden networks", m.hidden.bssid or ""))
bssid:depends("no_bssid", 0)
bssid.datatype = "macaddr"
bssid.default = m.hidden.bssid or ""
@@ -171,6 +176,7 @@ function wssid.write(self, section, value)
end
uci:save("wireless")
uci:commit("wireless")
+ luci.sys.call("env -i /bin/ubus call network reload >/dev/null 2>&1")
http.redirect(luci.dispatcher.build_url("admin/services/travelmate/stations"))
end
diff --git a/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/wifi_delete.lua b/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/wifi_delete.lua
index 0c3cc1865b..0a7678f7ed 100644
--- a/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/wifi_delete.lua
+++ b/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/wifi_delete.lua
@@ -9,5 +9,6 @@ if cfg ~= nil then
uci:delete("wireless", cfg)
uci:save("wireless")
uci:commit("wireless")
+ luci.sys.call("env -i /bin/ubus call network reload >/dev/null 2>&1")
end
http.redirect(luci.dispatcher.build_url("admin/services/travelmate/stations"))
diff --git a/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/wifi_edit.lua b/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/wifi_edit.lua
index ee4d342ea1..f3ad762594 100644
--- a/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/wifi_edit.lua
+++ b/applications/luci-app-travelmate/luasrc/model/cbi/travelmate/wifi_edit.lua
@@ -162,6 +162,7 @@ function wssid.write(self, section, value)
end
uci:save("wireless")
uci:commit("wireless")
+ luci.sys.call("env -i /bin/ubus call network reload >/dev/null 2>&1")
m.on_cancel()
end
diff --git a/applications/luci-app-travelmate/luasrc/view/travelmate/ap_qr.htm b/applications/luci-app-travelmate/luasrc/view/travelmate/ap_qr.htm
index 13342a3e66..a92dbe1469 100644
--- a/applications/luci-app-travelmate/luasrc/view/travelmate/ap_qr.htm
+++ b/applications/luci-app-travelmate/luasrc/view/travelmate/ap_qr.htm
@@ -44,9 +44,7 @@ This is free software, licensed under the Apache License, Version 2.0
local e_ssid = string.gsub(ssid,"[\"\\';:, ]",[[\\\%1]])
local e_key = string.gsub(key,"[\"\\';:, ]",[[\\\%1]])
local qrcode = ""
- if nixio.fs.access("/usr/bin/qrencode") then
- qrcode = luci.sys.exec("/usr/bin/qrencode --inline --8bit --type=SVG --output=- 'WIFI:S:\"'" .. e_ssid .. "'\";T:'" .. enc .. "';P:\"'" .. e_key .. "'\";H:'" .. hidden .. "';'")
- end
+ qrcode = luci.sys.exec("/usr/bin/qrencode --inline --8bit --type=SVG --output=- 'WIFI:S:\"'" .. e_ssid .. "'\";T:'" .. enc .. "';P:\"'" .. e_key .. "'\";H:'" .. hidden .. "';'")
-%>
<fieldset class="cbi-section">
<legend>AP on <%=device%> with SSID "<%=ssid%>"</legend>
@@ -58,5 +56,10 @@ This is free software, licensed under the Apache License, Version 2.0
end)
%>
</div>
+<div class="cbi-page-actions right">
+ <form class="inline" action="<%=luci.dispatcher.build_url('admin/services/travelmate/tab_from_cbi')%>" method="post">
+ <input class="cbi-button cbi-button-reset" type="submit" value="<%:Back to overview%>"/>
+ </form>
+</div>
<%+footer%>
diff --git a/applications/luci-app-travelmate/po/ja/travelmate.po b/applications/luci-app-travelmate/po/ja/travelmate.po
index 30f34ef309..535a9db260 100644
--- a/applications/luci-app-travelmate/po/ja/travelmate.po
+++ b/applications/luci-app-travelmate/po/ja/travelmate.po
@@ -12,9 +12,6 @@ msgstr ""
"Plural-Forms: nplurals=1; plural=0;\n"
"Language: ja\n"
-msgid "AP QR-Codes"
-msgstr "AP QR-コード"
-
msgid "Actions"
msgstr "操作"
@@ -65,6 +62,12 @@ msgid ""
msgstr ""
"トラベル ルーター機能を有効化するための、 Travelmate パッケージの設定です。"
+msgid ""
+"Connect your Android or iOS devices to your router's WiFi using the shown QR "
+"code."
+msgstr ""
+"Android や iOS デバイスを、表示される QR コードを使用して WiFi に接続します。"
+
msgid "Connection Limit"
msgstr "接続制限"
@@ -110,9 +113,6 @@ msgstr "無線アップリンク設定の編集"
msgid "Edit this Uplink"
msgstr "このアップリンクを編集"
-msgid "Enable 'automatic' mode"
-msgstr "'automatic' モードの有効化"
-
msgid "Enable travelmate"
msgstr "Travelmate の有効化"
@@ -144,10 +144,6 @@ msgstr "TKIP"
msgid "Force TKIP and CCMP (AES)"
msgstr "TKIP と CCMP (AES)"
-msgid "Force a manual uplink rescan / reconnect in 'trigger' mode."
-msgstr ""
-"'trigger' モード時に、手動でアップリンクの再スキャンと再接続を行います。"
-
msgid ""
"Here you'll find the QR codes from all of your configured Access Points. It "
"allows you to connect your Android or iOS devices to your router's WiFi "
@@ -176,19 +172,9 @@ msgstr "インターフェース タイムアウト"
msgid "Interface Wizard"
msgstr "インターフェース ウィザード"
-msgid ""
-"Keep travelmate in an active state. Check every n seconds the connection "
-"status, i.e. the uplink availability."
-msgstr ""
-"Travelmate をアクティブ状態で維持します。\"実行間隔\" で設定された時間毎"
-"(秒)に、アップリンクの可用性を確認するために接続状態をチェックします"
-
msgid "Last rundate"
msgstr "最終実行日時"
-msgid "Manual Rescan"
-msgstr "手動再スキャン"
-
msgid ""
"Minimum signal quality threshold as percent for conditional uplink (dis-) "
"connections."
@@ -215,6 +201,9 @@ msgstr "デフォルトの設定が適切でない場合、さらに設定する
msgid "Overall Timeout"
msgstr "実行間隔"
+msgid "Overall retry timeout in seconds."
+msgstr ""
+
msgid "Overview"
msgstr "概要"
@@ -246,15 +235,15 @@ msgstr ""
"ンクを追加することができます。現在使用されているアップリンクは、青色で強調さ"
"れます。"
+msgid "QR-Codes"
+msgstr "QR-コード"
+
msgid "Radio selection"
msgstr "無線の選択"
msgid "Repeat scan"
msgstr "再スキャン"
-msgid "Rescan"
-msgstr "再スキャン"
-
msgid "Restrict travelmate to a dedicated radio, e.g. 'radio0'."
msgstr "Travelmate が指定された無線に接続するよう制御します。(例: 'radio0')"
@@ -292,6 +281,10 @@ msgid "Station Radio"
msgstr "ステーション電波"
msgid ""
+"The BSSID information '%s' is optional and only required for hidden networks"
+msgstr ""
+
+msgid ""
"This form allows you to modify the content of the main firewall "
"configuration file (/etc/config/firewall)."
msgstr ""
@@ -326,9 +319,6 @@ msgstr ""
"このフォームには、システムログ内の Travelmate に関するメッセージのみが表示さ"
"れます。"
-msgid "Timeout in seconds between retries in 'automatic' mode."
-msgstr "'automatic' モード時に接続を確認または再試行する間隔(秒)です。"
-
msgid "Travelmate"
msgstr "Travelmate"
@@ -359,6 +349,9 @@ msgstr "アップリンク SSID"
msgid "Uplink interface"
msgstr "アップリンク インターフェース"
+msgid "View AP QR-Codes"
+msgstr "AP QR-コードを確認"
+
msgid "View Logfile"
msgstr "ログファイルの確認"
@@ -397,3 +390,26 @@ msgstr "(不明)"
msgid "n/a"
msgstr "利用不可"
+
+#~ msgid "Enable 'automatic' mode"
+#~ msgstr "'automatic' モードの有効化"
+
+#~ msgid "Force a manual uplink rescan / reconnect in 'trigger' mode."
+#~ msgstr ""
+#~ "'trigger' モード時に、手動でアップリンクの再スキャンと再接続を行います。"
+
+#~ msgid ""
+#~ "Keep travelmate in an active state. Check every n seconds the connection "
+#~ "status, i.e. the uplink availability."
+#~ msgstr ""
+#~ "Travelmate をアクティブ状態で維持します。\"実行間隔\" で設定された時間毎"
+#~ "(秒)に、アップリンクの可用性を確認するために接続状態をチェックします"
+
+#~ msgid "Manual Rescan"
+#~ msgstr "手動再スキャン"
+
+#~ msgid "Rescan"
+#~ msgstr "再スキャン"
+
+#~ msgid "Timeout in seconds between retries in 'automatic' mode."
+#~ msgstr "'automatic' モード時に接続を確認または再試行する間隔(秒)です。"
diff --git a/applications/luci-app-travelmate/po/pt-br/travelmate.po b/applications/luci-app-travelmate/po/pt-br/travelmate.po
index 7cb6ac0613..5ea4d4a0d3 100644
--- a/applications/luci-app-travelmate/po/pt-br/travelmate.po
+++ b/applications/luci-app-travelmate/po/pt-br/travelmate.po
@@ -12,9 +12,6 @@ msgstr ""
"Plural-Forms: nplurals=2; plural=(n > 1);\n"
"Language: pt_BR\n"
-msgid "AP QR-Codes"
-msgstr ""
-
msgid "Actions"
msgstr ""
@@ -62,6 +59,11 @@ msgid ""
"functionality."
msgstr ""
+msgid ""
+"Connect your Android or iOS devices to your router's WiFi using the shown QR "
+"code."
+msgstr ""
+
msgid "Connection Limit"
msgstr ""
@@ -105,9 +107,6 @@ msgstr ""
msgid "Edit this Uplink"
msgstr ""
-msgid "Enable 'automatic' mode"
-msgstr ""
-
msgid "Enable travelmate"
msgstr ""
@@ -137,9 +136,6 @@ msgstr ""
msgid "Force TKIP and CCMP (AES)"
msgstr ""
-msgid "Force a manual uplink rescan / reconnect in 'trigger' mode."
-msgstr ""
-
msgid ""
"Here you'll find the QR codes from all of your configured Access Points. It "
"allows you to connect your Android or iOS devices to your router's WiFi "
@@ -165,17 +161,9 @@ msgstr ""
msgid "Interface Wizard"
msgstr ""
-msgid ""
-"Keep travelmate in an active state. Check every n seconds the connection "
-"status, i.e. the uplink availability."
-msgstr ""
-
msgid "Last rundate"
msgstr ""
-msgid "Manual Rescan"
-msgstr ""
-
msgid ""
"Minimum signal quality threshold as percent for conditional uplink (dis-) "
"connections."
@@ -200,6 +188,9 @@ msgstr ""
msgid "Overall Timeout"
msgstr ""
+msgid "Overall retry timeout in seconds."
+msgstr ""
+
msgid "Overview"
msgstr ""
@@ -227,13 +218,13 @@ msgid ""
"one. The currently used uplink is emphasized in blue."
msgstr ""
-msgid "Radio selection"
+msgid "QR-Codes"
msgstr ""
-msgid "Repeat scan"
+msgid "Radio selection"
msgstr ""
-msgid "Rescan"
+msgid "Repeat scan"
msgstr ""
msgid "Restrict travelmate to a dedicated radio, e.g. 'radio0'."
@@ -273,6 +264,10 @@ msgid "Station Radio"
msgstr ""
msgid ""
+"The BSSID information '%s' is optional and only required for hidden networks"
+msgstr ""
+
+msgid ""
"This form allows you to modify the content of the main firewall "
"configuration file (/etc/config/firewall)."
msgstr ""
@@ -297,9 +292,6 @@ msgid ""
"messages only."
msgstr ""
-msgid "Timeout in seconds between retries in 'automatic' mode."
-msgstr ""
-
msgid "Travelmate"
msgstr "Travelmate"
@@ -330,6 +322,9 @@ msgstr ""
msgid "Uplink interface"
msgstr ""
+msgid "View AP QR-Codes"
+msgstr ""
+
msgid "View Logfile"
msgstr ""
diff --git a/applications/luci-app-travelmate/po/ru/travelmate.po b/applications/luci-app-travelmate/po/ru/travelmate.po
index 0b04e27838..fad31bb849 100644
--- a/applications/luci-app-travelmate/po/ru/travelmate.po
+++ b/applications/luci-app-travelmate/po/ru/travelmate.po
@@ -15,9 +15,6 @@ msgstr ""
"Project-Info: Это технический перевод, не дословный. Главное-удобный русский "
"интерфейс, все проверялось в графическом режиме, совместим с другими apps\n"
-msgid "AP QR-Codes"
-msgstr ""
-
msgid "Actions"
msgstr "Действия"
@@ -65,6 +62,11 @@ msgid ""
"functionality."
msgstr "Настройка утилиты TravelMate - помощника путешественника. "
+msgid ""
+"Connect your Android or iOS devices to your router's WiFi using the shown QR "
+"code."
+msgstr ""
+
msgid "Connection Limit"
msgstr "Ограничение соединений"
@@ -110,9 +112,6 @@ msgstr "Редактировать настройки беспроводной
msgid "Edit this Uplink"
msgstr "Редактировать настройки сети"
-msgid "Enable 'automatic' mode"
-msgstr "Включить режим 'автоматически'"
-
msgid "Enable travelmate"
msgstr "Включить Travelmate"
@@ -144,11 +143,6 @@ msgstr "Назначить TKIP"
msgid "Force TKIP and CCMP (AES)"
msgstr "Назначить TKIP и CCMP (AES)"
-msgid "Force a manual uplink rescan / reconnect in 'trigger' mode."
-msgstr ""
-"Принудительно выполнить повторное сканирование/повторное подключение внешних "
-"сетей в режиме 'ручной'."
-
msgid ""
"Here you'll find the QR codes from all of your configured Access Points. It "
"allows you to connect your Android or iOS devices to your router's WiFi "
@@ -174,19 +168,9 @@ msgstr "Временная задержка интерфейса"
msgid "Interface Wizard"
msgstr "Помощник настройки интерфейса"
-msgid ""
-"Keep travelmate in an active state. Check every n seconds the connection "
-"status, i.e. the uplink availability."
-msgstr ""
-"Поддержка TravelMate в активном состоянии.<br />Проверка состояния "
-"соединения каждые n секунд, т.е. доступность внешней сети."
-
msgid "Last rundate"
msgstr "Дата последнего запуска"
-msgid "Manual Rescan"
-msgstr "Поиск сети вручную"
-
msgid ""
"Minimum signal quality threshold as percent for conditional uplink (dis-) "
"connections."
@@ -213,6 +197,9 @@ msgstr ""
msgid "Overall Timeout"
msgstr "Общее время ожидания"
+msgid "Overall retry timeout in seconds."
+msgstr ""
+
msgid "Overview"
msgstr "Главное меню"
@@ -244,15 +231,15 @@ msgstr ""
"упорядочивать существующий список внешних сетей или выполнять их поиск.<br /"
">Используемое сетевое соединение выделено синим цветом."
+msgid "QR-Codes"
+msgstr ""
+
msgid "Radio selection"
msgstr "Выбор Wi-Fi устройства"
msgid "Repeat scan"
msgstr "Повторить поиск"
-msgid "Rescan"
-msgstr "Пересканировать"
-
msgid "Restrict travelmate to a dedicated radio, e.g. 'radio0'."
msgstr "Выделить TravelMate-у конкретное Wi-Fi устройство, например 'radio0'."
@@ -290,6 +277,10 @@ msgid "Station Radio"
msgstr "Wi-Fi устройство клиента"
msgid ""
+"The BSSID information '%s' is optional and only required for hidden networks"
+msgstr ""
+
+msgid ""
"This form allows you to modify the content of the main firewall "
"configuration file (/etc/config/firewall)."
msgstr ""
@@ -324,11 +315,6 @@ msgstr ""
"Страница просмотра системного журнала, показаны только события связанные с "
"работой утилиты TravelMate."
-msgid "Timeout in seconds between retries in 'automatic' mode."
-msgstr ""
-"Время ожидания в секундах между повторными попытками соединения в режиме "
-"'автоматически'."
-
msgid "Travelmate"
msgstr "TravelMate"
@@ -359,6 +345,9 @@ msgstr "SSID внешней сети"
msgid "Uplink interface"
msgstr "Интерфейс внешней сети"
+msgid "View AP QR-Codes"
+msgstr ""
+
msgid "View Logfile"
msgstr "Показать системный журнал"
@@ -396,6 +385,32 @@ msgstr "скрытый"
msgid "n/a"
msgstr "нет данных"
+#~ msgid "Enable 'automatic' mode"
+#~ msgstr "Включить режим 'автоматически'"
+
+#~ msgid "Force a manual uplink rescan / reconnect in 'trigger' mode."
+#~ msgstr ""
+#~ "Принудительно выполнить повторное сканирование/повторное подключение "
+#~ "внешних сетей в режиме 'ручной'."
+
+#~ msgid ""
+#~ "Keep travelmate in an active state. Check every n seconds the connection "
+#~ "status, i.e. the uplink availability."
+#~ msgstr ""
+#~ "Поддержка TravelMate в активном состоянии.<br />Проверка состояния "
+#~ "соединения каждые n секунд, т.е. доступность внешней сети."
+
+#~ msgid "Manual Rescan"
+#~ msgstr "Поиск сети вручную"
+
+#~ msgid "Rescan"
+#~ msgstr "Пересканировать"
+
+#~ msgid "Timeout in seconds between retries in 'automatic' mode."
+#~ msgstr ""
+#~ "Время ожидания в секундах между повторными попытками соединения в режиме "
+#~ "'автоматически'."
+
#~ msgid ""
#~ "How long should travelmate wait for a successful wlan interface reload."
#~ msgstr ""
diff --git a/applications/luci-app-travelmate/po/templates/travelmate.pot b/applications/luci-app-travelmate/po/templates/travelmate.pot
index e27c61a9d0..8ba17668ec 100644
--- a/applications/luci-app-travelmate/po/templates/travelmate.pot
+++ b/applications/luci-app-travelmate/po/templates/travelmate.pot
@@ -1,9 +1,6 @@
msgid ""
msgstr "Content-Type: text/plain; charset=UTF-8"
-msgid "AP QR-Codes"
-msgstr ""
-
msgid "Actions"
msgstr ""
@@ -51,6 +48,11 @@ msgid ""
"functionality."
msgstr ""
+msgid ""
+"Connect your Android or iOS devices to your router's WiFi using the shown QR "
+"code."
+msgstr ""
+
msgid "Connection Limit"
msgstr ""
@@ -94,9 +96,6 @@ msgstr ""
msgid "Edit this Uplink"
msgstr ""
-msgid "Enable 'automatic' mode"
-msgstr ""
-
msgid "Enable travelmate"
msgstr ""
@@ -126,9 +125,6 @@ msgstr ""
msgid "Force TKIP and CCMP (AES)"
msgstr ""
-msgid "Force a manual uplink rescan / reconnect in 'trigger' mode."
-msgstr ""
-
msgid ""
"Here you'll find the QR codes from all of your configured Access Points. It "
"allows you to connect your Android or iOS devices to your router's WiFi "
@@ -154,17 +150,9 @@ msgstr ""
msgid "Interface Wizard"
msgstr ""
-msgid ""
-"Keep travelmate in an active state. Check every n seconds the connection "
-"status, i.e. the uplink availability."
-msgstr ""
-
msgid "Last rundate"
msgstr ""
-msgid "Manual Rescan"
-msgstr ""
-
msgid ""
"Minimum signal quality threshold as percent for conditional uplink (dis-) "
"connections."
@@ -189,6 +177,9 @@ msgstr ""
msgid "Overall Timeout"
msgstr ""
+msgid "Overall retry timeout in seconds."
+msgstr ""
+
msgid "Overview"
msgstr ""
@@ -216,13 +207,13 @@ msgid ""
"one. The currently used uplink is emphasized in blue."
msgstr ""
-msgid "Radio selection"
+msgid "QR-Codes"
msgstr ""
-msgid "Repeat scan"
+msgid "Radio selection"
msgstr ""
-msgid "Rescan"
+msgid "Repeat scan"
msgstr ""
msgid "Restrict travelmate to a dedicated radio, e.g. 'radio0'."
@@ -262,6 +253,10 @@ msgid "Station Radio"
msgstr ""
msgid ""
+"The BSSID information '%s' is optional and only required for hidden networks"
+msgstr ""
+
+msgid ""
"This form allows you to modify the content of the main firewall "
"configuration file (/etc/config/firewall)."
msgstr ""
@@ -286,9 +281,6 @@ msgid ""
"messages only."
msgstr ""
-msgid "Timeout in seconds between retries in 'automatic' mode."
-msgstr ""
-
msgid "Travelmate"
msgstr ""
@@ -319,6 +311,9 @@ msgstr ""
msgid "Uplink interface"
msgstr ""
+msgid "View AP QR-Codes"
+msgstr ""
+
msgid "View Logfile"
msgstr ""