summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-smartdns/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-smartdns/Makefile')
-rw-r--r--applications/luci-app-smartdns/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/applications/luci-app-smartdns/Makefile b/applications/luci-app-smartdns/Makefile
new file mode 100644
index 0000000000..878fbf7394
--- /dev/null
+++ b/applications/luci-app-smartdns/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright 2018-2020 Nick Peng <pymumu@gmail.com>
+# Licensed to the public under the GPL V3 License.
+
+include $(TOPDIR)/rules.mk
+
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_MAINTAINER:=Nick Peng <pymumu@gmail.com>
+PKG_VERSION:=1.2020.30
+PKG_RELEASE:=1
+
+LUCI_TITLE:=LuCI for smartdns
+LUCI_DESCRIPTION:=Provides Luci for smartdns
+LUCI_DEPENDS:=+smartdns
+LUCI_PKGARCH:=all
+
+define Package/$(PKG_NAME)/config
+# shown in make menuconfig <Help>
+help
+ $(LUCI_TITLE)
+ Version: $(PKG_VERSION)-$(PKG_RELEASE)
+endef
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature