summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-pagekitec
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-pagekitec')
-rw-r--r--applications/luci-app-pagekitec/Makefile2
-rw-r--r--applications/luci-app-pagekitec/htdocs/luci-static/resources/view/pagekitec.js37
-rw-r--r--applications/luci-app-pagekitec/luasrc/model/cbi/pagekitec.lua26
-rw-r--r--applications/luci-app-pagekitec/po/de/pagekitec.po22
-rw-r--r--applications/luci-app-pagekitec/po/uk/pagekitec.po11
-rwxr-xr-xapplications/luci-app-pagekitec/root/etc/uci-defaults/40_luci-pagekitec4
-rw-r--r--applications/luci-app-pagekitec/root/usr/share/luci/menu.d/luci-app-pagekitec.json5
7 files changed, 67 insertions, 40 deletions
diff --git a/applications/luci-app-pagekitec/Makefile b/applications/luci-app-pagekitec/Makefile
index ea61323420..d875009772 100644
--- a/applications/luci-app-pagekitec/Makefile
+++ b/applications/luci-app-pagekitec/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI Support for PageKite
-LUCI_DEPENDS:=+luci-compat +pagekitec
+LUCI_DEPENDS:=+pagekitec
PKG_MAINTAINER:=Karl Palsson <karlp@tweak.net.au>
diff --git a/applications/luci-app-pagekitec/htdocs/luci-static/resources/view/pagekitec.js b/applications/luci-app-pagekitec/htdocs/luci-static/resources/view/pagekitec.js
new file mode 100644
index 0000000000..13161de7a8
--- /dev/null
+++ b/applications/luci-app-pagekitec/htdocs/luci-static/resources/view/pagekitec.js
@@ -0,0 +1,37 @@
+'use strict';
+'require form';
+
+var desc = _(""
+ + "<p/>Note: you need a working PageKite account, or at least, your own running front end for this form to work. "
+ + "Visit <a href='https://pagekite.net/home/'>your account</a> to set up a name for your "
+ + "router and get a secret key for the connection."
+ + "<p/><em>Note: this web configurator only supports "
+ + "some very very basic uses of pagekite.</em>"
+);
+
+return L.view.extend({
+ render: function() {
+ var m, s, o;
+
+ m = new form.Map('pagekitec', _('PageKite'), desc);
+
+ s = m.section(form.TypedSection, 'pagekitec', _("Configuration"));
+ s.anonymous = true;
+
+ o = s.option(form.Value, "kitename", _("Kite Name"));
+ o = s.option(form.Value, "kitesecret", _("Kite Secret"));
+ o.password = true;
+
+ o = s.option(form.Flag, "static", _("Static setup"),
+ _("Static setup, disable FE failover and DDNS updates, set this if you are running your "
+ + "own frontend without a pagekite.me account"));
+ o = s.option(form.Flag, "simple_http", _("Basic HTTP"), _("Enable a tunnel to the local HTTP server (in most cases, this admin interface)"));
+ o = s.option(form.Flag, "simple_ssh", _("Basic SSH"), _("Enable a tunnel to the local SSH server"));
+ o = s.option(form.Value, "simple_ws", _("Basic WebSockets"), _("Enable a WebSockets tunnel on a given local port"));
+ o.placeholder = 8083;
+ o.datatype = "port";
+ o.optional = true;
+
+ return m.render();
+ }
+});
diff --git a/applications/luci-app-pagekitec/luasrc/model/cbi/pagekitec.lua b/applications/luci-app-pagekitec/luasrc/model/cbi/pagekitec.lua
deleted file mode 100644
index 1abd3f79d5..0000000000
--- a/applications/luci-app-pagekitec/luasrc/model/cbi/pagekitec.lua
+++ /dev/null
@@ -1,26 +0,0 @@
-m = Map("pagekitec", translate("PageKite"),
- translate([[
-<p/>Note: you need a working PageKite account, or at least, your own running front end for this form to work.
-Visit <a href="https://pagekite.net/home/">your account</a> to set up a name for your
-router and get a secret key for the connection.
-<p/><em>Note: this web configurator only supports
-some very very basic uses of pagekite.</em>
-]]))
-
-s = m:section(TypedSection, "pagekitec", translate("PageKite"))
-s.anonymous = true
-
-p = s:option(Value, "kitename", translate("Kite Name"))
-p = s:option(Value, "kitesecret", translate("Kite Secret"))
-p.password = true
-p = s:option(Flag, "static", translate("Static Setup"),
- translate([[Static setup, disable FE failover and DDNS updates, set this if you are running your
- own frontend without a pagekite.me account]]))
-
-p = s:option(Flag, "simple_http", translate("Basic HTTP"),
- translate([[Enable a tunnel to the local HTTP server (in most cases, this admin
-site)]]))
-p = s:option(Flag, "simple_ssh", translate("Basic SSH"),
- translate([[Enable a tunnel to the local SSH server]]))
-
-return m
diff --git a/applications/luci-app-pagekitec/po/de/pagekitec.po b/applications/luci-app-pagekitec/po/de/pagekitec.po
index 8aa6a489ec..c8d2dc3f9b 100644
--- a/applications/luci-app-pagekitec/po/de/pagekitec.po
+++ b/applications/luci-app-pagekitec/po/de/pagekitec.po
@@ -1,8 +1,14 @@
msgid ""
msgstr ""
+"PO-Revision-Date: 2020-02-17 11:52+0000\n"
+"Last-Translator: marzzzello <anmeldezeugs@top-email.net>\n"
+"Language-Team: German <https://hosted.weblate.org/projects/openwrt/"
+"luciapplicationspagekitec/de/>\n"
"Language: de\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
+"Plural-Forms: nplurals=2; plural=n != 1;\n"
+"X-Generator: Weblate 3.11-dev\n"
#: applications/luci-app-pagekitec/luasrc/model/cbi/pagekitec.lua:2
msgid ""
@@ -12,6 +18,12 @@ msgid ""
"for the connection. <p/><em>Note: this web configurator only supports some "
"very very basic uses of pagekite.</em>"
msgstr ""
+"<p/>Hinweis: Damit dieses Formular funktioniert wird ein funktionierendes "
+"PageKite-Konto oder zumindest ein eigenes laufendes Frontend benötigt. "
+"Besuche <a href=\"https://pagekite.net/home/\">Dein Konto</a>, um einen "
+"Namen für deinen Router einzurichten und einen geheimen Schlüssel für die "
+"Verbindung zu erhalten. <p/><em>Hinweis: Dieser Web-Konfigurator unterstützt "
+"nur einige sehr einfache Anwendungen von Pagekite.</em>"
#: applications/luci-app-pagekitec/luasrc/model/cbi/pagekitec.lua:20
msgid "Basic HTTP"
@@ -25,24 +37,26 @@ msgstr ""
msgid ""
"Enable a tunnel to the local HTTP server (in most cases, this admin site)"
msgstr ""
+"Aktiviere einen Tunnel zum lokalen HTTP-Server (in den meisten Fällen diese "
+"Administrationsseite)"
#: applications/luci-app-pagekitec/luasrc/model/cbi/pagekitec.lua:24
msgid "Enable a tunnel to the local SSH server"
-msgstr ""
+msgstr "Aktiviere einen Tunnel zum lokalen SSH-Server"
#: applications/luci-app-pagekitec/luasrc/model/cbi/pagekitec.lua:13
msgid "Kite Name"
-msgstr ""
+msgstr "Kite Name"
#: applications/luci-app-pagekitec/luasrc/model/cbi/pagekitec.lua:14
msgid "Kite Secret"
-msgstr ""
+msgstr "Kite Geheimnis"
#: applications/luci-app-pagekitec/luasrc/model/cbi/pagekitec.lua:1
#: applications/luci-app-pagekitec/luasrc/model/cbi/pagekitec.lua:10
#: applications/luci-app-pagekitec/root/usr/share/luci/menu.d/luci-app-pagekitec.json:3
msgid "PageKite"
-msgstr ""
+msgstr "PageKite"
#: applications/luci-app-pagekitec/luasrc/model/cbi/pagekitec.lua:16
msgid "Static Setup"
diff --git a/applications/luci-app-pagekitec/po/uk/pagekitec.po b/applications/luci-app-pagekitec/po/uk/pagekitec.po
index c3fabf1374..5d43af5296 100644
--- a/applications/luci-app-pagekitec/po/uk/pagekitec.po
+++ b/applications/luci-app-pagekitec/po/uk/pagekitec.po
@@ -1,8 +1,15 @@
msgid ""
msgstr ""
+"PO-Revision-Date: 2020-02-17 11:52+0000\n"
+"Last-Translator: Olexandr Nesterenko <olexn@ukr.net>\n"
+"Language-Team: Ukrainian <https://hosted.weblate.org/projects/openwrt/"
+"luciapplicationspagekitec/uk/>\n"
"Language: uk\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
+"Plural-Forms: nplurals=3; plural=n%10==1 && n%100!=11 ? 0 : n%10>=2 && n%10<="
+"4 && (n%100<10 || n%100>=20) ? 1 : 2;\n"
+"X-Generator: Weblate 3.11-dev\n"
#: applications/luci-app-pagekitec/luasrc/model/cbi/pagekitec.lua:2
msgid ""
@@ -15,11 +22,11 @@ msgstr ""
#: applications/luci-app-pagekitec/luasrc/model/cbi/pagekitec.lua:20
msgid "Basic HTTP"
-msgstr ""
+msgstr "Базовий HTTP"
#: applications/luci-app-pagekitec/luasrc/model/cbi/pagekitec.lua:23
msgid "Basic SSH"
-msgstr ""
+msgstr "Базовий SSH"
#: applications/luci-app-pagekitec/luasrc/model/cbi/pagekitec.lua:21
msgid ""
diff --git a/applications/luci-app-pagekitec/root/etc/uci-defaults/40_luci-pagekitec b/applications/luci-app-pagekitec/root/etc/uci-defaults/40_luci-pagekitec
deleted file mode 100755
index d7bfee271d..0000000000
--- a/applications/luci-app-pagekitec/root/etc/uci-defaults/40_luci-pagekitec
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-
-rm -f /tmp/luci-indexcache
-exit 0
diff --git a/applications/luci-app-pagekitec/root/usr/share/luci/menu.d/luci-app-pagekitec.json b/applications/luci-app-pagekitec/root/usr/share/luci/menu.d/luci-app-pagekitec.json
index 54af904c51..fbbda3a268 100644
--- a/applications/luci-app-pagekitec/root/usr/share/luci/menu.d/luci-app-pagekitec.json
+++ b/applications/luci-app-pagekitec/root/usr/share/luci/menu.d/luci-app-pagekitec.json
@@ -2,9 +2,8 @@
"admin/services/pagekitec": {
"title": "PageKite",
"action": {
- "type": "cbi",
- "path": "pagekitec",
- "post": { "cbi.submit": true }
+ "type": "view",
+ "path": "pagekitec"
}
}
}