summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-lxc
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-lxc')
-rw-r--r--applications/luci-app-lxc/Makefile2
-rw-r--r--applications/luci-app-lxc/luasrc/controller/lxc.lua122
-rw-r--r--applications/luci-app-lxc/luasrc/model/cbi/lxc.lua43
-rw-r--r--applications/luci-app-lxc/luasrc/view/lxc.htm129
4 files changed, 184 insertions, 112 deletions
diff --git a/applications/luci-app-lxc/Makefile b/applications/luci-app-lxc/Makefile
index 85cae5c405..379cccbfc9 100644
--- a/applications/luci-app-lxc/Makefile
+++ b/applications/luci-app-lxc/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=LXC management Web UI
-LUCI_DEPENDS:=+luci-mod-admin-full +lxc +lxc-attach +lxc-console +lxc-create +liblxc +rpcd-mod-lxc +getopt
+LUCI_DEPENDS:=+luci-mod-admin-full +lxc +lxc-attach +lxc-console +lxc-create +liblxc +rpcd-mod-lxc +getopt +!LXC_BUSYBOX_OPTIONS:tar
LUCI_PKGARCH:=all
PKG_MAINTAINER:=Petar Koretic <petar.koretic@sartura.hr>
diff --git a/applications/luci-app-lxc/luasrc/controller/lxc.lua b/applications/luci-app-lxc/luasrc/controller/lxc.lua
index cc490f0b81..f14606ee81 100644
--- a/applications/luci-app-lxc/luasrc/controller/lxc.lua
+++ b/applications/luci-app-lxc/luasrc/controller/lxc.lua
@@ -14,74 +14,43 @@ Author: Petar Koretic <petar.koretic@sartura.hr>
]]--
-local uci = require "luci.model.uci"
-local util = require "luci.util"
-local nixio = require "nixio"
-
module("luci.controller.lxc", package.seeall)
-function fork_exec(command)
- local pid = nixio.fork()
- if pid > 0 then
- return
- elseif pid == 0 then
- -- change to root dir
- nixio.chdir("/")
-
- -- patch stdin, out, err to /dev/null
- local null = nixio.open("/dev/null", "w+")
- if null then
- nixio.dup(null, nixio.stderr)
- nixio.dup(null, nixio.stdout)
- nixio.dup(null, nixio.stdin)
- if null:fileno() > 2 then
- null:close()
- end
- end
+local uci = require "luci.model.uci".cursor()
+local util = require "luci.util"
+local fs = require "nixio"
- -- replace with target command
- nixio.exec("/bin/sh", "-c", command)
+function index()
+ if not nixio.fs.access("/etc/config/lxc") then
+ return
end
-end
-function index()
page = node("admin", "services", "lxc")
page.target = cbi("lxc")
page.title = _("LXC Containers")
page.order = 70
- page = entry({"admin", "services", "lxc_create"}, call("lxc_create"), nil)
- page.leaf = true
-
- page = entry({"admin", "services", "lxc_action"}, call("lxc_action"), nil)
- page.leaf = true
-
- page = entry({"admin", "services", "lxc_get_downloadable"}, call("lxc_get_downloadable"), nil)
- page.leaf = true
-
- page = entry({"admin", "services", "lxc_configuration_get"}, call("lxc_configuration_get"), nil)
- page.leaf = true
-
- page = entry({"admin", "services", "lxc_configuration_set"}, call("lxc_configuration_set"), nil)
- page.leaf = true
-
+ entry({"admin", "services", "lxc_create"}, call("lxc_create"), nil).leaf = true
+ entry({"admin", "services", "lxc_action"}, call("lxc_action"), nil).leaf = true
+ entry({"admin", "services", "lxc_get_downloadable"}, call("lxc_get_downloadable"), nil).leaf = true
+ entry({"admin", "services", "lxc_configuration_get"}, call("lxc_configuration_get"), nil).leaf = true
+ entry({"admin", "services", "lxc_configuration_set"}, call("lxc_configuration_set"), nil).leaf = true
end
function lxc_get_downloadable()
local target = lxc_get_arch_target()
local templates = {}
+ local ssl_status = lxc_get_ssl_status()
- local f = io.popen('sh /usr/share/lxc/templates/lxc-download --list --no-validate --server %s'
- % util.shellquote(uci.cursor():get("lxc", "lxc", "url")), 'r')
-
+ local f = io.popen('sh /usr/share/lxc/templates/lxc-download --list %s --server %s 2>/dev/null'
+ %{ ssl_status, util.shellquote(uci:get("lxc", "lxc", "url")) }, 'r')
local line
for line in f:lines() do
local dist, version, dist_target = line:match("^(%S+)%s+(%S+)%s+(%S+)%s+default%s+%S+$")
- if dist and version and dist_target == target then
+ if dist and version and dist_target and dist_target == target then
templates[#templates+1] = "%s:%s" %{ dist, version }
end
end
-
f:close()
luci.http.prepare_content("application/json")
@@ -91,23 +60,26 @@ end
function lxc_create(lxc_name, lxc_template)
luci.http.prepare_content("text/plain")
- if not pcall(dofile, "/etc/openwrt_release") then
- return luci.http.write("1")
+ local check = lxc_get_config_path()
+ if not check then
+ return
end
- local lxc_dist, lxc_release = lxc_template:match("^(.+):(.+)$")
+ local ssl_status = lxc_get_ssl_status()
+ local src_err
+ local lxc_dist, lxc_release = lxc_template:match("^(.+):(.+)$")
luci.http.write(util.ubus("lxc", "create", {
name = lxc_name,
template = "download",
args = {
- "--server", uci.cursor():get("lxc", "lxc", "url"),
- "--no-validate",
+ "--server", uci:get("lxc", "lxc", "url"),
"--dist", lxc_dist,
"--release", lxc_release,
- "--arch", lxc_get_arch_target()
+ "--arch", lxc_get_arch_target(),
+ ssl_status
}
- }))
+ }), src_err)
end
function lxc_action(lxc_action, lxc_name)
@@ -121,11 +93,28 @@ function lxc_get_config_path()
local f = io.open("/etc/lxc/lxc.conf", "r")
local content = f:read("*all")
f:close()
+
local ret = content:match('^%s*lxc.lxcpath%s*=%s*([^%s]*)')
if ret then
- return ret .. "/"
+ if nixio.fs.access(ret) then
+ local min_space = tonumber(uci:get("lxc", "lxc", "min_space")) or 100000
+ local free_space = tonumber(util.exec("df " ..ret.. " | awk '{if(NR==2)print $4}'"))
+ if free_space and free_space >= min_space then
+ local min_temp = tonumber(uci:get("lxc", "lxc", "min_temp")) or 100000
+ local free_temp = tonumber(util.exec("df /tmp | awk '{if(NR==2)print $4}'"))
+ if free_temp and free_temp >= min_temp then
+ return ret .. "/"
+ else
+ util.perror("lxc error: not enough temporary space (< " ..min_temp.. " KB)")
+ end
+ else
+ util.perror("lxc error: not enough space (< " ..min_space.. " KB)")
+ end
+ else
+ util.perror("lxc error: directory not found")
+ end
else
- return "/srv/lxc/"
+ util.perror("lxc error: config path is empty")
end
end
@@ -143,14 +132,15 @@ function lxc_configuration_set(lxc_name)
luci.http.prepare_content("text/plain")
local lxc_configuration = luci.http.formvalue("lxc_configuration")
-
if lxc_configuration == nil then
- return luci.http.write("1")
+ util.perror("lxc error: config formvalue is empty")
+ return
end
local f, err = io.open(lxc_get_config_path() .. lxc_name .. "/config","w+")
if not f then
- return luci.http.write("2")
+ util.perror("lxc error: config file not found")
+ return
end
f:write(lxc_configuration)
@@ -160,7 +150,7 @@ function lxc_configuration_set(lxc_name)
end
function lxc_get_arch_target()
- local target = nixio.uname().machine
+ local target = fs.uname().machine
local target_map = {
armv5 = "armel",
armv6 = "armel",
@@ -168,13 +158,21 @@ function lxc_get_arch_target()
armv8 = "arm64",
x86_64 = "amd64"
}
-
local k, v
for k, v in pairs(target_map) do
- if target:find(k) then
+ if target:find("^" ..k.. "$") then
return v
end
end
-
return target
end
+
+function lxc_get_ssl_status()
+ local ssl_enabled = uci:get("lxc", "lxc", "ssl_enabled")
+ local ssl_status = "--no-validate"
+
+ if ssl_enabled and ssl_enabled == "1" then
+ ssl_status = ""
+ end
+ return ssl_status
+end
diff --git a/applications/luci-app-lxc/luasrc/model/cbi/lxc.lua b/applications/luci-app-lxc/luasrc/model/cbi/lxc.lua
index ac0fdff332..8a8fc2be0d 100644
--- a/applications/luci-app-lxc/luasrc/model/cbi/lxc.lua
+++ b/applications/luci-app-lxc/luasrc/model/cbi/lxc.lua
@@ -14,18 +14,35 @@ Author: Petar Koretic <petar.koretic@sartura.hr>
]]--
-local fs = require "nixio.fs"
-
-m = Map("lxc", translate("LXC Containers"))
-
-if fs.access("/etc/config/lxc") then
- m:section(SimpleSection).template = "lxc"
-
- s = m:section(TypedSection, "lxc", translate("Options"))
- s.anonymous = true
- s.addremove = false
-
- s:option(Value, "url", translate("Containers URL"))
-end
+m = Map("lxc", translate("LXC Containers"),
+ translate("<b>Please note:</b> For LXC Containers you need a custom OpenWrt image.<br />")
+ .. translate("The image should include at least support for 'kernel cgroups', 'kernel namespaces' and 'miscellaneous LXC related options'."))
+m:section(SimpleSection).template = "lxc"
+
+s = m:section(TypedSection, "lxc", translate("Options"))
+s.anonymous = true
+
+o1 = s:option(Value, "url", translate("Containers URL"))
+o1:value("images.linuxcontainers.org")
+o1:value("repo.turris.cz/lxc", "repo.turris.cz/lxc (SSL req.)")
+o1.default = "images.linuxcontainers.org"
+o1.rmempty = false
+
+o2 = s:option(Flag, "ssl_enabled", translate("Enable SSL"),
+ translate("Enable optional SSL encryption support. This requires additional packages like 'wget', 'ca-certificates', 'gnupg' and 'gnupg-utils'."))
+o2.default = o2.disabled
+o2.rmempty = false
+
+o3 = s:option(Value, "min_space", translate("Free Space Threshold"),
+ translate("Minimum required free space for LXC Container creation in KB"))
+o3.default = "100000"
+o3.datatype = "min(50000)"
+o3.rmempty = false
+
+o4 = s:option(Value, "min_temp", translate("Free Temp Threshold"),
+ translate("Minimum required free temp space for LXC Container creation in KB"))
+o4.default = "100000"
+o4.datatype = "min(50000)"
+o4.rmempty = false
return m
diff --git a/applications/luci-app-lxc/luasrc/view/lxc.htm b/applications/luci-app-lxc/luasrc/view/lxc.htm
index edfff8e063..e02c3a7888 100644
--- a/applications/luci-app-lxc/luasrc/view/lxc.htm
+++ b/applications/luci-app-lxc/luasrc/view/lxc.htm
@@ -14,6 +14,32 @@ Author: Petar Koretic <petar.koretic@sartura.hr>
-%>
+<%
+local fs = require "nixio"
+local target = fs.uname().machine
+%>
+
+<style type="text/css">
+table.cbi-section-table th,
+table.cbi-section-table td,
+.cbi-section-table-cell,
+.cbi-input-select,
+.cbi-input-text
+{
+ text-align:left;
+ vertical-align:top;
+ padding-left:2px;
+ margin-right:auto;
+ margin-left:0px;
+}
+
+.cbi-input-select,
+.cbi-input-text
+{
+ width:15em;
+}
+</style>
+
<fieldset class="cbi-section">
<legend><%:Available Containers%></legend>
<div class="cbi-section-node">
@@ -43,7 +69,7 @@ Author: Petar Koretic <petar.koretic@sartura.hr>
</tr>
<tr id="tr_holder">
<td>
- <input type="text" id="tx_name" placeholder="<%:Enter new name%>" value='' />
+ <input class="cbi-input-text" type="text" id="tx_name" placeholder="<%:Enter new name%>" value='' />
</td>
<td>
<select id="s_template" class="cbi-input-select cbi-button">
@@ -65,23 +91,25 @@ Author: Petar Koretic <petar.koretic@sartura.hr>
<hr/>
<script type="text/javascript" src="<%=resource%>/cbi.js"></script>
-<script type="text/javascript">//<![CDATA[
-
- window.img = { "red" : "<%=resource%>/cbi/red.gif", "green" : "<%=resource%>/cbi/green.gif", "purple" : "<%=resource%>/cbi/purple.gif" }
- window.states = { "STOPPED" : "red", "RUNNING" : "green", "FROZEN" : "purple"}
+<script type="text/javascript">
+//<![CDATA[
+ window.img = { "red" : "<%=resource%>/cbi/red.gif", "green" : "<%=resource%>/cbi/green.gif", "purple" : "<%=resource%>/cbi/purple.gif" }
+ window.states = { "STOPPED" : "red", "RUNNING" : "green", "FROZEN" : "purple" }
- var t_lxc_list = document.getElementById('t_lxc_list');
- var loader_html = '<img src="<%=resource%>/icons/loading.gif" alt="<%:Loading%>" width="16" height="16" style="vertical-align:middle" /> ';
+ var t_lxc_list = document.getElementById('t_lxc_list');
+ var loader_html = '<img src="<%=resource%>/icons/loading.gif" alt="<%:Loading%>" width="16" height="16" style="vertical-align:middle" />';
var timeout_msg = 0
var output_list = document.getElementById("lxc-list-output")
- var output_add = document.getElementById("lxc-add-output")
- var loader_add = document.getElementById("lxc-add-loader")
+ var output_add = document.getElementById("lxc-add-output")
+ var loader_add = document.getElementById("lxc-add-loader")
+
+ info_message(output_add, "Template download in progress, please be patient!", 10000)
function lxc_create(tr)
{
- var lxc_name = tr.querySelector("#tx_name").value.trim()
+ var lxc_name = tr.querySelector("#tx_name").value.replace(/[\s!@#$%^&*()+=\[\]{};':"\\|,<>\/?]/g,'')
var lxc_template = tr.querySelector("#s_template").value
- var bt_create = tr.querySelector("#bt_create")
+ var bt_create = tr.querySelector("#bt_create")
if (t_lxc_list.querySelector("[data-id='" + lxc_name + "']") != null)
return info_message(output_add, "Container with that name already exists!", 4000)
@@ -92,7 +120,13 @@ Author: Petar Koretic <petar.koretic@sartura.hr>
if (!lxc_name || !lxc_name.length)
{
bt_create.disabled = false
- return info_message(output_add, "Name cannot be empty!", 4000)
+ return info_message(output_add, "The 'Name' field must not be empty!", 4000)
+ }
+
+ if (!lxc_template)
+ {
+ bt_create.disabled = false
+ return info_message(output_add, "The 'Template' field must not be empty!", 4000)
}
loading(loader_add)
@@ -101,6 +135,7 @@ Author: Petar Koretic <petar.koretic@sartura.hr>
function(x)
{
bt_create.disabled = false
+
loading(loader_add, 0)
if (!x)
@@ -116,16 +151,16 @@ Author: Petar Koretic <petar.koretic@sartura.hr>
var actions = ''
actions += '<input type="button" onclick="action_handler(this)" data-action="start" value="<%:Start%>" class="cbi-button cbi-button-apply" />'
- actions+= '<input type="button" onclick="action_handler(this)" data-action="stop" value="<%:Stop%>" class="cbi-button cbi-button-reset" />'
- actions+= '<input type="button" onclick="action_handler(this)" data-action="destroy" value="<%:Delete%>" class="cbi-button cbi-button-remove" />'
- actions+= ' <select class="cbi-input-select cbi-button" onchange="action_more_handler(this)">\
- <option selected disabled>more</option>\
+ actions += '&#160;<input type="button" onclick="action_handler(this)" data-action="stop" value="<%:Stop%>" class="cbi-button cbi-button-reset" />'
+ actions += '&#160;<input type="button" onclick="action_handler(this)" data-action="destroy" value="<%:Delete%>" class="cbi-button cbi-button-remove" />'
+ actions += '&#160;<select class="cbi-input-select cbi-button" onchange="action_more_handler(this)">\
+ <option selected="selected" disabled="disabled">more</option>\
<option>configure</option>\
<option>freeze</option>\
<option>unfreeze</option>\
<option>reboot</option>\
</select>'
- actions+= '<span data-loader style="display:inline-block; width:16px; height:16px; margin:0 5px"></span>'
+ actions += '<span data-loader="" style="display:inline-block; width:16px; height:16px; margin:0 5px"></span>'
var row = t_lxc_list.insertRow(-1)
var cell = row.insertCell(-1)
@@ -144,12 +179,11 @@ Author: Petar Koretic <petar.koretic@sartura.hr>
function action_handler(self)
{
- var action = self.getAttribute("data-action");
-
- var bt_action = self
- var lxc_name = self.parentNode.parentNode.children[0].getAttribute('data-id')
+ var action = self.getAttribute("data-action");
+ var bt_action = self
+ var lxc_name = self.parentNode.parentNode.children[0].getAttribute('data-id')
var status_img = self.parentNode.parentNode.querySelector('img')
- var loader = self.parentNode.querySelector('[data-loader]')
+ var loader = self.parentNode.querySelector('[data-loader]')
bt_action.disabled = true
@@ -181,18 +215,24 @@ Author: Petar Koretic <petar.koretic@sartura.hr>
loading(loader, 0)
bt_action.disabled = false
- //FIXME: uncomment after fixing 'lxc-start'
if (!x /*|| ec */)
return info_message(output_list,"Action failed!")
- //FIXME: uncomment after fixing 'lxc-start'
- //set_status(status_img, "green")
+ set_status(status_img, "green")
});
}
else if (action == "destroy")
{
- if (!confirm("This will completely remove LXC container from the disk. Are you sure? (container will be stopped if running)"))
+ var tr = self.parentNode.parentNode
+ var img = tr.querySelector('img')
+ if (img.getAttribute('src') != window.img["red"])
+ {
+ bt_action.disabled = false
+ return info_message(output_list,"Container is still running!")
+ }
+
+ if (!confirm("This will completely remove a stopped LXC container from disk. Are you sure?"))
return
loading(loader)
@@ -253,13 +293,12 @@ Author: Petar Koretic <petar.koretic@sartura.hr>
function action_more_handler(self)
{
var lxc_name = self.parentNode.parentNode.querySelector('[data-id]').getAttribute('data-id')
- var loader = self.parentNode.parentNode.querySelector('[data-loader]')
-
- var option = self.options[self.selectedIndex].text
+ var loader = self.parentNode.parentNode.querySelector('[data-loader]')
+ var option = self.options[self.selectedIndex].text
self.value = "more"
- switch (option)
+ switch(option)
{
case "configure":
var tr = document.createElement('tr')
@@ -352,10 +391,22 @@ Author: Petar Koretic <petar.koretic@sartura.hr>
var row = t_lxc_list.insertRow(-1);
row.id = 'empty'
var cell = row.insertCell(0);
- cell.colSpan = 4;
+ cell.colSpan = 3;
cell.innerHTML = '<em><br />There are no containers available yet.</em>';
}
+ function set_empty_template()
+ {
+ var row_count = t_lxc_create.rows.length;
+ while(--row_count) t_lxc_create.deleteRow(row_count);
+
+ var row = t_lxc_create.insertRow(-1);
+ row.id = 'tr_holder'
+ var cell = row.insertCell(0);
+ cell.colSpan = 3;
+ cell.innerHTML = '<em><br />There are no templates for your architecture (<%=target%>) available, please select another containers URL.</em>';
+ }
+
function lxc_list_update()
{
XHR.poll(4, '<%=luci.dispatcher.build_url("admin", "services")%>/lxc_action/list', null,
@@ -363,8 +414,11 @@ Author: Petar Koretic <petar.koretic@sartura.hr>
{
if (!x) return;
+ if (!data)
+ return set_empty(t_lxc_list)
+
var lxc_count = Object.keys(data).length
- if (!data || !lxc_count)
+ if (!lxc_count)
return set_empty(t_lxc_list)
if (document.getElementById('empty') !== null)
@@ -443,8 +497,11 @@ Author: Petar Koretic <petar.koretic@sartura.hr>
{
if (!x) return;
- var lxc_count = Object.keys(data).length
- if (!data || !lxc_count) return;
+ if (!data) return set_empty_template();
+
+ var lxc_count = Object.keys(data).length;
+ if (!lxc_count) return set_empty_template();
+
var select = document.getElementById("s_template");
for(var key in data)
{
@@ -454,5 +511,5 @@ Author: Petar Koretic <petar.koretic@sartura.hr>
select.add(option, -1);
}
})
-
-//]]></script>
+//]]>
+</script>