summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-https-dns-proxy
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-https-dns-proxy')
-rw-r--r--applications/luci-app-https-dns-proxy/Makefile2
-rw-r--r--applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/status/include/71_https-dns-proxy.js75
-rw-r--r--applications/luci-app-https-dns-proxy/po/es/https-dns-proxy.po64
-rw-r--r--applications/luci-app-https-dns-proxy/po/pl/https-dns-proxy.po12
-rw-r--r--applications/luci-app-https-dns-proxy/po/ru/https-dns-proxy.po12
-rw-r--r--applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot11
-rw-r--r--applications/luci-app-https-dns-proxy/po/tr/https-dns-proxy.po6
-rw-r--r--applications/luci-app-https-dns-proxy/po/zh_Hans/https-dns-proxy.po11
8 files changed, 94 insertions, 99 deletions
diff --git a/applications/luci-app-https-dns-proxy/Makefile b/applications/luci-app-https-dns-proxy/Makefile
index 20e3be869e..f546806849 100644
--- a/applications/luci-app-https-dns-proxy/Makefile
+++ b/applications/luci-app-https-dns-proxy/Makefile
@@ -7,7 +7,7 @@ PKG_NAME:=luci-app-https-dns-proxy
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
PKG_VERSION:=2023.11.19
-PKG_RELEASE:=r2
+PKG_RELEASE:=r3
LUCI_TITLE:=DNS Over HTTPS Proxy Web UI
LUCI_DESCRIPTION:=Provides Web UI for DNS Over HTTPS Proxy
diff --git a/applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/status/include/71_https-dns-proxy.js b/applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/status/include/71_https-dns-proxy.js
index 1f22f6d6d7..8723b6e653 100644
--- a/applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/status/include/71_https-dns-proxy.js
+++ b/applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/status/include/71_https-dns-proxy.js
@@ -105,46 +105,47 @@ return baseclass.extend({
);
var rows = [];
- Object.values(reply.runtime.instances).forEach((element) => {
- var resolver;
- var address;
- var port;
- var name;
- var option;
- var found;
- element.command.forEach((param, index, arr) => {
- if (param === "-r") resolver = arr[index + 1];
- if (param === "-a") address = arr[index + 1];
- if (param === "-p") port = arr[index + 1];
- });
- resolver = resolver || "Unknown";
- address = address || "127.0.0.1";
- port = port || "Unknown";
- reply.providers.forEach((prov) => {
- let regexp = pkg.templateToRegexp(prov.template);
- if (!found && regexp.test(resolver)) {
- found = true;
- name = _(prov.title);
- let match = resolver.match(regexp);
- if (match[1] != null) {
- if (
- prov.params &&
- prov.params.option &&
- prov.params.option.options
- ) {
- prov.params.option.options.forEach((opt) => {
- if (opt.value === match[1]) option = _(opt.description);
- });
- name += " (" + option + ")";
- } else {
- if (match[1] !== "") name += " (" + match[1] + ")";
+ if (reply.runtime.instances) {
+ Object.values(reply.runtime.instances).forEach((element) => {
+ var resolver;
+ var address;
+ var port;
+ var name;
+ var option;
+ var found;
+ element.command.forEach((param, index, arr) => {
+ if (param === "-r") resolver = arr[index + 1];
+ if (param === "-a") address = arr[index + 1];
+ if (param === "-p") port = arr[index + 1];
+ });
+ resolver = resolver || "Unknown";
+ address = address || "127.0.0.1";
+ port = port || "Unknown";
+ reply.providers.forEach((prov) => {
+ let regexp = pkg.templateToRegexp(prov.template);
+ if (!found && regexp.test(resolver)) {
+ found = true;
+ name = _(prov.title);
+ let match = resolver.match(regexp);
+ if (match[1] != null) {
+ if (
+ prov.params &&
+ prov.params.option &&
+ prov.params.option.options
+ ) {
+ prov.params.option.options.forEach((opt) => {
+ if (opt.value === match[1]) option = _(opt.description);
+ });
+ name += " (" + option + ")";
+ } else {
+ if (match[1] !== "") name += " (" + match[1] + ")";
+ }
}
}
- }
+ });
+ rows.push([name, address, port, forceDnsText]);
});
- rows.push([name, address, port, forceDnsText]);
- });
-
+ }
cbi_update_table(table, rows, E("em", _("There are no active instances.")));
return table;
diff --git a/applications/luci-app-https-dns-proxy/po/es/https-dns-proxy.po b/applications/luci-app-https-dns-proxy/po/es/https-dns-proxy.po
index 6dcbeac22b..e867d88f8a 100644
--- a/applications/luci-app-https-dns-proxy/po/es/https-dns-proxy.po
+++ b/applications/luci-app-https-dns-proxy/po/es/https-dns-proxy.po
@@ -2,8 +2,8 @@ msgid ""
msgstr ""
"Project-Id-Version: \n"
"POT-Creation-Date: \n"
-"PO-Revision-Date: 2024-04-08 08:55+0000\n"
-"Last-Translator: Salvador Peña <salvadorp74@hotmail.com>\n"
+"PO-Revision-Date: 2024-04-11 03:16+0000\n"
+"Last-Translator: gallegonovato <fran-carro@hotmail.es>\n"
"Language-Team: Spanish <https://hosted.weblate.org/projects/openwrt/"
"luciapplicationshttps-dns-proxy/es/>\n"
"Language: es\n"
@@ -91,11 +91,11 @@ msgstr "DNS de arranque"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/net.cfiec.dns.json:2
msgid "CFIEC Public IPv6 Only DNS (CN)"
-msgstr ""
+msgstr "CFIEC DNS público solo IPv6 (CN)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/ca.cira.canadianshield.json:2
msgid "CIRA Canadian Shield"
-msgstr ""
+msgstr "Escudo canadiense CIRA"
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js:168
msgid "Canary Domains Mozilla"
@@ -107,7 +107,7 @@ msgstr "Dominios iCloud Canary"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/org.cleanbrowsing.doh.json:2
msgid "CleanBrowsing"
-msgstr ""
+msgstr "CleanBrowsing"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.cloudflare-dns.json:2
msgid "Cloudflare"
@@ -115,15 +115,15 @@ msgstr "Cloudflare"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/app.tiarap.doh.json:18
msgid "Cloudlfare Cached"
-msgstr ""
+msgstr "Cloudflare Cached"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/one.comss.dns.json:2
msgid "Comss DNS (RU)"
-msgstr ""
+msgstr "Comss DNS (RU)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.controld.freedns.json:2
msgid "ControlD"
-msgstr ""
+msgstr "ControlD"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.dnsforfamily.dns-doh.json:2
msgid "DNS For Family"
@@ -131,15 +131,15 @@ msgstr "DNS para la familia"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/de.dnsforge.json:2
msgid "DNS Forge (DE)"
-msgstr ""
+msgstr "DNS Forge (DE)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/pub.doh.json:2
msgid "DNSPod Public DNS (CN)"
-msgstr ""
+msgstr "DNSPod Public DNS (CN)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.dnslify.doh.json:2
msgid "DNSlify DNS"
-msgstr ""
+msgstr "DNSlify DNS"
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js:377
msgid "DSCP Codepoint"
@@ -151,11 +151,11 @@ msgstr "DNS de DeCloudUs"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:14
msgid "Default (Blocks ads and trackers)"
-msgstr ""
+msgstr "Por defecto (bloquea anuncios y rastreadores)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/ch.digitale-gesellschaft.dns.json:2
msgid "Digitale Gesellschaft (CH)"
-msgstr ""
+msgstr "Digitale Gesellschaft (CH)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/app.tiarap.doh.json:14
msgid "Direct"
@@ -175,11 +175,11 @@ msgstr "No actualizar las configuraciones"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/cn.360.doh.json:2
msgid "DoH 360 DNS (CN)"
-msgstr ""
+msgstr "DoH 360 DNS (CN)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/sb.dns.json:2
msgid "DoH DNS (SB)"
-msgstr ""
+msgstr "DoH DNS (SB)"
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/https-dns-proxy/status.js:357
msgid "Enable"
@@ -191,7 +191,7 @@ msgstr "Activando el servicio %s"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/net.ffmuc.doh.json:2
msgid "FFMUC DNS (DE)"
-msgstr ""
+msgstr "FFMUC DNS (DE)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/ca.cira.canadianshield.json:14
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:22
@@ -285,11 +285,11 @@ msgstr "Hurricane Electric"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/net.idnet.doh.json:2
msgid "IDNet (UK)"
-msgstr ""
+msgstr "IDNet (UK)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/jp.iij.dns.public.json:2
msgid "IIJ Public DNS (JP)"
-msgstr ""
+msgstr "IIJ Public DNS (JP)"
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js:84
msgid ""
@@ -315,7 +315,7 @@ msgstr "Japón"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/fi.lelux.resolver-eu.json:2
msgid "Lelux DNS (FI)"
-msgstr ""
+msgstr "Lelux DNS (FI)"
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js:179
msgid "Let local devices use Mozilla Private Relay"
@@ -333,7 +333,7 @@ msgstr ""
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/gr.libredns.doh.json:2
msgid "LibreDNS (GR)"
-msgstr ""
+msgstr "LibreDNS (GR)"
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js:355
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/status/include/71_https-dns-proxy.js:100
@@ -393,11 +393,11 @@ msgstr "No instalado o no encontrado"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/cz.nic.odvr.json:2
msgid "ODVR (CZ)"
-msgstr ""
+msgstr "ODVR (CZ)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/co.oszx.dns.json:2
msgid "OSZX DNS (UK)"
-msgstr ""
+msgstr "OSZX DNS (UK)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.opendns.doh.json:2
msgid "OpenDNS"
@@ -442,11 +442,11 @@ msgstr "Servidor proxy"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/tw.twnic.dns.json:2
msgid "Quad 101 (TW)"
-msgstr ""
+msgstr "Quad 101 (TW)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/net.quad9.json:2
msgid "Quad 9"
-msgstr ""
+msgstr "Quad 9"
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/https-dns-proxy/status.js:319
msgid "Restart"
@@ -458,15 +458,15 @@ msgstr "Reiniciando el servicio %s"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/lu.restena.kaitain.json:2
msgid "Restena DNS (LU)"
-msgstr ""
+msgstr "Restena DNS (LU)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.rethinkdns.sky.json:2
msgid "Rethink DNS"
-msgstr ""
+msgstr "Rethink DNS"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/cn.rubyfish.dns.json:2
msgid "RubyFish (CN)"
-msgstr ""
+msgstr "RubyFish (CN)"
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js:372
msgid "Run As Group"
@@ -478,7 +478,7 @@ msgstr "Ejecutar como usuario"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/io.seby.doh-2.json:2
msgid "Seby DNS (AU)"
-msgstr ""
+msgstr "Seby DNS (AU)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/net.quad9.json:18
msgid "Secured"
@@ -523,7 +523,7 @@ msgstr "Singapur"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/org.snopyta.dns.doh.fi.json:2
msgid "Snopyta DNS (FI)"
-msgstr ""
+msgstr "Snopyta DNS (FI)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/net.ahadns.doh.json:22
msgid "Spain"
@@ -557,7 +557,7 @@ msgstr "Deteniendo el servicio %s"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/ch.switch.dns.json:2
msgid "Switch DNS (CH)"
-msgstr ""
+msgstr "Switch DNS (CH)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.blahdns.doh.json:14
msgid "Switzerland"
@@ -569,7 +569,7 @@ msgstr "No hay instancias activas."
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/app.tiarap.doh.json:2
msgid "Tiarap Public DNS (JP)"
-msgstr ""
+msgstr "Tiarap Public DNS (JP)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/net.ahadns.doh.json:18
msgid "US/Chicago"
@@ -585,7 +585,7 @@ msgstr "US/Nueva York"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:18
msgid "Unfiltered"
-msgstr ""
+msgstr "Sin filtrar"
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js:245
msgid "Unknown"
diff --git a/applications/luci-app-https-dns-proxy/po/pl/https-dns-proxy.po b/applications/luci-app-https-dns-proxy/po/pl/https-dns-proxy.po
index cd5e12a828..5c3576dc89 100644
--- a/applications/luci-app-https-dns-proxy/po/pl/https-dns-proxy.po
+++ b/applications/luci-app-https-dns-proxy/po/pl/https-dns-proxy.po
@@ -1,15 +1,15 @@
msgid ""
msgstr ""
-"PO-Revision-Date: 2023-12-18 20:17+0000\n"
+"PO-Revision-Date: 2024-04-11 03:16+0000\n"
"Last-Translator: Matthaiks <kitynska@gmail.com>\n"
"Language-Team: Polish <https://hosted.weblate.org/projects/openwrt/"
"luciapplicationshttps-dns-proxy/pl/>\n"
"Language: pl\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
-"Plural-Forms: nplurals=3; plural=n==1 ? 0 : n%10>=2 && n%10<=4 && (n%100<10 "
-"|| n%100>=20) ? 1 : 2;\n"
-"X-Generator: Weblate 5.3\n"
+"Plural-Forms: nplurals=3; plural=(n==1 ? 0 : n%10>=2 && n%10<=4 && (n%100<10 "
+"|| n%100>=20) ? 1 : 2);\n"
+"X-Generator: Weblate 5.5-dev\n"
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/https-dns-proxy/status.js:258
msgid "%s%s%s proxy at %s on port %s.%s"
@@ -147,7 +147,7 @@ msgstr "DeCloudUs DNS"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:14
msgid "Default (Blocks ads and trackers)"
-msgstr ""
+msgstr "Domyślny (blokuje reklamy i śledzenie)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/ch.digitale-gesellschaft.dns.json:2
msgid "Digitale Gesellschaft (CH)"
@@ -579,7 +579,7 @@ msgstr "USA/Nowy Jork"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:18
msgid "Unfiltered"
-msgstr ""
+msgstr "Niefiltrowany"
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js:245
msgid "Unknown"
diff --git a/applications/luci-app-https-dns-proxy/po/ru/https-dns-proxy.po b/applications/luci-app-https-dns-proxy/po/ru/https-dns-proxy.po
index 8bbf2bd49d..c3a1448980 100644
--- a/applications/luci-app-https-dns-proxy/po/ru/https-dns-proxy.po
+++ b/applications/luci-app-https-dns-proxy/po/ru/https-dns-proxy.po
@@ -1,15 +1,15 @@
msgid ""
msgstr ""
-"PO-Revision-Date: 2023-12-20 10:09+0000\n"
+"PO-Revision-Date: 2024-04-12 04:01+0000\n"
"Last-Translator: st7105 <st7105@gmail.com>\n"
"Language-Team: Russian <https://hosted.weblate.org/projects/openwrt/"
"luciapplicationshttps-dns-proxy/ru/>\n"
"Language: ru\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
-"Plural-Forms: nplurals=3; plural=n%10==1 && n%100!=11 ? 0 : n%10>=2 && "
-"n%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2;\n"
-"X-Generator: Weblate 5.3\n"
+"Plural-Forms: nplurals=3; plural=(n%10==1 && n%100!=11 ? 0 : n%10>=2 && "
+"n%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2);\n"
+"X-Generator: Weblate 5.5-dev\n"
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/https-dns-proxy/status.js:258
msgid "%s%s%s proxy at %s on port %s.%s"
@@ -149,7 +149,7 @@ msgstr "DeCloudUs DNS"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:14
msgid "Default (Blocks ads and trackers)"
-msgstr ""
+msgstr "По умолчанию (Блокирует рекламу и трекеры)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/ch.digitale-gesellschaft.dns.json:2
msgid "Digitale Gesellschaft (CH)"
@@ -583,7 +583,7 @@ msgstr "США/Нью-Йорк"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:18
msgid "Unfiltered"
-msgstr ""
+msgstr "Нефильтрованный"
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js:245
msgid "Unknown"
diff --git a/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot b/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot
index 4f8db0f910..9267960845 100644
--- a/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot
+++ b/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot
@@ -131,10 +131,6 @@ msgstr ""
msgid "DeCloudUs DNS"
msgstr ""
-#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:14
-msgid "Default (Blocks ads and trackers)"
-msgstr ""
-
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/ch.digitale-gesellschaft.dns.json:2
msgid "Digitale Gesellschaft (CH)"
msgstr ""
@@ -176,7 +172,7 @@ msgid "FFMUC DNS (DE)"
msgstr ""
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/ca.cira.canadianshield.json:14
-#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:22
+#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:14
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.cloudflare-dns.json:14
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.controld.freedns.json:14
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.opendns.doh.json:14
@@ -503,6 +499,7 @@ msgid "Spain"
msgstr ""
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/co.oszx.dns.json:18
+#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:18
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.cloudflare-dns.json:18
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.controld.freedns.json:18
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.opendns.doh.json:18
@@ -556,10 +553,6 @@ msgstr ""
msgid "US/New York"
msgstr ""
-#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:18
-msgid "Unfiltered"
-msgstr ""
-
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js:245
msgid "Unknown"
msgstr ""
diff --git a/applications/luci-app-https-dns-proxy/po/tr/https-dns-proxy.po b/applications/luci-app-https-dns-proxy/po/tr/https-dns-proxy.po
index 334fa70812..5f3cdd7423 100644
--- a/applications/luci-app-https-dns-proxy/po/tr/https-dns-proxy.po
+++ b/applications/luci-app-https-dns-proxy/po/tr/https-dns-proxy.po
@@ -1,6 +1,6 @@
msgid ""
msgstr ""
-"PO-Revision-Date: 2024-03-31 19:53+0000\n"
+"PO-Revision-Date: 2024-04-11 03:16+0000\n"
"Last-Translator: Oğuz Han <h4n.3545@gmail.com>\n"
"Language-Team: Turkish <https://hosted.weblate.org/projects/openwrt/"
"luciapplicationshttps-dns-proxy/tr/>\n"
@@ -146,7 +146,7 @@ msgstr "DeCloudUs DNS"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:14
msgid "Default (Blocks ads and trackers)"
-msgstr ""
+msgstr "Varsayılan (Reklam ve izleyicileri engeller)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/ch.digitale-gesellschaft.dns.json:2
msgid "Digitale Gesellschaft (CH)"
@@ -578,7 +578,7 @@ msgstr "ABD/New York"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:18
msgid "Unfiltered"
-msgstr ""
+msgstr "Filtrelenmemiş"
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js:245
msgid "Unknown"
diff --git a/applications/luci-app-https-dns-proxy/po/zh_Hans/https-dns-proxy.po b/applications/luci-app-https-dns-proxy/po/zh_Hans/https-dns-proxy.po
index 45f24312be..ab6e66860d 100644
--- a/applications/luci-app-https-dns-proxy/po/zh_Hans/https-dns-proxy.po
+++ b/applications/luci-app-https-dns-proxy/po/zh_Hans/https-dns-proxy.po
@@ -5,8 +5,9 @@ msgid ""
msgstr ""
"Project-Id-Version: \n"
"POT-Creation-Date: \n"
-"PO-Revision-Date: 2023-12-19 15:10+0000\n"
-"Last-Translator: Eric <zxmegaxqug@hldrive.com>\n"
+"PO-Revision-Date: 2024-04-11 03:16+0000\n"
+"Last-Translator: 大王叫我来巡山 <hamburger2048@users.noreply.hosted.weblate."
+"org>\n"
"Language-Team: Chinese (Simplified) <https://hosted.weblate.org/projects/"
"openwrt/luciapplicationshttps-dns-proxy/zh_Hans/>\n"
"Language: zh_Hans\n"
@@ -14,7 +15,7 @@ msgstr ""
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=1; plural=0;\n"
-"X-Generator: Weblate 5.3\n"
+"X-Generator: Weblate 5.5-dev\n"
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/https-dns-proxy/status.js:258
msgid "%s%s%s proxy at %s on port %s.%s"
@@ -152,7 +153,7 @@ msgstr "DeCloudUs DNS服务器"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:14
msgid "Default (Blocks ads and trackers)"
-msgstr ""
+msgstr "默认(拦截广告和跟踪器)"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/ch.digitale-gesellschaft.dns.json:2
msgid "Digitale Gesellschaft (CH)"
@@ -579,7 +580,7 @@ msgstr "美国纽约"
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:18
msgid "Unfiltered"
-msgstr ""
+msgstr "未过滤"
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js:245
msgid "Unknown"