summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-https-dns-proxy
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-https-dns-proxy')
-rw-r--r--applications/luci-app-https-dns-proxy/Makefile2
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns-family.lua4
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns.lua4
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/gr.libredns.doh-ads.lua8
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/gr.libredns.doh.lua8
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns.lua4
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns10.lua4
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns11.lua4
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns9.lua4
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/org.cleanbrowsing.doh-adult.lua4
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/org.cleanbrowsing.doh-family.lua4
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/org.cleanbrowsing.doh-security.lua4
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua41
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/view/https-dns-proxy/buttons.htm83
-rw-r--r--applications/luci-app-https-dns-proxy/po/en/https-dns-proxy.po8
-rw-r--r--applications/luci-app-https-dns-proxy/po/pl/https-dns-proxy.po6
-rw-r--r--applications/luci-app-https-dns-proxy/po/ru/https-dns-proxy.po10
-rw-r--r--applications/luci-app-https-dns-proxy/po/sk/https-dns-proxy.po8
-rw-r--r--applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot58
-rw-r--r--applications/luci-app-https-dns-proxy/root/etc/uci-defaults/40_luci-https-dns-proxy3
20 files changed, 186 insertions, 85 deletions
diff --git a/applications/luci-app-https-dns-proxy/Makefile b/applications/luci-app-https-dns-proxy/Makefile
index 47e8971919..918d8b0856 100644
--- a/applications/luci-app-https-dns-proxy/Makefile
+++ b/applications/luci-app-https-dns-proxy/Makefile
@@ -10,7 +10,7 @@ LUCI_TITLE:=DNS Over HTTPS Proxy Web UI
LUCI_DESCRIPTION:=Provides Web UI for DNS Over HTTPS Proxy
LUCI_DEPENDS:=+luci-compat +luci-mod-admin-full +https-dns-proxy
LUCI_PKGARCH:=all
-PKG_RELEASE:=1
+PKG_RELEASE:=3
include ../../luci.mk
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns-family.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns-family.lua
index 5fb6df3632..56a409f916 100644
--- a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns-family.lua
+++ b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns-family.lua
@@ -2,5 +2,7 @@ return {
name = "AdGuard-Family",
label = _("AdGuard (Family Protection)"),
resolver_url = "https://dns-family.adguard.com/dns-query",
- bootstrap_dns = "176.103.130.132,176.103.130.134"
+ bootstrap_dns = "176.103.130.132,176.103.130.134",
+ help_link = "https://adguard.com/en/adguard-dns/overview.html",
+ help_link_text = "AdGuard.com"
}
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns.lua
index 950f203f6e..504070501f 100644
--- a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns.lua
+++ b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns.lua
@@ -2,5 +2,7 @@ return {
name = "AdGuard-Standard",
label = _("AdGuard (Standard)"),
resolver_url = "https://dns.adguard.com/dns-query",
- bootstrap_dns = "176.103.130.130,176.103.130.131"
+ bootstrap_dns = "176.103.130.130,176.103.130.131",
+ help_link = "https://adguard.com/en/adguard-dns/overview.html",
+ help_link_text = "AdGuard.com"
}
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/gr.libredns.doh-ads.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/gr.libredns.doh-ads.lua
new file mode 100644
index 0000000000..22e6fffe41
--- /dev/null
+++ b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/gr.libredns.doh-ads.lua
@@ -0,0 +1,8 @@
+return {
+ name = "LibreDNS (No Ads)",
+ label = _("LibreDNS (No Ads)"),
+ resolver_url = "https://doh.libredns.gr/ads",
+ bootstrap_dns = "116.202.176.26",
+ help_link = "https://libredns.gr/",
+ help_link_text = "LibreDNS.gr"
+}
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/gr.libredns.doh.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/gr.libredns.doh.lua
new file mode 100644
index 0000000000..bd51e1be42
--- /dev/null
+++ b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/gr.libredns.doh.lua
@@ -0,0 +1,8 @@
+return {
+ name = "LibreDNS",
+ label = _("LibreDNS"),
+ resolver_url = "https://doh.libredns.gr/dns-query",
+ bootstrap_dns = "116.202.176.26",
+ help_link = "https://libredns.gr/",
+ help_link_text = "LibreDNS.gr"
+}
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns.lua
index 89becb18b3..eaa4b83703 100644
--- a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns.lua
+++ b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns.lua
@@ -2,5 +2,7 @@ return {
name = "Quad9-Recommended",
label = _("Quad 9 (Recommended)"),
resolver_url = "https://dns.quad9.net/dns-query",
- bootstrap_dns = "9.9.9.9,149.112.112.112"
+ bootstrap_dns = "9.9.9.9,149.112.112.112",
+ help_link = "https://www.quad9.net/doh-quad9-dns-servers/",
+ help_link_text = "Quad9.net"
}
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns10.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns10.lua
index 67c24fa774..4d1914a0f6 100644
--- a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns10.lua
+++ b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns10.lua
@@ -2,5 +2,7 @@ return {
name = "Quad9-Unsecured",
label = _("Quad 9 (Unsecured)"),
resolver_url = "https://dns10.quad9.net/dns-query",
- bootstrap_dns = "9.9.9.10,149.112.112.10"
+ bootstrap_dns = "9.9.9.10,149.112.112.10",
+ help_link = "https://www.quad9.net/doh-quad9-dns-servers/",
+ help_link_text = "Quad9.net"
}
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns11.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns11.lua
index e367794820..36fbeb39e8 100644
--- a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns11.lua
+++ b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns11.lua
@@ -2,5 +2,7 @@ return {
name = "Quad9-ECS",
label = _("Quad 9 (Secured with ECS Support)"),
resolver_url = "https://dns11.quad9.net/dns-query",
- bootstrap_dns = "9.9.9.11,149.112.112.11"
+ bootstrap_dns = "9.9.9.11,149.112.112.11",
+ help_link = "https://www.quad9.net/doh-quad9-dns-servers/",
+ help_link_text = "Quad9.net"
}
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns9.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns9.lua
index e459f2933e..61ca444eff 100644
--- a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns9.lua
+++ b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/net.quad9.dns9.lua
@@ -2,5 +2,7 @@ return {
name = "Quad9-Secured",
label = _("Quad 9 (Secured)"),
resolver_url = "https://dns9.quad9.net/dns-query",
- bootstrap_dns = "9.9.9.9,149.112.112.9"
+ bootstrap_dns = "9.9.9.9,149.112.112.9",
+ help_link = "https://www.quad9.net/doh-quad9-dns-servers/",
+ help_link_text = "Quad9.net"
}
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/org.cleanbrowsing.doh-adult.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/org.cleanbrowsing.doh-adult.lua
index e81637935b..5b4d908543 100644
--- a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/org.cleanbrowsing.doh-adult.lua
+++ b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/org.cleanbrowsing.doh-adult.lua
@@ -2,5 +2,7 @@ return {
name = "CleanBrowsing-Adult",
label = _("CleanBrowsing (Adult Filter)"),
resolver_url = "https://doh.cleanbrowsing.org/doh/adult-filter/",
- bootstrap_dns = "185.228.168.168"
+ bootstrap_dns = "185.228.168.168",
+ help_link = "https://cleanbrowsing.org/guides/dnsoverhttps",
+ help_link_text = "CleanBrowsing.org"
}
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/org.cleanbrowsing.doh-family.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/org.cleanbrowsing.doh-family.lua
index 9fabda1d77..47a0654d22 100644
--- a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/org.cleanbrowsing.doh-family.lua
+++ b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/org.cleanbrowsing.doh-family.lua
@@ -2,5 +2,7 @@ return {
name = "CleanBrowsing-Family",
label = _("CleanBrowsing (Family Filter)"),
resolver_url = "https://doh.cleanbrowsing.org/doh/family-filter/",
- bootstrap_dns = "185.228.168.168"
+ bootstrap_dns = "185.228.168.168",
+ help_link = "https://cleanbrowsing.org/guides/dnsoverhttps",
+ help_link_text = "CleanBrowsing.org"
}
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/org.cleanbrowsing.doh-security.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/org.cleanbrowsing.doh-security.lua
index 0bf11f59d8..6e370d513f 100644
--- a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/org.cleanbrowsing.doh-security.lua
+++ b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/org.cleanbrowsing.doh-security.lua
@@ -2,5 +2,7 @@ return {
name = "CleanBrowsing-Security",
label = _("CleanBrowsing (Security Filter)"),
resolver_url = "https://doh.cleanbrowsing.org/doh/security-filter/",
- bootstrap_dns = "185.228.168.168"
+ bootstrap_dns = "185.228.168.168",
+ help_link = "https://cleanbrowsing.org/guides/dnsoverhttps",
+ help_link_text = "CleanBrowsing.org"
}
diff --git a/applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua b/applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua
index 11eca60399..d914bf09a3 100644
--- a/applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua
+++ b/applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua
@@ -7,6 +7,33 @@ local uci = require("luci.model.uci").cursor()
local packageName = "https-dns-proxy"
local providers_dir = "/usr/lib/lua/luci/" .. packageName .. "/providers/"
+local helperText = ""
+
+function create_helper_text()
+ local initText = "<br />" .. translate("For more information on different options check") .. " "
+ for filename in fs.dir(providers_dir) do
+ local p_func = loadfile(providers_dir .. filename)
+ setfenv(p_func, { _ = i18n.translate })
+ local p = p_func()
+ if p.help_link then
+ local url, domain
+ url = p.help_link
+ domain = p.help_link_text or url:match('^%w+://([^/]+)')
+ if not helperText:find(domain) then
+ if helperText == "" then
+ helperText = initText
+ else
+ helperText = helperText .. ", "
+ end
+ helperText = helperText .. [[<a href="]] .. url .. [[">]] .. domain .. [[</a>]]
+ end
+ end
+ end
+ if helperText ~= "" then
+ local a = helperText:gsub('(.*),%s.*$', '%1')
+ helperText = a .. " " .. translate("and") .. helperText:sub(#a + 2) .. "."
+ end
+end
function get_provider_name(value)
for filename in fs.dir(providers_dir) do
@@ -35,6 +62,9 @@ else
if not ubusStatus or not ubusStatus[packageName] then
tmpfsStatusCode = 0
tmpfsStatus = translate("Stopped")
+ if not luci.sys.init.enabled(packageName) then
+ tmpfsStatus = tmpfsStatus .. " (" .. translate("disabled") .. ")"
+ end
else
tmpfsStatusCode, tmpfsStatus = 1, ""
for n = 1,1000 do
@@ -80,17 +110,10 @@ else
buttons.template = packageName .. "/buttons"
end
+create_helper_text()
s3 = m:section(TypedSection, "https-dns-proxy", translate("Instances"), translate("When you add/remove any instances below, they will be used to override the 'DNS forwardings' section of ")
.. [[ <a href="]] .. dispatcher.build_url("admin/network/dhcp") .. [[">]]
- .. translate("DHCP and DNS") .. [[</a>]] .. "."
- .. "<br />"
- .. translate("For more information on different options check ")
- .. [[ <a href="https://adguard.com/en/adguard-dns/overview.html">]]
- .. "AdGuard.com" .. [[</a>]] .. ", "
- .. [[ <a href="https://cleanbrowsing.org/guides/dnsoverhttps">]]
- .. "CleanBrowsing.org" .. [[</a>]] .. " " .. translate("and") .. " "
- .. [[ <a href="https://www.quad9.net/doh-quad9-dns-servers/">]]
- .. "Quad9.net" .. [[</a>]] .. ".")
+ .. translate("DHCP and DNS") .. [[</a>]] .. "." .. helperText)
s3.template = "cbi/tblsection"
s3.sortable = false
s3.anonymous = true
diff --git a/applications/luci-app-https-dns-proxy/luasrc/view/https-dns-proxy/buttons.htm b/applications/luci-app-https-dns-proxy/luasrc/view/https-dns-proxy/buttons.htm
index 52d2b50e52..b7fcd472ed 100644
--- a/applications/luci-app-https-dns-proxy/luasrc/view/https-dns-proxy/buttons.htm
+++ b/applications/luci-app-https-dns-proxy/luasrc/view/https-dns-proxy/buttons.htm
@@ -1,56 +1,77 @@
-<%#
- Copyright 2019 Stan Grishin <stangri@melmac.net>
--%>
+<%# Copyright 2020 Stan Grishin <stangri@melmac.net> -%>
+
+<%+https-dns-proxy/css%>
+<%+https-dns-proxy/js%>
<%-
local packageName = "https-dns-proxy"
- local enabledFlag = luci.sys.init.enabled(packageName)
- local ubusStatus = luci.util.ubus("service", "list", { name = packageName })
+ local serviceRunning, serviceEnabled = false, false;
- if not ubusStatus or not ubusStatus[packageName] then
- tmpfsStatusCode = 0
- else
- tmpfsStatusCode = 1
+ serviceEnabled = luci.sys.init.enabled(packageName)
+ local ubusStatus = luci.util.ubus("service", "list", { name = packageName })
+ if ubusStatus and ubusStatus[packageName] then
+ serviceRunning = true
end
- if tmpfsStatusCode == 0 then
- btn_start_style = "cbi-button cbi-button-apply important"
- btn_action_style = "cbi-button cbi-button-apply important"
- btn_stop_style = "cbi-button cbi-button-reset -disabled"
+ if serviceEnabled then
+ btn_start_status = true
+ btn_action_status = true
+ btn_stop_status = true
+ btn_enable_status = false
+ btn_disable_status = true
else
- btn_start_style = "cbi-button cbi-button-apply -disabled"
- btn_action_style = "cbi-button cbi-button-apply important"
- btn_stop_style = "cbi-button cbi-button-reset important"
+ btn_start_status = false
+ btn_action_status = false
+ btn_stop_status = false
+ btn_enable_status = true
+ btn_disable_status = false
end
- if not enabledFlag then
- btn_start_style = "cbi-button cbi-button-apply -disabled"
- btn_action_style = "cbi-button cbi-button-apply -disabled"
- btn_enable_style = "cbi-button cbi-button-apply important"
- btn_disable_style = "cbi-button cbi-button-reset -disabled"
+ if serviceRunning then
+ btn_start_status = false
+ btn_action_status = true
+ btn_stop_status = true
else
- btn_enable_style = "cbi-button cbi-button-apply -disabled"
- btn_disable_style = "cbi-button cbi-button-reset important"
+ btn_action_status = false
+ btn_stop_status = false
end
-%>
-<%+https-dns-proxy/css%>
-<%+https-dns-proxy/js%>
-
<div class="cbi-value"><label class="cbi-value-title">Service Control</label>
<div class="cbi-value-field">
- <input type="button" class="<%=btn_start_style%>" id="btn_start" name="start" value="<%:Start%>" onclick="button_action(this)" />
+ <input type="button" class="cbi-button cbi-button-apply" id="btn_start" name="start" value="<%:Start%>"
+ onclick="button_action(this)" />
<span id="btn_start_spinner" class="btn_spinner"></span>
- <input type="button" class="<%=btn_action_style%>" id="btn_action" name="action" value="<%:Reload%>" onclick="button_action(this)" />
+ <input type="button" class="cbi-button cbi-button-apply" id="btn_action" name="action" value="<%:Reload%>"
+ onclick="button_action(this)" />
<span id="btn_action_spinner" class="btn_spinner"></span>
- <input type="button" class="<%=btn_stop_style%>" id="btn_stop" name="stop" value="<%:Stop%>" onclick="button_action(this)" />
+ <input type="button" class="cbi-button cbi-button-reset" id="btn_stop" name="stop" value="<%:Stop%>"
+ onclick="button_action(this)" />
<span id="btn_stop_spinner" class="btn_spinner"></span>
&nbsp;
&nbsp;
&nbsp;
&nbsp;
- <input type="button" class="<%=btn_enable_style%>" id="btn_enable" name="enable" value="<%:Enable%>" onclick="button_action(this)" />
+ <input type="button" class="cbi-button cbi-button-apply" id="btn_enable" name="enable" value="<%:Enable%>"
+ onclick="button_action(this)" />
<span id="btn_enable_spinner" class="btn_spinner"></span>
- <input type="button" class="<%=btn_disable_style%>" id="btn_disable" name="disable" value="<%:Disable%>" onclick="button_action(this)" />
+ <input type="button" class="cbi-button cbi-button-reset" id="btn_disable" name="disable" value="<%:Disable%>"
+ onclick="button_action(this)" />
<span id="btn_disable_spinner" class="btn_spinner"></span>
</div>
</div>
+
+<%-if not btn_start_status then%>
+<script type="text/javascript">document.getElementById("btn_start").disabled = true;</script>
+<%-end%>
+<%-if not btn_action_status then%>
+<script type="text/javascript">document.getElementById("btn_action").disabled = true;</script>
+<%-end%>
+<%-if not btn_stop_status then%>
+<script type="text/javascript">document.getElementById("btn_stop").disabled = true;</script>
+<%-end%>
+<%-if not btn_enable_status then%>
+<script type="text/javascript">document.getElementById("btn_enable").disabled = true;</script>
+<%-end%>
+<%-if not btn_disable_status then%>
+<script type="text/javascript">document.getElementById("btn_disable").disabled = true;</script>
+<%-end%>
diff --git a/applications/luci-app-https-dns-proxy/po/en/https-dns-proxy.po b/applications/luci-app-https-dns-proxy/po/en/https-dns-proxy.po
index 9dc2bebfb5..4c462b5c4d 100644
--- a/applications/luci-app-https-dns-proxy/po/en/https-dns-proxy.po
+++ b/applications/luci-app-https-dns-proxy/po/en/https-dns-proxy.po
@@ -88,6 +88,14 @@ msgstr ""
msgid "Loading"
msgstr ""
+#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/gr.libredns.doh.lua:3
+msgid "LibreDNS"
+msgstr ""
+
+#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/gr.libredns.doh-ads.lua:3
+msgid "LibreDNS (No Ads)"
+msgstr ""
+
#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/cz.nic.odvr.lua:3
msgid "ODVR (nic.cz)"
msgstr ""
diff --git a/applications/luci-app-https-dns-proxy/po/pl/https-dns-proxy.po b/applications/luci-app-https-dns-proxy/po/pl/https-dns-proxy.po
index 98d7553be3..ddfc9516e7 100644
--- a/applications/luci-app-https-dns-proxy/po/pl/https-dns-proxy.po
+++ b/applications/luci-app-https-dns-proxy/po/pl/https-dns-proxy.po
@@ -1,6 +1,6 @@
msgid ""
msgstr ""
-"PO-Revision-Date: 2020-01-13 14:27+0000\n"
+"PO-Revision-Date: 2020-04-02 19:50+0000\n"
"Last-Translator: Marcin Net <marcin.net@linux.pl>\n"
"Language-Team: Polish <https://hosted.weblate.org/projects/openwrt/"
"luciapplicationshttps-dns-proxy/pl/>\n"
@@ -9,7 +9,7 @@ msgstr ""
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=3; plural=n==1 ? 0 : n%10>=2 && n%10<=4 && (n%100<10 "
"|| n%100>=20) ? 1 : 2;\n"
-"X-Generator: Weblate 3.10.1\n"
+"X-Generator: Weblate 4.0-dev\n"
#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns-family.lua:3
msgid "AdGuard (Family Protection)"
@@ -170,7 +170,7 @@ msgstr "na"
#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:32
msgid "is not installed or not found"
-msgstr "nie jest zainstalowany lub nie został znaleziony"
+msgstr "nie jest zainstalowany lub nie znaleziono"
#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers.disabled/cn.rubyfish.dns.lua:3
msgid "rubyfish.cn"
diff --git a/applications/luci-app-https-dns-proxy/po/ru/https-dns-proxy.po b/applications/luci-app-https-dns-proxy/po/ru/https-dns-proxy.po
index aa3681fd6a..506cc926d3 100644
--- a/applications/luci-app-https-dns-proxy/po/ru/https-dns-proxy.po
+++ b/applications/luci-app-https-dns-proxy/po/ru/https-dns-proxy.po
@@ -1,7 +1,7 @@
msgid ""
msgstr ""
-"PO-Revision-Date: 2020-02-19 20:00+0000\n"
-"Last-Translator: Anton Kikin <a.a.kikin@gmail.com>\n"
+"PO-Revision-Date: 2020-03-24 16:46+0000\n"
+"Last-Translator: Константин <konstantin.z100@gmail.com>\n"
"Language-Team: Russian <https://hosted.weblate.org/projects/openwrt/"
"luciapplicationshttps-dns-proxy/ru/>\n"
"Language: ru\n"
@@ -9,11 +9,11 @@ msgstr ""
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=3; plural=n%10==1 && n%100!=11 ? 0 : n%10>=2 && n%10<="
"4 && (n%100<10 || n%100>=20) ? 1 : 2;\n"
-"X-Generator: Weblate 3.11\n"
+"X-Generator: Weblate 4.0-dev\n"
#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns-family.lua:3
msgid "AdGuard (Family Protection)"
-msgstr ""
+msgstr "AdGuard (Семейная защита)"
#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.adguard.dns.lua:3
msgid "AdGuard (Standard)"
@@ -29,7 +29,7 @@ msgstr "CleanBrowsing (Семейный фильтр)"
#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/org.cleanbrowsing.doh-security.lua:3
msgid "CleanBrowsing (Security Filter)"
-msgstr ""
+msgstr "CleanBrowsing (Фильтр безопасности)"
#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.cloudflare-dns.lua:3
msgid "Cloudflare"
diff --git a/applications/luci-app-https-dns-proxy/po/sk/https-dns-proxy.po b/applications/luci-app-https-dns-proxy/po/sk/https-dns-proxy.po
index 2d33828699..802f26451d 100644
--- a/applications/luci-app-https-dns-proxy/po/sk/https-dns-proxy.po
+++ b/applications/luci-app-https-dns-proxy/po/sk/https-dns-proxy.po
@@ -1,7 +1,7 @@
msgid ""
msgstr ""
-"PO-Revision-Date: 2020-03-09 14:35+0000\n"
-"Last-Translator: Chaoos <all@chaoos.com>\n"
+"PO-Revision-Date: 2020-04-04 17:35+0000\n"
+"Last-Translator: Dušan Kazik <prescott66@gmail.com>\n"
"Language-Team: Slovak <https://hosted.weblate.org/projects/openwrt/"
"luciapplicationshttps-dns-proxy/sk/>\n"
"Language: sk\n"
@@ -56,7 +56,7 @@ msgstr ""
#: applications/luci-app-https-dns-proxy/luasrc/view/https-dns-proxy/buttons.htm:53
msgid "Disable"
-msgstr ""
+msgstr "Zakázať"
#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:56
msgid "DoH"
@@ -141,7 +141,7 @@ msgstr "Spustiť"
#: applications/luci-app-https-dns-proxy/luasrc/view/https-dns-proxy/buttons.htm:45
msgid "Stop"
-msgstr ""
+msgstr "Zastaviť"
#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:37
msgid "Stopped"
diff --git a/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot b/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot
index 3e1ddb2a32..6b7877f265 100644
--- a/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot
+++ b/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot
@@ -25,7 +25,7 @@ msgstr ""
msgid "Cloudflare"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:85
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:116
msgid "DHCP and DNS"
msgstr ""
@@ -33,7 +33,7 @@ msgstr ""
msgid "DNS Over HTTPS Proxy"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:64
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:94
msgid "DNS Over HTTPS Proxy Settings"
msgstr ""
@@ -45,23 +45,23 @@ msgstr ""
msgid "Digitale Gesellschaft"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/view/https-dns-proxy/buttons.htm:53
+#: applications/luci-app-https-dns-proxy/luasrc/view/https-dns-proxy/buttons.htm:57
msgid "Disable"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:56
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:86
msgid "DoH"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:143
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:166
msgid "EDNS client subnet"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/view/https-dns-proxy/buttons.htm:51
+#: applications/luci-app-https-dns-proxy/luasrc/view/https-dns-proxy/buttons.htm:54
msgid "Enable"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:87
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:13
msgid "For more information on different options check"
msgstr ""
@@ -69,15 +69,23 @@ msgstr ""
msgid "Google"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:83
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:114
msgid "Instances"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:126
+#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/gr.libredns.doh.lua:3
+msgid "LibreDNS"
+msgstr ""
+
+#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/gr.libredns.doh-ads.lua:3
+msgid "LibreDNS (No Ads)"
+msgstr ""
+
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:149
msgid "Listen address"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:139
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:162
msgid "Listen port"
msgstr ""
@@ -89,7 +97,7 @@ msgstr ""
msgid "ODVR (nic.cz)"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:146
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:169
msgid "Proxy server"
msgstr ""
@@ -109,20 +117,20 @@ msgstr ""
msgid "Quad 9 (Unsecured)"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/view/https-dns-proxy/buttons.htm:43
+#: applications/luci-app-https-dns-proxy/luasrc/view/https-dns-proxy/buttons.htm:44
msgid "Reload"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:99
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:122
msgid "Resolver"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:56
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:86
msgid "Running"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:66
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:68
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:96
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:98
msgid "Service Status"
msgstr ""
@@ -130,33 +138,37 @@ msgstr ""
msgid "Start"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/view/https-dns-proxy/buttons.htm:45
+#: applications/luci-app-https-dns-proxy/luasrc/view/https-dns-proxy/buttons.htm:47
msgid "Stop"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:37
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:64
msgid "Stopped"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:22
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:49
msgid "Unknown Provider"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:83
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:114
msgid ""
"When you add/remove any instances below, they will be used to override the "
"'DNS forwardings' section of"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:91
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:34
msgid "and"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:56
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:86
msgid "at"
msgstr ""
-#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:32
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:66
+msgid "disabled"
+msgstr ""
+
+#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:59
msgid "is not installed or not found"
msgstr ""
diff --git a/applications/luci-app-https-dns-proxy/root/etc/uci-defaults/40_luci-https-dns-proxy b/applications/luci-app-https-dns-proxy/root/etc/uci-defaults/40_luci-https-dns-proxy
new file mode 100644
index 0000000000..a1ecfcea24
--- /dev/null
+++ b/applications/luci-app-https-dns-proxy/root/etc/uci-defaults/40_luci-https-dns-proxy
@@ -0,0 +1,3 @@
+#!/bin/sh
+rm -rf /var/luci-modulecache/; rm -f /var/luci-indexcache;
+exit 0