summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-ddns
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-ddns')
-rw-r--r--applications/luci-app-ddns/Makefile3
-rwxr-xr-xapplications/luci-app-ddns/luasrc/tools/ddns.lua69
-rw-r--r--applications/luci-app-ddns/po/ru/ddns.po58
-rw-r--r--applications/luci-app-ddns/po/zh-cn/ddns.po10
-rw-r--r--applications/luci-app-ddns/po/zh-tw/ddns.po18
5 files changed, 77 insertions, 81 deletions
diff --git a/applications/luci-app-ddns/Makefile b/applications/luci-app-ddns/Makefile
index 7295189518..195e08131b 100644
--- a/applications/luci-app-ddns/Makefile
+++ b/applications/luci-app-ddns/Makefile
@@ -19,8 +19,7 @@ PKG_VERSION:=2.4.9
PKG_RELEASE:=5
PKG_LICENSE:=Apache-2.0
-PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>, \
- Ansuel Smith <ansuelsmth@gmail.com>
+PKG_MAINTAINER:=Ansuel Smith <ansuelsmth@gmail.com>
# LuCI specific settings
LUCI_TITLE:=LuCI Support for Dynamic DNS Client (ddns-scripts)
diff --git a/applications/luci-app-ddns/luasrc/tools/ddns.lua b/applications/luci-app-ddns/luasrc/tools/ddns.lua
index 57913a51fe..6f0c7f0952 100755
--- a/applications/luci-app-ddns/luasrc/tools/ddns.lua
+++ b/applications/luci-app-ddns/luasrc/tools/ddns.lua
@@ -10,121 +10,120 @@ local SYS = require "luci.sys"
function env_info(type)
- if ( type == "has_ssl" ) or ( type == "has_proxy" ) or ( type == "has_forceip" )
- or ( type == "has_bindnet" ) or ( type == "has_fetch" )
- or ( type == "has_wgetssl" ) or ( type == "has_curl" )
- or ( type == "has_curlssl" ) or ( type == "has_curlpxy" )
- or ( type == "has_fetchssl" ) or ( type == "has_bbwget" ) then
-
- local function has_wgetssl()
+ if ( type == "has_ssl" ) or ( type == "has_proxy" ) or ( type == "has_forceip" )
+ or ( type == "has_bindnet" ) or ( type == "has_fetch" )
+ or ( type == "has_wgetssl" ) or ( type == "has_curl" )
+ or ( type == "has_curlssl" ) or ( type == "has_curlpxy" )
+ or ( type == "has_fetchssl" ) or ( type == "has_bbwget" ) then
+
+ local function has_wgetssl()
return (SYS.call( [[which wget-ssl >/dev/null 2>&1]] ) == 0) -- and true or nil
end
-
- local function has_curlssl()
+
+ local function has_curlssl()
return (SYS.call( [[$(which curl) -V 2>&1 | grep "Protocols:" | grep -qF "https"]] ) ~= 0)
end
-
+
local function has_fetch()
return (SYS.call( [[which uclient-fetch >/dev/null 2>&1]] ) == 0)
end
-
+
local function has_fetchssl()
return NXFS.access("/lib/libustream-ssl.so")
end
-
+
local function has_curl()
return (SYS.call( [[which curl >/dev/null 2>&1]] ) == 0)
end
-
+
local function has_curlpxy()
return (SYS.call( [[grep -i "all_proxy" /usr/lib/libcurl.so* >/dev/null 2>&1]] ) == 0)
end
-
+
local function has_bbwget()
return (SYS.call( [[$(which wget) -V 2>&1 | grep -iqF "busybox"]] ) == 0)
end
-
+
if type == "has_wgetssl" then
return has_wgetssl()
-
+
elseif type == "has_curl" then
return has_curl()
-
+
elseif type == "has_curlssl" then
return has_curlssl()
-
+
elseif type == "has_curlpxy" then
return has_curlpxy()
-
+
elseif type == "has_fetch" then
return has_fetch()
-
+
elseif type == "has_fetchssl" then
return has_fetchssl()
-
+
elseif type == "has_bbwget" then
return has_bbwget()
-
+
elseif type == "has_ssl" then
if has_wgetssl() then return true end
if has_curlssl() then return true end
if (has_fetch() and has_fetchssl()) then return true end
return false
-
+
elseif type == "has_proxy" then
if has_wgetssl() then return true end
if has_curlpxy() then return true end
if has_fetch() then return true end
if has_bbwget() then return true end
return false
-
+
elseif type == "has_forceip" then
if has_wgetssl() then return true end
if has_curl() then return true end
if has_fetch() then return true end -- only really needed for transfer
return false
-
+
elseif type == "has_bindnet" then
if has_curl() then return true end
if has_wgetssl() then return true end
return false
end
-
+
elseif ( type == "has_dnsserver" ) or ( type == "has_bindhost" ) or ( type == "has_hostip" ) or ( type == "has_nslookup" ) then
- local function has_bindhost()
- if (SYS.call( [[which host >/dev/null 2>&1]] ) == 0) then return true end
+ local function has_bindhost()
if (SYS.call( [[which host >/dev/null 2>&1]] ) == 0) then return true end
if (SYS.call( [[which khost >/dev/null 2>&1]] ) == 0) then return true end
if (SYS.call( [[which drill >/dev/null 2>&1]] ) == 0) then return true end
return false
end
-
+
local function has_hostip()
return (SYS.call( [[which hostip >/dev/null 2>&1]] ) == 0)
end
-
+
local function has_nslookup()
return (SYS.call( [[$(which nslookup) localhost 2>&1 | grep -qF "(null)"]] ) ~= 0)
end
-
+
if type == "has_bindhost" then
return has_bindhost()
elseif type == "has_hostip" then
return has_hostip()
elseif type == "has_nslookup" then
return has_nslookup()
- elseif tyep == "has_dnsserver" then
+ elseif type == "has_dnsserver" then
if has_bindhost() then return true end
if has_hostip() then return true end
if has_nslookup() then return true end
return false
end
-
+
elseif type == "has_ipv6" then
return (NXFS.access("/proc/net/ipv6_route") and NXFS.access("/usr/sbin/ip6tables"))
-
+
elseif type == "has_cacerts" then
- --old _check_certs() local function
+ --old _check_certs() local function
local _, v = NXFS.glob("/etc/ssl/certs/*.crt")
if ( v == 0 ) then _, v = NXFS.glob("/etc/ssl/certs/*.pem") end
return (v > 0)
diff --git a/applications/luci-app-ddns/po/ru/ddns.po b/applications/luci-app-ddns/po/ru/ddns.po
index 4731cc379f..415f7badb8 100644
--- a/applications/luci-app-ddns/po/ru/ddns.po
+++ b/applications/luci-app-ddns/po/ru/ddns.po
@@ -56,22 +56,22 @@ msgid ""
"BusyBox's nslookup and Wget do not support to specify the IP version to use "
"for communication with DDNS Provider!"
msgstr ""
-"Утилиты nslookup и wget из состава busybox не поддерживают указание IP-версии"
-", используемой для связи с DDNS провайдером!"
+"Утилиты nslookup и wget из состава busybox не поддерживают указание IP-"
+"версии, используемой для связи с DDNS провайдером!"
msgid ""
"BusyBox's nslookup and hostip do not support to specify to use TCP instead "
"of default UDP when requesting DNS server!"
msgstr ""
-"Утилиты nslookup и hostip из состава busybox не поддерживают указание использ"
-"овать TCP вместо UDP по умолчанию при запросе DNS сервера!"
+"Утилиты nslookup и hostip из состава busybox не поддерживают указание "
+"использовать TCP вместо UDP по умолчанию при запросе DNS сервера!"
msgid ""
"BusyBox's nslookup in the current compiled version does not handle given DNS "
"Servers correctly!"
msgstr ""
-"Благодаря текущей скомпилированной версии busybox, утилита nslookup не обраба"
-"тывает данные DNS сервера правильно!"
+"Благодаря текущей скомпилированной версии busybox, утилита nslookup не "
+"обрабатывает данные DNS сервера правильно!"
msgid "Casual users should not change this setting"
msgstr "Обычный пользователь не должен изменять данную опцию"
@@ -116,8 +116,8 @@ msgid ""
">You can start/stop each configuration here. It will run until next reboot."
msgstr ""
"В настоящее время, обновления DDNS не запускаются при загрузке или при "
-"событиях интерфейса.<br />Вы можете запустить/остановить каждый "
-"config здесь. Он будет работать до следующей перезагрузки."
+"событиях интерфейса.<br />Вы можете запустить/остановить каждый config "
+"здесь. Он будет работать до следующей перезагрузки."
msgid "Custom update script to be used for updating your DDNS Provider."
msgstr ""
@@ -310,9 +310,9 @@ msgid ""
"the instructions on OpenWrt's homepage to enable IPv6 support<br />or update "
"your system to the latest OpenWrt Release"
msgstr ""
-"IPv6 не поддерживается вашей прошивкой.<br />Следуйте инструкциям на "
-"главной странице OpenWrt, чтобы включить поддержку IPv6<br / >или обновить "
-"прошивку до последнего выпуска OpenWrt с включенной поддержкой IPv6"
+"IPv6 не поддерживается вашей прошивкой.<br />Следуйте инструкциям на главной "
+"странице OpenWrt, чтобы включить поддержку IPv6<br / >или обновить прошивку "
+"до последнего выпуска OpenWrt с включенной поддержкой IPv6"
msgid "IPv6 not supported"
msgstr "IPv6 не поддерживается"
@@ -322,8 +322,7 @@ msgstr "IPv6-адрес"
msgid "If both cURL and GNU Wget are installed, Wget is used by default."
msgstr ""
-"Если установлены и cURL и GNU wget, по умолчанию будет использоваться "
-"wget."
+"Если установлены и cURL и GNU wget, по умолчанию будет использоваться wget."
msgid ""
"If this service section is disabled it could not be started.<br />Neither "
@@ -381,8 +380,7 @@ msgstr ""
msgid "It is NOT recommended for casual users to change settings on this page."
msgstr ""
-"Настройки на данной странице не рекомендуется изменять обычным "
-"пользователям."
+"Настройки на данной странице не рекомендуется изменять обычным пользователям."
msgid "Last Update"
msgstr "Последнее обновление"
@@ -414,8 +412,9 @@ msgstr "Не установлено"
msgid ""
"Neither GNU Wget with SSL nor cURL installed to select a network to use for "
"communication."
-msgstr "Не установлены пакеты GNU wget c SSL или cURL для возможности выбора "
-"сети для связи."
+msgstr ""
+"Не установлены пакеты GNU wget c SSL или cURL для возможности выбора сети "
+"для связи."
msgid ""
"Neither GNU Wget with SSL nor cURL installed to support secure updates via "
@@ -459,8 +458,8 @@ msgstr "Необязательно: использовать только чис
msgid "OPTIONAL: Force the use of TCP instead of default UDP on DNS requests."
msgstr ""
-"Необязательно: использовать протокол TCP вместо UDP по умолчанию "
-"для DNS-запросов."
+"Необязательно: использовать протокол TCP вместо UDP по умолчанию для DNS-"
+"запросов."
msgid "OPTIONAL: Network to use for communication"
msgstr "Необязательно: сеть для связи"
@@ -470,8 +469,8 @@ msgstr "Необязательно: прокси-сервер для обнар
msgid "OPTIONAL: Use non-default DNS-Server to detect 'Registered IP'."
msgstr ""
-"Необязательно: использовать DNS сервер не используемый по умолчанию, "
-"для обнаружения 'Зарегистрированного IP-адреса'."
+"Необязательно: использовать DNS сервер не используемый по умолчанию, для "
+"обнаружения 'Зарегистрированного IP-адреса'."
msgid "On Error the script will retry the failed action after given time"
msgstr ""
@@ -496,8 +495,7 @@ msgid "Optional: Replaces [PARAMENC] in Update-URL (URL-encoded)"
msgstr "Необязательно: заменяет [PARAMENC] в Update-URL (URL-encoded)"
msgid "Optional: Replaces [PARAMOPT] in Update-URL (NOT URL-encoded)"
-msgstr ""
-"Необязательно: заменяет [PARAMOPT] в Update-URL (не URL-encoded)"
+msgstr "Необязательно: заменяет [PARAMOPT] в Update-URL (не URL-encoded)"
msgid "Overview"
msgstr "Обзор"
@@ -605,8 +603,8 @@ msgid ""
"Update URL to be used for updating your DDNS Provider.<br />Follow "
"instructions you will find on their WEB page."
msgstr ""
-"URL обновления используется для обновления вашего DDNS-провайдера.<br />Следуйте "
-"инструкциям, которые вы найдете на их на веб-странице."
+"URL обновления используется для обновления вашего DDNS-провайдера.<br /"
+">Следуйте инструкциям, которые вы найдете на их на веб-странице."
msgid "Update error"
msgstr "Ошибка обновления"
@@ -658,14 +656,15 @@ msgid ""
"You should install 'bind-host' or 'knot-host' or 'drill' or 'hostip' "
"package, if you need to specify a DNS server to detect your registered IP."
msgstr ""
-"Установите пакет 'bind-host', 'knot-host', 'drill' или 'hostip' если "
-"вам нужно указать DNS сервер для обнаружения вашего зарегистрированного IP-"
+"Установите пакет 'bind-host', 'knot-host', 'drill' или 'hostip' если вам "
+"нужно указать DNS сервер для обнаружения вашего зарегистрированного IP-"
"адреса."
msgid ""
"You should install 'bind-host' or 'knot-host' or 'drill' package for DNS "
"requests."
-msgstr "Установите пакет 'bind-host', 'knot-host' или 'drill' для DNS запросов."
+msgstr ""
+"Установите пакет 'bind-host', 'knot-host' или 'drill' для DNS запросов."
msgid "You should install 'wget' or 'curl' or 'uclient-fetch' package."
msgstr "Установите пакет 'wget', 'curl' или 'uclient-fetch'."
@@ -757,8 +756,7 @@ msgid "no data"
msgstr "нет данных"
msgid "not found or not executable - Sample: '/path/to/script.sh'"
-msgstr ""
-"Не найден или не является исполняемым — пример: '/path/to/script.sh'"
+msgstr "Не найден или не является исполняемым — пример: '/path/to/script.sh'"
msgid "nslookup can not resolve host"
msgstr "Утилита nslookup не может разрешить хост"
diff --git a/applications/luci-app-ddns/po/zh-cn/ddns.po b/applications/luci-app-ddns/po/zh-cn/ddns.po
index f004f8282f..3d8b551403 100644
--- a/applications/luci-app-ddns/po/zh-cn/ddns.po
+++ b/applications/luci-app-ddns/po/zh-cn/ddns.po
@@ -1,11 +1,11 @@
#
-# Yangfl <mmyangfl@gmail.com>, 2017.
+# Yangfl <mmyangfl@gmail.com>, 2017, 2018.
#
msgid ""
msgstr ""
"Project-Id-Version: luci-app-ddns 2.4.0-1\n"
"POT-Creation-Date: 2016-01-30 11:07+0100\n"
-"PO-Revision-Date: 2017-10-29 14:14+0800\n"
+"PO-Revision-Date: 2018-08-08 08:38+0800\n"
"Last-Translator: Yangfl <mmyangfl@gmail.com>\n"
"Language: zh_CN\n"
"MIME-Version: 1.0\n"
@@ -80,7 +80,7 @@ msgid "Check Interval"
msgstr "检查时间周期"
msgid "Collecting data..."
-msgstr "正在收集数据..."
+msgstr "正在收集数据…"
msgid "Config error"
msgstr "配置错误"
@@ -532,7 +532,7 @@ msgstr "已停止"
msgid ""
"The currently installed 'ddns-scripts' package did not support all available "
"settings."
-msgstr "当前已安装的'ddns-scripts'软件包暂不支持所有可用设置项"
+msgstr "当前已安装的“ddns-scripts”软件包不支持所有可用设置项。"
msgid "The default setting of '0' will retry infinite."
msgstr "默认设置“0”将无限重试。"
@@ -593,7 +593,7 @@ msgid "Version Information"
msgstr "版本信息"
msgid "Waiting for changes to be applied..."
-msgstr "正在应用更改..."
+msgstr "正在应用更改…"
msgid "Warning"
msgstr "等待"
diff --git a/applications/luci-app-ddns/po/zh-tw/ddns.po b/applications/luci-app-ddns/po/zh-tw/ddns.po
index f378b39738..fdb1070c2e 100644
--- a/applications/luci-app-ddns/po/zh-tw/ddns.po
+++ b/applications/luci-app-ddns/po/zh-tw/ddns.po
@@ -1,11 +1,11 @@
#
-# Yangfl <mmyangfl@gmail.com>, 2017.
+# Yangfl <mmyangfl@gmail.com>, 2017, 2018.
#
msgid ""
msgstr ""
"Project-Id-Version: luci-app-ddns 2.4.0-1\n"
"POT-Creation-Date: 2016-01-30 11:07+0100\n"
-"PO-Revision-Date: 2017-10-29 14:14+0800\n"
+"PO-Revision-Date: 2018-08-08 08:38+0800\n"
"Last-Translator: Yangfl <mmyangfl@gmail.com>\n"
"Language: zh_TW\n"
"MIME-Version: 1.0\n"
@@ -19,7 +19,7 @@ msgid "&"
msgstr "&"
msgid "-- custom --"
-msgstr "-- 自定義 --"
+msgstr "-- 自訂 --"
msgid "-- default --"
msgstr "-- 預設 --"
@@ -80,7 +80,7 @@ msgid "Check Interval"
msgstr "檢查時間週期"
msgid "Collecting data..."
-msgstr "正在收集資料..."
+msgstr "正在收集資料…"
msgid "Config error"
msgstr "配置錯誤"
@@ -115,13 +115,13 @@ msgstr ""
"一個設定的條目。它在下次重啟之前一直有效。"
msgid "Custom update script to be used for updating your DDNS Provider."
-msgstr "用來更新動態 DNS 的自定義指令碼。"
+msgstr "用來更新動態 DNS 的自訂指令碼。"
msgid "Custom update-URL"
-msgstr "自定義更新 URL"
+msgstr "自訂更新 URL"
msgid "Custom update-script"
-msgstr "自定義更新指令碼"
+msgstr "自訂更新指令碼"
msgid "DDNS Autostart disabled"
msgstr "DDNS 自動啟動已禁用。"
@@ -532,7 +532,7 @@ msgstr "已停止"
msgid ""
"The currently installed 'ddns-scripts' package did not support all available "
"settings."
-msgstr "當前已安裝的'ddns-scripts'軟體包暫不支援所有可用設定項"
+msgstr "當前已安裝的“ddns-scripts”軟體包不支援所有可用設定項。"
msgid "The default setting of '0' will retry infinite."
msgstr "預設設定“0”將無限重試。"
@@ -593,7 +593,7 @@ msgid "Version Information"
msgstr "版本資訊"
msgid "Waiting for changes to be applied..."
-msgstr "正在應用更改..."
+msgstr "正在應用更改…"
msgid "Warning"
msgstr "等待"