summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-aria2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-aria2/Makefile')
-rw-r--r--applications/luci-app-aria2/Makefile31
1 files changed, 5 insertions, 26 deletions
diff --git a/applications/luci-app-aria2/Makefile b/applications/luci-app-aria2/Makefile
index 8035ea3a50..541672f4d2 100644
--- a/applications/luci-app-aria2/Makefile
+++ b/applications/luci-app-aria2/Makefile
@@ -1,39 +1,18 @@
#
-# Copyright (C) 2016 Openwrt.org
+# Copyright (C) 2017-2019 Xingwang Liao <kuoruan@gmail.com>
#
-# This is free software, licensed under the Apache License, Version 2.0 .
+# This is free software, licensed under the MIT License.
#
include $(TOPDIR)/rules.mk
-PKG_NAME:=luci-app-aria2
-
-# Version == major.minor.patch
-# increase "minor" on new functionality and "patch" on patches/optimization
-PKG_VERSION:=1.0.1
-
-# Release == build
-# increase on changes of translation files
-PKG_RELEASE:=4
-
-PKG_LICENSE:=Apache-2.0
-PKG_MAINTAINER:=Hsing-Wang Liao <kuoruan@gmail.com>
-
-# LuCI specific settings
LUCI_TITLE:=LuCI Support for Aria2
-LUCI_DEPENDS:=+luci-lib-ipkg +aria2
+LUCI_DEPENDS:=+aria2 +luci-lib-ipkg
LUCI_PKGARCH:=all
-define Package/$(PKG_NAME)/config
-# shown in make menuconfig <Help>
-help
- $(LUCI_TITLE)
- .
- Version: $(PKG_VERSION)-$(PKG_RELEASE)
- $(PKG_MAINTAINER)
-endef
+PKG_MAINTAINER:=Xingwang Liao <kuoruan@gmail.com>
+PKG_LICENSE:=MIT
include ../../luci.mk
# call BuildPackage - OpenWrt buildroot signature
-