summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-advanced-reboot
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-advanced-reboot')
-rw-r--r--applications/luci-app-advanced-reboot/Makefile2
-rw-r--r--applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js11
-rw-r--r--applications/luci-app-advanced-reboot/po/nl/advanced-reboot.po214
-rw-r--r--applications/luci-app-advanced-reboot/root/etc/uci-defaults/40_luci-advanced-reboot3
-rwxr-xr-xapplications/luci-app-advanced-reboot/root/usr/libexec/rpcd/luci.advanced_reboot2
-rw-r--r--applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-ea7500v2.json1
-rw-r--r--applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-ea8100v2.json14
-rw-r--r--applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-whw01v1.json14
-rw-r--r--applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/xiaomi-ax3600.json14
-rw-r--r--applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/xiaomi-ax9000.json14
10 files changed, 283 insertions, 6 deletions
diff --git a/applications/luci-app-advanced-reboot/Makefile b/applications/luci-app-advanced-reboot/Makefile
index 114d1cd859..adee08a63a 100644
--- a/applications/luci-app-advanced-reboot/Makefile
+++ b/applications/luci-app-advanced-reboot/Makefile
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
-PKG_VERSION:=1.0.1-3
+PKG_VERSION:=1.0.1-8
LUCI_TITLE:=Advanced Linksys Reboot Web UI
LUCI_URL:=https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
diff --git a/applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js b/applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js
index 482b8e2e91..3fdf6c18ec 100644
--- a/applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js
+++ b/applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js
@@ -5,6 +5,11 @@
'require uci';
'require fs';
+var pkg = {
+ get Name() { return 'luci-app-advanced-reboot'; },
+ get URL() { return 'https://docs.openwrt.melmac.net/' + pkg.Name + '/'; }
+};
+
return view.extend({
translateTable: {
NO_BOARD_NAME : function(args) { return _('Unable to find Device Board Name.')},
@@ -213,9 +218,13 @@ return view.extend({
body.appendChild(partitions_table);
} else {
body.appendChild(E('p', { 'class' : 'alert-message warning'},
- device_info.rom_board_name ? _("Warning: Device (%s) is unknown or isn't a dual-partition device!").format(device_info.rom_board_name)
+ device_info.rom_board_name ? _("Warning: Device (%s) is unknown or isn't a dual-firmware device!" + "%s" +
+ "If you are seeing this on an OpenWrt dual-firmware supported device," + "%s" + "please refer to " +
+ "%sHow to add a new device section of the README%s.").format(device_info.rom_board_name, "<br /><br />", "<br />",
+ "<a href=\"" + pkg.URL + "#how-to-add-a-new-device\" target=\"_blank\">", "</a>" )
: _('Warning: Unable to obtain device information!')
));
+
}
body.appendChild(E('hr'));
diff --git a/applications/luci-app-advanced-reboot/po/nl/advanced-reboot.po b/applications/luci-app-advanced-reboot/po/nl/advanced-reboot.po
new file mode 100644
index 0000000000..92b6f50250
--- /dev/null
+++ b/applications/luci-app-advanced-reboot/po/nl/advanced-reboot.po
@@ -0,0 +1,214 @@
+msgid ""
+msgstr ""
+"PO-Revision-Date: 2023-04-22 21:01+0000\n"
+"Last-Translator: xtz1983 <xtz1983@gmail.com>\n"
+"Language-Team: Dutch <https://hosted.weblate.org/projects/openwrt/"
+"luciapplicationsadvanced-reboot/nl/>\n"
+"Language: nl\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"Plural-Forms: nplurals=2; plural=n != 1;\n"
+"X-Generator: Weblate 4.18-dev\n"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:188
+#: applications/luci-app-advanced-reboot/root/usr/share/luci/menu.d/luci-app-advanced-reboot.json:3
+msgid "Advanced Reboot"
+msgstr "Geavanceerd opnieuw opstarten"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:53
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:136
+msgid "Cancel"
+msgstr "Annuleren"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:163
+msgid "Compressed"
+msgstr "Gecomprimeerd"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:125
+msgid "Confirm"
+msgstr "Bevestigen"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:77
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:106
+msgid "Device unreachable! Still waiting for device..."
+msgstr "Toestel onbereikbaar! Wacht nog steeds op apparaat..."
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:198
+msgid "ERROR:"
+msgstr "FOUT:"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:206
+msgid "Firmware"
+msgstr "Firmware"
+
+#: applications/luci-app-advanced-reboot/root/usr/share/rpcd/acl.d/luci-app-advanced-reboot.json:3
+msgid "Grant UCI and file access for luci-app-advanced-reboot"
+msgstr "Verleen UCI en bestandstoegang voor luci-app-advanced-reboot"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:122
+msgid "No access to fw_printenv or fw_printenv!"
+msgstr "Geen toegang tot fw_printenv of fw_printenv!"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:204
+msgid "Partition"
+msgstr "Partitie"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:200
+msgid "Partitions"
+msgstr "Partities"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:226
+msgid "Perform power off..."
+msgstr "Voer de stroom uit..."
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:46
+msgid "Power Off Device"
+msgstr "Apparaat uitschakelen"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:57
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:140
+msgid "Proceed"
+msgstr "Doorgaan"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:207
+msgid "Reboot"
+msgstr "Opnieuw opstarten"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:125
+msgid "Reboot Device to an Alternative Partition"
+msgstr "Apparaat herstarten naar een alternatieve partitie"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:157
+msgid "Reboot to alternative partition..."
+msgstr "Herstart naar alternatieve partitie..."
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:154
+msgid "Reboot to current partition"
+msgstr "Herstart naar huidige partitie"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:70
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:75
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:99
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:104
+msgid "Rebooting…"
+msgstr "Opnieuw opstarten…"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:38
+msgid "Shutting down..."
+msgstr "Afsluiten..."
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:205
+msgid "Status"
+msgstr "Status"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:12
+msgid "The Dual Boot Flag Partition: %s is not a block device."
+msgstr "De Dual Boot Flag Partitie: %s is geen blokapparaat."
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:66
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:95
+msgid "The reboot command failed with code %d"
+msgstr "Het reboot commando is mislukt met code %d"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:100
+msgid ""
+"The system is rebooting to an alternative partition now.<br /> DO NOT POWER "
+"OFF THE DEVICE!<br /> Wait a few minutes before you try to reconnect. It "
+"might be necessary to renew the address of your computer to reach the device "
+"again, depending on your settings."
+msgstr ""
+"Het systeem wordt nu opnieuw opgestart naar een alternatieve partitie. <br /"
+"> SCHAKEL HET APPARAAT NIET UIT! <br /> Wacht een paar minuten voordat u "
+"probeert opnieuw verbinding te maken. Afhankelijk van uw instellingen kan "
+"het nodig zijn om het adres van uw computer te vernieuwen om het apparaat "
+"weer te kunnen bereiken."
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:39
+msgid ""
+"The system is shutting down now.<br /> DO NOT POWER OFF THE DEVICE!<br /> It "
+"might be necessary to renew the address of your computer to reach the device "
+"again, depending on your settings."
+msgstr ""
+"Het systeem wordt nu afgesloten.<br /> SCHAKEL HET APPARAAT NIET UIT!<br /> "
+"Het kan nodig zijn om het adres van uw computer te vernieuwen om het "
+"apparaat weer te kunnen bereiken, afhankelijk van uw instellingen."
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:10
+msgid "Unable to find Device Board Name."
+msgstr "Kan de naam van het apparaatbord niet vinden."
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:11
+msgid "Unable to find Dual Boot Flag Partition."
+msgstr "Kan de Dual Boot Flag-partitie niet vinden."
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:14
+msgid "Unable to obtain firmware environment variable: %s."
+msgstr "Kan de omgevingsvariabele firmware niet verkrijgen: %s."
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:13
+msgid "Unable to set Dual Boot Flag Partition entry for partition: %s."
+msgstr "Kan Dual Boot Flag Partition entry niet instellen voor partitie: %s."
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:15
+msgid "Unable to set firmware environment variable: %s to %s."
+msgstr "Kan firmware-omgevingsvariabele niet instellen: %s op %s."
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:163
+msgid "Unknown"
+msgstr "Onbekend"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:126
+msgid ""
+"WARNING: An alternative partition might have its own settings and completely "
+"different firmware.<br /><br /> As your network configuration and WiFi SSID/"
+"password on alternative partition might be different, you might have to "
+"adjust your computer settings to be able to access your device once it "
+"reboots.<br /><br /> Please also be aware that alternative partition "
+"firmware might not provide an easy way to switch active partition and boot "
+"back to the currently active partition.<br /><br /> Click \"Proceed\" below "
+"to reboot device to an alternative partition."
+msgstr ""
+"WAARSCHUWING: Een alternatieve partitie kan zijn eigen instellingen en "
+"volledig andere firmware hebben.<br /><br /> Aangezien uw "
+"netwerkconfiguratie en WiFi SSID/wachtwoord op een alternatieve partitie "
+"anders kunnen zijn, moet u mogelijk uw computerinstellingen aanpassen om "
+"toegang te krijgen tot uw apparaat zodra het opnieuw wordt opgestart.<br /"
+"><br /> Houd er ook rekening mee dat alternatieve partitie firmware mogelijk "
+"geen gemakkelijke manier biedt om van actieve partitie te wisselen en terug "
+"te starten naar de huidige actieve partitie.<br /><br /> Klik op \"Doorgaan\""
+" hieronder om het apparaat opnieuw op te starten naar een alternatieve "
+"partitie."
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:47
+msgid ""
+"WARNING: Power off might result in a reboot on a device which doesn't "
+"support power off.<br /><br /> Click \"Proceed\" below to power off your "
+"device."
+msgstr ""
+"WAARSCHUWING: Uitschakelen kan resulteren in een herstart op een apparaat "
+"dat uitschakelen niet ondersteunt.<br /><br /> Klik hieronder op \"Doorgaan\""
+" om uw apparaat uit te schakelen."
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:71
+msgid "Waiting for device..."
+msgstr "Wachten op apparaat..."
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:216
+msgid "Warning: Device (%s) is unknown or isn't a dual-partition device!"
+msgstr ""
+"Waarschuwing: Apparaat (%s) is onbekend of is geen apparaat met twee "
+"partities!"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:193
+msgid "Warning: There are unsaved changes that will get lost on reboot!"
+msgstr ""
+"Waarschuwing: Er zijn niet opgeslagen wijzigingen die verloren gaan bij het "
+"opnieuw opstarten!"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:229
+msgid "Warning: This system does not support powering off!"
+msgstr "Waarschuwing: Dit systeem ondersteunt geen uitschakeling!"
+
+#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:217
+msgid "Warning: Unable to obtain device information!"
+msgstr "Waarschuwing: Kan geen apparaatinformatie verkrijgen!"
diff --git a/applications/luci-app-advanced-reboot/root/etc/uci-defaults/40_luci-advanced-reboot b/applications/luci-app-advanced-reboot/root/etc/uci-defaults/40_luci-advanced-reboot
index 8e457adce8..b42fa5859f 100644
--- a/applications/luci-app-advanced-reboot/root/etc/uci-defaults/40_luci-advanced-reboot
+++ b/applications/luci-app-advanced-reboot/root/etc/uci-defaults/40_luci-advanced-reboot
@@ -1,5 +1,4 @@
#!/bin/sh
-
-/etc/init.d/rpcd reload
rm -rf /var/luci-modulecache/; rm -f /var/luci-indexcache;
+[ -x /etc/init.d/rpcd ] && /etc/init.d/rpcd reload
exit 0
diff --git a/applications/luci-app-advanced-reboot/root/usr/libexec/rpcd/luci.advanced_reboot b/applications/luci-app-advanced-reboot/root/usr/libexec/rpcd/luci.advanced_reboot
index 7ec52a3097..b92459a7b3 100755
--- a/applications/luci-app-advanced-reboot/root/usr/libexec/rpcd/luci.advanced_reboot
+++ b/applications/luci-app-advanced-reboot/root/usr/libexec/rpcd/luci.advanced_reboot
@@ -1,5 +1,5 @@
#!/bin/sh
-# Copyright 2017-2020 Stan Grishin (stangri@melmac.net)
+# Copyright 2017-2020 Stan Grishin (stangri@melmac.ca)
# shellcheck disable=SC2039,SC1091,SC3043,SC3057,SC3060
readonly devices_dir="/usr/share/advanced-reboot/devices/"
diff --git a/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-ea7500v2.json b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-ea7500v2.json
index 03a18be684..b061c65865 100644
--- a/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-ea7500v2.json
+++ b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-ea7500v2.json
@@ -12,4 +12,3 @@
"bootEnv2Partition1Value": "run nandboot",
"bootEnv2Partition2Value": "run altnandboot"
}
-
diff --git a/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-ea8100v2.json b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-ea8100v2.json
new file mode 100644
index 0000000000..d62843cc1b
--- /dev/null
+++ b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-ea8100v2.json
@@ -0,0 +1,14 @@
+{
+ "vendorName": "Linksys",
+ "deviceName": "EA8100v2",
+ "boardNames": [ "linksys,ea8100-v2" ],
+ "partition1MTD": "mtd5",
+ "partition2MTD": "mtd7",
+ "labelOffset": 32,
+ "bootEnv1": "boot_part",
+ "bootEnv1Partition1Value": 1,
+ "bootEnv1Partition2Value": 2,
+ "bootEnv2": null,
+ "bootEnv2Partition1Value": null,
+ "bootEnv2Partition2Value": null
+}
diff --git a/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-whw01v1.json b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-whw01v1.json
new file mode 100644
index 0000000000..82238f3548
--- /dev/null
+++ b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-whw01v1.json
@@ -0,0 +1,14 @@
+{
+ "vendorName": "Linksys",
+ "deviceName": "WHW01 V1 (Velop)",
+ "boardNames": [ "linksys,whw01" ],
+ "partition1MTD": "mtd9",
+ "partition2MTD": "mtd11",
+ "labelOffset": 192,
+ "bootEnv1": "boot_part",
+ "bootEnv1Partition1Value": 1,
+ "bootEnv1Partition2Value": 2,
+ "bootEnv2": null,
+ "bootEnv2Partition1Value": null,
+ "bootEnv2Partition2Value": null
+}
diff --git a/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/xiaomi-ax3600.json b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/xiaomi-ax3600.json
new file mode 100644
index 0000000000..618911326a
--- /dev/null
+++ b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/xiaomi-ax3600.json
@@ -0,0 +1,14 @@
+{
+ "vendorName": "Xiaomi",
+ "deviceName": "AX3600",
+ "boardNames": [ "xiaomi,ax3600" ],
+ "partition1MTD": "mtd12",
+ "partition2MTD": "mtd13",
+ "labelOffset": 266432,
+ "bootEnv1": "flag_boot_rootfs",
+ "bootEnv1Partition1Value": 0,
+ "bootEnv1Partition2Value": 1,
+ "bootEnv2": "flag_last_success",
+ "bootEnv2Partition1Value": 0,
+ "bootEnv2Partition2Value": 1
+}
diff --git a/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/xiaomi-ax9000.json b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/xiaomi-ax9000.json
new file mode 100644
index 0000000000..09435b84f2
--- /dev/null
+++ b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/xiaomi-ax9000.json
@@ -0,0 +1,14 @@
+{
+ "vendorName": "Xiaomi",
+ "deviceName": "AX9000",
+ "boardNames": [ "xiaomi,ax9000" ],
+ "partition1MTD": "mtd20",
+ "partition2MTD": "mtd21",
+ "labelOffset": 266432,
+ "bootEnv1": "flag_boot_rootfs",
+ "bootEnv1Partition1Value": 0,
+ "bootEnv1Partition2Value": 1,
+ "bootEnv2": "flag_last_success",
+ "bootEnv2Partition1Value": 0,
+ "bootEnv2Partition2Value": 1
+}