summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-advanced-reboot
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-advanced-reboot')
-rw-r--r--applications/luci-app-advanced-reboot/Makefile1
-rw-r--r--applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js8
-rw-r--r--applications/luci-app-advanced-reboot/po/bg/advanced-reboot.po14
-rw-r--r--applications/luci-app-advanced-reboot/po/de/advanced-reboot.po16
-rw-r--r--applications/luci-app-advanced-reboot/po/nb_NO/advanced-reboot.po6
-rw-r--r--applications/luci-app-advanced-reboot/po/sv/advanced-reboot.po10
-rw-r--r--applications/luci-app-advanced-reboot/po/zh_Hans/advanced-reboot.po8
-rw-r--r--applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices.disabled/netgear-wac510.json14
8 files changed, 49 insertions, 28 deletions
diff --git a/applications/luci-app-advanced-reboot/Makefile b/applications/luci-app-advanced-reboot/Makefile
index 46ebedae9d..a4192271cd 100644
--- a/applications/luci-app-advanced-reboot/Makefile
+++ b/applications/luci-app-advanced-reboot/Makefile
@@ -7,6 +7,7 @@ PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
LUCI_TITLE:=Advanced Linksys Reboot Web UI
+LUCI_URL:=https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
LUCI_DESCRIPTION:=Provides Web UI (found under System/Advanced Reboot) to reboot supported Linksys and ZyXEL routers to\
an alternative partition. Also provides Web UI to shut down (power off) your device. Supported dual-partition\
routers are listed at https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
diff --git a/applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js b/applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js
index 794ac8565e..c9cc20bec0 100644
--- a/applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js
+++ b/applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js
@@ -51,7 +51,7 @@ return view.extend({
'click': ui.hideModal
}, _('Cancel')), ' ',
E('button', {
- 'class': 'cbi-button cbi-button-positive important',
+ 'class': 'btn cbi-button cbi-button-positive important',
'click': L.bind(this.callPowerOff, this)
}, _('Proceed'))
])
@@ -134,7 +134,7 @@ return view.extend({
'click': ui.hideModal
}, _('Cancel')), ' ',
E('button', {
- 'class': 'cbi-button cbi-button-positive important',
+ 'class': 'btn cbi-button cbi-button-positive important',
'click': L.bind(this.handleTogglePartition, this)
}, _('Proceed'))
])
@@ -161,7 +161,7 @@ return view.extend({
_(partition.state),
partition.os.replace("Unknown", _("Unknown")).replace("Compressed", _("Compressed")),
E('button', {
- 'class': 'cbi-button cbi-button-apply important',
+ 'class': 'btn cbi-button cbi-button-apply important',
'click': ui.createHandlerFn(this, func)
}, text)
])
@@ -220,7 +220,7 @@ return view.extend({
body.appendChild(E('hr'));
body.appendChild(
poweroff_supported ? E('button', {
- 'class': 'cbi-button cbi-button-apply important',
+ 'class': 'btn cbi-button cbi-button-apply important',
'click': ui.createHandlerFn(this, 'handlePowerOff')
}, _('Perform power off...'))
diff --git a/applications/luci-app-advanced-reboot/po/bg/advanced-reboot.po b/applications/luci-app-advanced-reboot/po/bg/advanced-reboot.po
index 06ecd62c83..98618ff43d 100644
--- a/applications/luci-app-advanced-reboot/po/bg/advanced-reboot.po
+++ b/applications/luci-app-advanced-reboot/po/bg/advanced-reboot.po
@@ -1,8 +1,14 @@
msgid ""
msgstr ""
+"PO-Revision-Date: 2021-01-26 11:29+0000\n"
+"Last-Translator: Iskren Mihaylov <iskren.mihaylov91@gmail.com>\n"
+"Language-Team: Bulgarian <https://hosted.weblate.org/projects/openwrt/"
+"luciapplicationsadvanced-reboot/bg/>\n"
"Language: bg\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
+"Plural-Forms: nplurals=2; plural=n != 1;\n"
+"X-Generator: Weblate 4.5-dev\n"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:187
#: applications/luci-app-advanced-reboot/root/usr/share/luci/menu.d/luci-app-advanced-reboot.json:3
@@ -16,20 +22,20 @@ msgstr ""
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:162
msgid "Compressed"
-msgstr ""
+msgstr "Архивиран"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:124
msgid "Confirm"
-msgstr ""
+msgstr "Потвърди"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:76
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:105
msgid "Device unreachable! Still waiting for device..."
-msgstr ""
+msgstr "Недостъпно устройство! Все още се изчаква устройството..."
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:197
msgid "ERROR:"
-msgstr ""
+msgstr "ГРЕШКА:"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:205
msgid "Firmware"
diff --git a/applications/luci-app-advanced-reboot/po/de/advanced-reboot.po b/applications/luci-app-advanced-reboot/po/de/advanced-reboot.po
index 636f9b1364..8d6d3b9bc4 100644
--- a/applications/luci-app-advanced-reboot/po/de/advanced-reboot.po
+++ b/applications/luci-app-advanced-reboot/po/de/advanced-reboot.po
@@ -1,14 +1,14 @@
msgid ""
msgstr ""
-"PO-Revision-Date: 2020-07-11 21:29+0000\n"
-"Last-Translator: ssantos <ssantos@web.de>\n"
+"PO-Revision-Date: 2021-02-08 04:46+0000\n"
+"Last-Translator: Zocker1012 <julian.schoemer.1997@gmail.com>\n"
"Language-Team: German <https://hosted.weblate.org/projects/openwrt/"
"luciapplicationsadvanced-reboot/de/>\n"
"Language: de\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
-"X-Generator: Weblate 4.2-dev\n"
+"X-Generator: Weblate 4.5-dev\n"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:187
#: applications/luci-app-advanced-reboot/root/usr/share/luci/menu.d/luci-app-advanced-reboot.json:3
@@ -31,7 +31,7 @@ msgstr "Bestätigen"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:76
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:105
msgid "Device unreachable! Still waiting for device..."
-msgstr ""
+msgstr "Gerät nicht erreichbar! Warte immer noch..."
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:197
msgid "ERROR:"
@@ -91,7 +91,7 @@ msgstr "Von aktueller Partition neu starten"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:98
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:103
msgid "Rebooting…"
-msgstr ""
+msgstr "Neustart…"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:37
msgid "Shutting down..."
@@ -104,7 +104,7 @@ msgstr "Status"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:65
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:94
msgid "The reboot command failed with code %d"
-msgstr ""
+msgstr "Der Neustartbefehl ist mit dem Code %d fehlgeschlagen"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:99
msgid ""
@@ -131,7 +131,7 @@ msgstr ""
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:10
msgid "Unable to find Device Board Name."
-msgstr ""
+msgstr "Kann Gerätename nicht finden."
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:11
msgid "Unable to find Dual Boot Flag Partition."
@@ -186,7 +186,7 @@ msgstr ""
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:70
msgid "Waiting for device..."
-msgstr ""
+msgstr "Warte auf Gerät..."
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:215
msgid "Warning: Device (%s) is unknown or isn't a dual-partition device!"
diff --git a/applications/luci-app-advanced-reboot/po/nb_NO/advanced-reboot.po b/applications/luci-app-advanced-reboot/po/nb_NO/advanced-reboot.po
index 7c4bb73640..5604934270 100644
--- a/applications/luci-app-advanced-reboot/po/nb_NO/advanced-reboot.po
+++ b/applications/luci-app-advanced-reboot/po/nb_NO/advanced-reboot.po
@@ -1,6 +1,6 @@
msgid ""
msgstr ""
-"PO-Revision-Date: 2020-12-13 05:29+0000\n"
+"PO-Revision-Date: 2021-02-08 10:51+0000\n"
"Last-Translator: Allan Nordhøy <epost@anotheragency.no>\n"
"Language-Team: Norwegian Bokmål <https://hosted.weblate.org/projects/openwrt/"
"luciapplicationsadvanced-reboot/nb_NO/>\n"
@@ -8,7 +8,7 @@ msgstr ""
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
-"X-Generator: Weblate 4.4-dev\n"
+"X-Generator: Weblate 4.5-dev\n"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:187
#: applications/luci-app-advanced-reboot/root/usr/share/luci/menu.d/luci-app-advanced-reboot.json:3
@@ -18,7 +18,7 @@ msgstr ""
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:52
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:135
msgid "Cancel"
-msgstr ""
+msgstr "Avbryt"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:162
msgid "Compressed"
diff --git a/applications/luci-app-advanced-reboot/po/sv/advanced-reboot.po b/applications/luci-app-advanced-reboot/po/sv/advanced-reboot.po
index c49338431b..ae8c329872 100644
--- a/applications/luci-app-advanced-reboot/po/sv/advanced-reboot.po
+++ b/applications/luci-app-advanced-reboot/po/sv/advanced-reboot.po
@@ -1,14 +1,14 @@
msgid ""
msgstr ""
-"PO-Revision-Date: 2020-08-20 15:36+0000\n"
-"Last-Translator: Luna Jernberg <droidbittin@gmail.com>\n"
+"PO-Revision-Date: 2021-02-07 14:21+0000\n"
+"Last-Translator: Simon <swedafone@hotmail.com>\n"
"Language-Team: Swedish <https://hosted.weblate.org/projects/openwrt/"
"luciapplicationsadvanced-reboot/sv/>\n"
"Language: sv\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
-"X-Generator: Weblate 4.2.1-dev\n"
+"X-Generator: Weblate 4.5-dev\n"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:187
#: applications/luci-app-advanced-reboot/root/usr/share/luci/menu.d/luci-app-advanced-reboot.json:3
@@ -22,7 +22,7 @@ msgstr "Avbryt"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:162
msgid "Compressed"
-msgstr ""
+msgstr "Komprimerad"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:124
msgid "Confirm"
@@ -31,7 +31,7 @@ msgstr "Bekräfta"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:76
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:105
msgid "Device unreachable! Still waiting for device..."
-msgstr ""
+msgstr "Enheten ej nåbar! Väntar fortfarande på enheten..."
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:197
msgid "ERROR:"
diff --git a/applications/luci-app-advanced-reboot/po/zh_Hans/advanced-reboot.po b/applications/luci-app-advanced-reboot/po/zh_Hans/advanced-reboot.po
index 00deef253c..5d1a7346f3 100644
--- a/applications/luci-app-advanced-reboot/po/zh_Hans/advanced-reboot.po
+++ b/applications/luci-app-advanced-reboot/po/zh_Hans/advanced-reboot.po
@@ -5,8 +5,8 @@
msgid ""
msgstr ""
"Project-Id-Version: \n"
-"PO-Revision-Date: 2020-11-18 13:28+0000\n"
-"Last-Translator: SunSpring <yearnsun@gmail.com>\n"
+"PO-Revision-Date: 2021-02-05 14:57+0000\n"
+"Last-Translator: zheshifandian <sunjiazheng321521@gmail.com>\n"
"Language-Team: Chinese (Simplified) <https://hosted.weblate.org/projects/"
"openwrt/luciapplicationsadvanced-reboot/zh_Hans/>\n"
"Language: zh_Hans\n"
@@ -14,7 +14,7 @@ msgstr ""
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=1; plural=0;\n"
-"X-Generator: Weblate 4.4-dev\n"
+"X-Generator: Weblate 4.5-dev\n"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:187
#: applications/luci-app-advanced-reboot/root/usr/share/luci/menu.d/luci-app-advanced-reboot.json:3
@@ -24,7 +24,7 @@ msgstr "高级重启"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:52
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:135
msgid "Cancel"
-msgstr "取消"
+msgstr "关闭"
#: applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js:162
msgid "Compressed"
diff --git a/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices.disabled/netgear-wac510.json b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices.disabled/netgear-wac510.json
new file mode 100644
index 0000000000..b9067c4d4b
--- /dev/null
+++ b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices.disabled/netgear-wac510.json
@@ -0,0 +1,14 @@
+{
+ "vendorName": "Netgear",
+ "deviceName": "WAC510",
+ "boardNames": [ "netgear,wac510" ],
+ "partition1MTD": "mtd9",
+ "partition2MTD": "mtd10",
+ "labelOffset": null,
+ "bootEnv1": "primary",
+ "bootEnv1Partition1Value": 0,
+ "bootEnv1Partition2Value": 3800000,
+ "bootEnv2": "secondary",
+ "bootEnv2Partition1Value": 3800000,
+ "bootEnv2Partition2Value": 0
+}