summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-advanced-reboot
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-advanced-reboot')
-rw-r--r--applications/luci-app-advanced-reboot/Makefile4
-rw-r--r--applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua2
-rw-r--r--applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm14
-rw-r--r--applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/alternative_reboot.htm6
-rw-r--r--applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/power_off.htm6
-rw-r--r--applications/luci-app-advanced-reboot/po/ru/advanced-reboot.po18
-rw-r--r--applications/luci-app-advanced-reboot/po/sv/advanced-reboot.po15
-rw-r--r--applications/luci-app-advanced-reboot/po/templates/advanced-reboot.pot5
8 files changed, 38 insertions, 32 deletions
diff --git a/applications/luci-app-advanced-reboot/Makefile b/applications/luci-app-advanced-reboot/Makefile
index b1ecf677f0..08919640d7 100644
--- a/applications/luci-app-advanced-reboot/Makefile
+++ b/applications/luci-app-advanced-reboot/Makefile
@@ -1,4 +1,4 @@
-# Copyright (c) 2017 Stan Grishin (stangri@melmac.net)
+# Copyright 2017-2018 Stan Grishin (stangri@melmac.net)
# This is free software, licensed under the GNU General Public License v3.
include $(TOPDIR)/rules.mk
@@ -13,7 +13,7 @@ LUCI_DESCRIPTION:=Provides Web UI (found under System/Advanced Reboot) to reboot
LUCI_DEPENDS:=+luci-mod-admin-full
LUCI_PKGARCH:=all
-PKG_RELEASE:=32
+PKG_RELEASE:=33
include ../../luci.mk
diff --git a/applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua b/applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua
index f4d28145ea..dd8071677e 100644
--- a/applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua
+++ b/applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua
@@ -1,4 +1,4 @@
--- Copyright 2017 Stan Grishin <stangri@melmac.net>
+-- Copyright 2017-2018 Stan Grishin <stangri@melmac.net>
-- Licensed to the public under the Apache License 2.0.
module("luci.controller.advanced_reboot", package.seeall)
diff --git a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm
index dcf51c749e..5c14f52ff8 100644
--- a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm
+++ b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm
@@ -1,7 +1,7 @@
<%#
Copyright 2008 Steven Barth <steven@midlink.org>
Copyright 2008-2015 Jo-Philipp Wich <jow@openwrt.org>
- Copyright 2017 Stan Grishin <stangri@melmac.net>
+ Copyright 2017-2018 Stan Grishin <stangri@melmac.net>
Licensed to the public under the Apache License 2.0.
-%>
@@ -42,12 +42,12 @@
<%- if boot_envvar1_partition_one == current_partition then -%>
<form method="post" action="<%=url('admin/system/advanced_reboot/reboot')%>">
<input type="hidden" name="token" value="<%=token%>" />
- <input id="reboot-button" type="submit" class="cbi-button cbi-button-apply" value="<%:Reboot to current partition%>" />
+ <input id="reboot-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Reboot to current partition%>" />
</form>
<%- else -%>
<form method="post" action="<%=url('admin/system/advanced_reboot/alternative_reboot')%>">
<input type="hidden" name="token" value="<%=token%>" />
- <input id="altreboot-button" type="submit" class="cbi-button cbi-button-apply" value="<%:Reboot to alternative partition...%>" />
+ <input id="altreboot-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Reboot to alternative partition...%>" />
</form>
<%- end -%>
</div>
@@ -66,12 +66,12 @@
<%- if boot_envvar1_partition_two == current_partition then -%>
<form method="post" action="<%=url('admin/system/advanced_reboot/reboot')%>">
<input type="hidden" name="token" value="<%=token%>" />
- <input id="reboot-button" type="submit" class="cbi-button cbi-button-apply" value="<%:Reboot to current partition%>" />
+ <input id="reboot-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Reboot to current partition%>" />
</form>
<%- else -%>
<form method="post" action="<%=url('admin/system/advanced_reboot/alternative_reboot')%>">
<input type="hidden" name="token" value="<%=token%>" />
- <input id="altreboot-button" type="submit" class="cbi-button cbi-button-apply" value="<%:Reboot to alternative partition...%>" />
+ <input id="altreboot-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Reboot to alternative partition...%>" />
</form>
<%- end -%>
</div>
@@ -82,7 +82,7 @@
<%- if rom_board_name then -%>
<p class="alert-message warning"><%=pcdata(translatef("Warning: Device (%s) is unknown or isn't a dual-partition device!", rom_board_name))%></p>
<%- else -%>
- <p class="alert-message warning"><%:Warning: Unable to obtain device information!%></p>
+ <p class="alert-message warning"><%=pcdata(translatef("Warning: Unable to obtain device information!"))%></p>
<%- end -%>
<%- end -%>
@@ -91,7 +91,7 @@
<%- if nixio.fs.access("/sbin/poweroff") then -%>
<form method="post" action="<%=url('admin/system/advanced_reboot/power_off')%>">
<input type="hidden" name="token" value="<%=token%>" />
- <input id="poweroff-button" type="submit" class="cbi-button cbi-button-apply" value="<%:Perform power off...%>" />
+ <input id="poweroff-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Perform power off...%>" />
</form>
<%- else -%>
<p class="alert-message warning"><%:Warning: This system does not support powering off!%></p>
diff --git a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/alternative_reboot.htm b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/alternative_reboot.htm
index 6325934094..b15f16b0d5 100644
--- a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/alternative_reboot.htm
+++ b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/alternative_reboot.htm
@@ -1,7 +1,7 @@
<%#
Copyright 2008 Steven Barth <steven@midlink.org>
Copyright 2008-2009 Jo-Philipp Wich <jow@openwrt.org>
- Copyright 2017 Stan Grishin <stangri@melmac.net>
+ Copyright 2017-2018 Stan Grishin <stangri@melmac.net>
Licensed to the public under the Apache License 2.0.
-%>
@@ -21,8 +21,8 @@
<form class="inline" action="<%=REQUEST_URI%>" method="post">
<input type="hidden" name="token" value="<%=token%>" />
<input type="hidden" name="step" value="2" />
- <input class="cbi-button cbi-button-reset" name="cancel" type="submit" value="<%:Cancel%>" />
- <input class="cbi-button cbi-button-apply" type="submit" value="<%:Proceed%>" />
+ <input class="cbi-button cbi-button-reset important" name="cancel" type="submit" value="<%:Cancel%>" />
+ <input class="cbi-button cbi-button-apply important" type="submit" value="<%:Proceed%>" />
</form>
</div>
diff --git a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/power_off.htm b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/power_off.htm
index 0ddea11e65..1acf01b995 100644
--- a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/power_off.htm
+++ b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/power_off.htm
@@ -1,7 +1,7 @@
<%#
Copyright 2008 Steven Barth <steven@midlink.org>
Copyright 2008-2009 Jo-Philipp Wich <jow@openwrt.org>
- Copyright 2017 Stan Grishin <stangri@melmac.net>
+ Copyright 2017-2018 Stan Grishin <stangri@melmac.net>
Licensed to the public under the Apache License 2.0.
-%>
@@ -17,8 +17,8 @@
<form class="inline" action="<%=REQUEST_URI%>" method="post">
<input type="hidden" name="token" value="<%=token%>" />
<input type="hidden" name="step" value="2" />
- <input class="cbi-button cbi-button-reset" name="cancel" type="submit" value="<%:Cancel%>" />
- <input class="cbi-button cbi-button-apply" type="submit" value="<%:Proceed%>" />
+ <input class="cbi-button cbi-button-reset important" name="cancel" type="submit" value="<%:Cancel%>" />
+ <input class="cbi-button cbi-button-apply important" type="submit" value="<%:Proceed%>" />
</form>
</div>
diff --git a/applications/luci-app-advanced-reboot/po/ru/advanced-reboot.po b/applications/luci-app-advanced-reboot/po/ru/advanced-reboot.po
index 75d463677b..8ad352055f 100644
--- a/applications/luci-app-advanced-reboot/po/ru/advanced-reboot.po
+++ b/applications/luci-app-advanced-reboot/po/ru/advanced-reboot.po
@@ -22,9 +22,6 @@ msgstr "Дополнительная перезагрузка"
msgid "Alternative"
msgstr "Альтернатива"
-msgid "Alternative reboot cancelled."
-msgstr "Альтернативная перезагрузка отменена."
-
msgid "Cancel"
msgstr "Отменить"
@@ -148,16 +145,25 @@ msgstr ""
"которое не поддерживает выключение питания.<br /><br /> Нажмите \"Продолжить"
"\" ниже, чтобы выключить устройство."
+msgid "Warning: Device (%s) is unknown or isn't a dual-partition device!"
+msgstr ""
+
msgid "Warning: There are unsaved changes that will get lost on reboot!"
msgstr ""
"Внимание: Есть несохраненные изменения, которые будут потеряны при "
"перезагрузке!"
-msgid "Warning: This system does not have two partitions!"
-msgstr "Внимание: Эта система не имеет двух разделов!"
-
msgid "Warning: This system does not support powering off!"
msgstr "Внимание: Эта система не поддерживает отключение питания!"
+msgid "Warning: Unable to obtain device information!"
+msgstr ""
+
msgid "to"
msgstr ""
+
+#~ msgid "Alternative reboot cancelled."
+#~ msgstr "Альтернативная перезагрузка отменена."
+
+#~ msgid "Warning: This system does not have two partitions!"
+#~ msgstr "Внимание: Эта система не имеет двух разделов!"
diff --git a/applications/luci-app-advanced-reboot/po/sv/advanced-reboot.po b/applications/luci-app-advanced-reboot/po/sv/advanced-reboot.po
index e0e13cfda9..46008b1322 100644
--- a/applications/luci-app-advanced-reboot/po/sv/advanced-reboot.po
+++ b/applications/luci-app-advanced-reboot/po/sv/advanced-reboot.po
@@ -10,9 +10,6 @@ msgstr "Avancerad omstart"
msgid "Alternative"
msgstr "Alternativ"
-msgid "Alternative reboot cancelled."
-msgstr ""
-
msgid "Cancel"
msgstr "Avbryt"
@@ -119,15 +116,21 @@ msgstr ""
"stöd för avstängning.<br /><br /> Klicka på \"Fortsätt\" nedanför för att "
"stänga av din enhet."
+msgid "Warning: Device (%s) is unknown or isn't a dual-partition device!"
+msgstr ""
+
msgid "Warning: There are unsaved changes that will get lost on reboot!"
msgstr ""
"Varning: Det finns osparade ändringar som kommer att förloras vid omstart!"
-msgid "Warning: This system does not have two partitions!"
-msgstr "Varning: Det här systemet har inte två partitioner!"
-
msgid "Warning: This system does not support powering off!"
msgstr "Varning: Det här systemet har inte stöd för avstängning!"
+msgid "Warning: Unable to obtain device information!"
+msgstr ""
+
msgid "to"
msgstr ""
+
+#~ msgid "Warning: This system does not have two partitions!"
+#~ msgstr "Varning: Det här systemet har inte två partitioner!"
diff --git a/applications/luci-app-advanced-reboot/po/templates/advanced-reboot.pot b/applications/luci-app-advanced-reboot/po/templates/advanced-reboot.pot
index edc8c2a062..8324ea4e2e 100644
--- a/applications/luci-app-advanced-reboot/po/templates/advanced-reboot.pot
+++ b/applications/luci-app-advanced-reboot/po/templates/advanced-reboot.pot
@@ -1,9 +1,6 @@
msgid ""
msgstr "Content-Type: text/plain; charset=UTF-8"
-msgid ") is unknown or isn't a dual-partition device!"
-msgstr ""
-
msgid "Action"
msgstr ""
@@ -113,7 +110,7 @@ msgid ""
"device."
msgstr ""
-msgid "Warning: Device ("
+msgid "Warning: Device (%s) is unknown or isn't a dual-partition device!"
msgstr ""
msgid "Warning: There are unsaved changes that will get lost on reboot!"