summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-advanced-reboot
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-advanced-reboot')
-rw-r--r--applications/luci-app-advanced-reboot/Makefile2
-rw-r--r--applications/luci-app-advanced-reboot/README.md2
-rw-r--r--applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-e4200v2.lua14
-rw-r--r--applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea3500.lua2
-rw-r--r--applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea4500.lua14
-rw-r--r--applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm10
-rw-r--r--applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/alternative_reboot.htm4
-rw-r--r--applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/power_off.htm4
-rw-r--r--applications/luci-app-advanced-reboot/po/sv/advanced-reboot.po36
9 files changed, 68 insertions, 20 deletions
diff --git a/applications/luci-app-advanced-reboot/Makefile b/applications/luci-app-advanced-reboot/Makefile
index 79197c43ba..7be53efcb9 100644
--- a/applications/luci-app-advanced-reboot/Makefile
+++ b/applications/luci-app-advanced-reboot/Makefile
@@ -12,7 +12,7 @@ LUCI_DESCRIPTION:=Provides Web UI (found under System/Advanced Reboot) to reboot
routers are listed at https://github.com/openwrt/luci/blob/master/applications/luci-app-advanced-reboot/README.md
LUCI_DEPENDS:=+luci-compat +luci-mod-admin-full
LUCI_PKGARCH:=all
-PKG_RELEASE:=54
+PKG_RELEASE:=55
include ../../luci.mk
diff --git a/applications/luci-app-advanced-reboot/README.md b/applications/luci-app-advanced-reboot/README.md
index 85c10fcc12..35b2d32d7b 100644
--- a/applications/luci-app-advanced-reboot/README.md
+++ b/applications/luci-app-advanced-reboot/README.md
@@ -1,5 +1,7 @@
# Advanced Reboot Web UI (luci-app-advanced-reboot)
+[![HitCount](http://hits.dwyl.com/stangri/openwrt/luci-app-advanced-reboot.svg)](http://hits.dwyl.com/stangri/openwrt/luci-app-advanced-reboot)
+
## Description
This package allows you to reboot to an alternative partition on the supported (dual-partition) routers and to power off (power down) your OpenWrt device.
diff --git a/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-e4200v2.lua b/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-e4200v2.lua
new file mode 100644
index 0000000000..50c4970ed9
--- /dev/null
+++ b/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-e4200v2.lua
@@ -0,0 +1,14 @@
+return {
+ vendorName = "Linksys",
+ deviceName = "E4200v2",
+ boardNames = { "linksys-e4200v2", "linksys,e4200v2" },
+ partition1MTD = "mtd3",
+ partition2MTD = "mtd5",
+ labelOffset = 32,
+ bootEnv1 = "boot_part",
+ bootEnv1Partition1Value = 1,
+ bootEnv1Partition2Value = 2,
+ bootEnv2 = "bootcmd",
+ bootEnv2Partition1Value = "run nandboot",
+ bootEnv2Partition2Value = "run altnandboot"
+}
diff --git a/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea3500.lua b/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea3500.lua
index 553788fd57..2b72cd4b7d 100644
--- a/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea3500.lua
+++ b/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea3500.lua
@@ -1,7 +1,7 @@
return {
vendorName = "Linksys",
deviceName = "EA3500",
- boardNames = { "linksys-audi", "linksys,audi" },
+ boardNames = { "linksys-audi", "linksys,audi", "linksys-ea3500", "linksys,ea3500" },
partition1MTD = "mtd3",
partition2MTD = "mtd5",
labelOffset = 32,
diff --git a/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea4500.lua b/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea4500.lua
new file mode 100644
index 0000000000..10f53d1d78
--- /dev/null
+++ b/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea4500.lua
@@ -0,0 +1,14 @@
+return {
+ vendorName = "Linksys",
+ deviceName = "EA4500",
+ boardNames = { "linksys-e4500", "linksys,e4500" },
+ partition1MTD = "mtd3",
+ partition2MTD = "mtd5",
+ labelOffset = 32,
+ bootEnv1 = "boot_part",
+ bootEnv1Partition1Value = 1,
+ bootEnv1Partition2Value = 2,
+ bootEnv2 = "bootcmd",
+ bootEnv2Partition1Value = "run nandboot",
+ bootEnv2Partition2Value = "run altnandboot"
+}
diff --git a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm
index 49985b32ce..a28418cc5f 100644
--- a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm
+++ b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm
@@ -42,12 +42,12 @@
<%- if bev1p1 == current_partition then -%>
<form method="post" action="<%=url('admin/system/advanced_reboot/reboot')%>">
<input type="hidden" name="token" value="<%=token%>" />
- <input id="reboot-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Reboot to current partition%>" />
+ <input id="reboot-button" type="submit" class="btn cbi-button cbi-button-apply important" value="<%:Reboot to current partition%>" />
</form>
<%- else -%>
<form method="post" action="<%=url('admin/system/advanced_reboot/alternative_reboot')%>">
<input type="hidden" name="token" value="<%=token%>" />
- <input id="altreboot-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Reboot to alternative partition...%>" />
+ <input id="altreboot-button" type="submit" class="btn cbi-button cbi-button-apply important" value="<%:Reboot to alternative partition...%>" />
</form>
<%- end -%>
</div>
@@ -66,12 +66,12 @@
<%- if bev1p2 == current_partition then -%>
<form method="post" action="<%=url('admin/system/advanced_reboot/reboot')%>">
<input type="hidden" name="token" value="<%=token%>" />
- <input id="reboot-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Reboot to current partition%>" />
+ <input id="reboot-button" type="submit" class="btn cbi-button cbi-button-apply important" value="<%:Reboot to current partition%>" />
</form>
<%- else -%>
<form method="post" action="<%=url('admin/system/advanced_reboot/alternative_reboot')%>">
<input type="hidden" name="token" value="<%=token%>" />
- <input id="altreboot-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Reboot to alternative partition...%>" />
+ <input id="altreboot-button" type="submit" class="btn cbi-button cbi-button-apply important" value="<%:Reboot to alternative partition...%>" />
</form>
<%- end -%>
</div>
@@ -91,7 +91,7 @@
<%- if nixio.fs.access("/sbin/poweroff") then -%>
<form method="post" action="<%=url('admin/system/advanced_reboot/power_off')%>">
<input type="hidden" name="token" value="<%=token%>" />
- <input id="poweroff-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Perform power off...%>" />
+ <input id="poweroff-button" type="submit" class="btn cbi-button cbi-button-apply important" value="<%:Perform power off...%>" />
</form>
<%- else -%>
<p class="alert-message warning"><%:Warning: This system does not support powering off!%></p>
diff --git a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/alternative_reboot.htm b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/alternative_reboot.htm
index db11020628..b81aaf4558 100644
--- a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/alternative_reboot.htm
+++ b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/alternative_reboot.htm
@@ -21,8 +21,8 @@
<form class="inline" action="<%=REQUEST_URI%>" method="post">
<input type="hidden" name="token" value="<%=token%>" />
<input type="hidden" name="step" value="2" />
- <input class="cbi-button cbi-button-reset important" name="cancel" type="submit" value="<%:Cancel%>" />
- <input class="cbi-button cbi-button-apply important" type="submit" value="<%:Proceed%>" />
+ <input class="btn cbi-button cbi-button-reset important" name="cancel" type="submit" value="<%:Cancel%>" />
+ <input class="btn cbi-button cbi-button-apply important" type="submit" value="<%:Proceed%>" />
</form>
</div>
diff --git a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/power_off.htm b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/power_off.htm
index 1acf01b995..56200a4c1c 100644
--- a/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/power_off.htm
+++ b/applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/power_off.htm
@@ -17,8 +17,8 @@
<form class="inline" action="<%=REQUEST_URI%>" method="post">
<input type="hidden" name="token" value="<%=token%>" />
<input type="hidden" name="step" value="2" />
- <input class="cbi-button cbi-button-reset important" name="cancel" type="submit" value="<%:Cancel%>" />
- <input class="cbi-button cbi-button-apply important" type="submit" value="<%:Proceed%>" />
+ <input class="btn cbi-button cbi-button-reset important" name="cancel" type="submit" value="<%:Cancel%>" />
+ <input class="btn cbi-button cbi-button-apply important" type="submit" value="<%:Proceed%>" />
</form>
</div>
diff --git a/applications/luci-app-advanced-reboot/po/sv/advanced-reboot.po b/applications/luci-app-advanced-reboot/po/sv/advanced-reboot.po
index 4efc94ce9e..ab4b21cddf 100644
--- a/applications/luci-app-advanced-reboot/po/sv/advanced-reboot.po
+++ b/applications/luci-app-advanced-reboot/po/sv/advanced-reboot.po
@@ -1,14 +1,14 @@
msgid ""
msgstr ""
-"PO-Revision-Date: 2019-12-03 08:27+0000\n"
-"Last-Translator: Mattias Münster <mattiasmun@gmail.com>\n"
+"PO-Revision-Date: 2020-08-20 15:36+0000\n"
+"Last-Translator: Luna Jernberg <droidbittin@gmail.com>\n"
"Language-Team: Swedish <https://hosted.weblate.org/projects/openwrt/"
"luciapplicationsadvanced-reboot/sv/>\n"
"Language: sv\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
-"X-Generator: Weblate 3.10-dev\n"
+"X-Generator: Weblate 4.2.1-dev\n"
#: applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua:171
#: applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm:10
@@ -27,7 +27,7 @@ msgstr "Avbryt"
#: applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/applyreboot.htm:42
msgid "Changes applied."
-msgstr ""
+msgstr "Ändringar tillämpade. "
#: applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua:131
#: applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua:132
@@ -46,11 +46,11 @@ msgstr "Nuvarande"
#: applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm:18
msgid "ERROR:"
-msgstr ""
+msgstr "FEL:"
#: applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm:28
msgid "Firmware"
-msgstr ""
+msgstr "Firmware"
#: applications/luci-app-advanced-reboot/root/usr/share/rpcd/acl.d/luci-app-advanced-reboot.json:3
msgid "Grant UCI and file access for luci-app-advanced-reboot"
@@ -62,7 +62,7 @@ msgstr "Laddar"
#: applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua:213
msgid "No access to fw_printenv or fw_printenv!"
-msgstr ""
+msgstr "Ingen åtkomst till fw_printenv eller fw_printenv! "
#: applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm:26
msgid "Partition"
@@ -129,6 +129,9 @@ msgid ""
"address of your computer to reach the device again, depending on your "
"settings."
msgstr ""
+"Systemet startar om nu. <br /> STÄNG INTE AV ENHETEN!<br /> Vänta ett par "
+"minuter innan du försöker ansluta. Du kan behöva förnya adressen på din "
+"dator för att nå enheten igen, beroende på inställningarna."
#: applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua:265
msgid ""
@@ -137,6 +140,10 @@ msgid ""
"might be necessary to renew the address of your computer to reach the device "
"again, depending on your settings."
msgstr ""
+"Systemet startar om till en alternativ partition nu.<br />STÄNG INTE AV "
+"ENHETEN!<br /> Vänta ett par minuter innan du försöker ansluta. Du kan "
+"behöva förnya adressen på din dator för att nå enheten igen, beroende på "
+"inställningarna. "
#: applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua:298
msgid ""
@@ -153,7 +160,7 @@ msgstr ""
#: applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua:248
#: applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua:249
msgid "Unable to find Dual Boot Flag Partition."
-msgstr ""
+msgstr "Det gick inte att hitta Dual Boot Flag Partition."
#: applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua:220
#: applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua:221
@@ -192,6 +199,15 @@ msgid ""
"back to the currently active partition.<br /><br /> Click \"Proceed\" below "
"to reboot device to an alternative partition."
msgstr ""
+"VARNING: En alternativ partition kan ha sina egna inställningar och helt "
+"annan firmware.<br /> <br />Eftersom din nätverkskonfiguration och WiFi SSID "
+"/ lösenord på alternativ partition kan vara annorlunda, kan du behöva "
+"justera dina datorinställningar för att kunna nå din enhet igen efter "
+"omstart.\n"
+"<br /> <br /> Tänk också på att en alternativ partition firmware kanske inte "
+"är ett enkelt sätt att växla aktiv partition och starta tillbaka till den "
+"aktiva partitionen. <br /> <br / > Klicka på \"Fortsätt\" nedan för att "
+"starta om enheten till en alternativ partition."
#: applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/power_off.htm:12
msgid ""
@@ -210,6 +226,8 @@ msgstr "Väntar på att ändringarna ska bli verkställda..."
#: applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm:83
msgid "Warning: Device (%s) is unknown or isn't a dual-partition device!"
msgstr ""
+"Varning: Enheten (% s) är okänd eller är inte en enhet med dubbla "
+"partitioner!"
#: applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm:14
msgid "Warning: There are unsaved changes that will get lost on reboot!"
@@ -222,7 +240,7 @@ msgstr "Varning: Det här systemet har inte stöd för avstängning!"
#: applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm:85
msgid "Warning: Unable to obtain device information!"
-msgstr ""
+msgstr "Varning: Det går inte att få information om enheten!"
#: applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua:45
msgid "attempting to mount alternative partition (mtd%s)"