summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-adblock-fast/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-adblock-fast/Makefile')
-rw-r--r--applications/luci-app-adblock-fast/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/applications/luci-app-adblock-fast/Makefile b/applications/luci-app-adblock-fast/Makefile
index cc7948130d..defaa96ae4 100644
--- a/applications/luci-app-adblock-fast/Makefile
+++ b/applications/luci-app-adblock-fast/Makefile
@@ -1,16 +1,25 @@
-# Copyright 2023 MOSSDeF, Stan Grishin (stangri@melmac.ca)
-# This is free software, licensed under the GNU General Public License v3.
+# Copyright 2023-2024 MOSSDeF, Stan Grishin (stangri@melmac.ca).
+# This is free software, licensed under AGPL-3.0-or-later.
include $(TOPDIR)/rules.mk
-PKG_LICENSE:=GPL-3.0-or-later
+PKG_NAME:=luci-app-adblock-fast
+PKG_LICENSE:=AGPL-3.0-or-later
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
-PKG_VERSION:=1.1.1-r7
+PKG_VERSION:=1.1.2
+PKG_RELEASE:=1
LUCI_TITLE:=AdBlock-Fast Web UI
LUCI_DESCRIPTION:=Provides Web UI for adblock-fast service.
LUCI_DEPENDS:=+luci-base +adblock-fast +jsonfilter
-LUCI_PKGARCH:=all
+
+define Package/$(PKG_NAME)/config
+# shown in make menuconfig <Help>
+help
+ $(LUCI_TITLE)
+ .
+ Version: $(PKG_VERSION)-$(PKG_RELEASE)
+endef
include ../../luci.mk