summaryrefslogtreecommitdiffhomepage
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000..a57acf497
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,22 @@
+include build/config.mk
+
+MODULES = applications/* core modules/* themes/*
+LUA_TARGET = source
+
+
+.PHONY: all build clean host hostclean
+
+all: build
+
+build:
+ for i in $(MODULES); do make -C$$i $(LUA_TARGET); done
+
+clean:
+ for i in $(MODULES); do make -C$$i clean; done
+
+host: build
+ mkdir -p host/ffluci
+ for i in $(MODULES); do cp $$i/dist$(LUCI_INSTALLDIR) host/ffluci -R; done
+
+hostclean:
+ rm host -rf \ No newline at end of file