summaryrefslogtreecommitdiffhomepage
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 21c88b2db..efccd79d0 100644
--- a/Makefile
+++ b/Makefile
@@ -3,6 +3,8 @@ include build/config.mk
MODULES = contrib/* applications/* libs/* modules/* themes/* i18n/*
OS:=$(shell uname)
+MODULES:=$(foreach item,$(wildcard $(MODULES)),$(if $(realpath $(wildcard $(item)/Makefile)),$(item)))
+
export OS
.PHONY: all build gccbuild luabuild clean host gcchost luahost hostcopy hostclean