summaryrefslogtreecommitdiffhomepage
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 4b3fb64f4b..d76be9a2de 100644
--- a/Makefile
+++ b/Makefile
@@ -1,8 +1,12 @@
include build/config.mk
MODULES = applications/* libs/* modules/* themes/* i18n/*
-LUA_TARGET = source
-
+LUA_TARGET = compile
+OS:=$(shell uname)
+export OS
+ifeq ($(OS),Darwin)
+ MODULES += contrib/luaposix
+endif
.PHONY: all build clean host hostclean