summaryrefslogtreecommitdiffhomepage
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 12c1d89e0..a9e5e1eb2 100644
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,7 @@ luabuild:
for i in $(MODULES); do make -C$$i lua$(LUA_TARGET); done
clean:
+ rm -rf docs
for i in $(MODULES); do make -C$$i clean; done
@@ -58,6 +59,9 @@ runshell: hostenv
hostclean: clean
rm -rf host
+apidocs: hostenv
+ build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "build/makedocs.sh host/luci/ docs"
+
run:
# make run is deprecated #
# Please use: #