diff options
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 27 |
1 files changed, 21 insertions, 6 deletions
@@ -1,27 +1,42 @@ include build/config.mk MODULES = applications/* libs/* modules/* themes/* i18n/* -LUA_TARGET = compile +LUA_TARGET = source + +### luaposix merge (temporary) ### OS:=$(shell uname) export OS ifeq ($(OS),Darwin) MODULES += contrib/luaposix endif -.PHONY: all build clean host hostclean + +.PHONY: all build gccbuild luabuild clean host gcchost luahost hostcopy hostclean all: build -build: - for i in $(MODULES); do make -C$$i $(LUA_TARGET); done +build: luabuild gccbuild + +gccbuild: + for i in $(MODULES); do make -C$$i compile; done + +luabuild: + for i in $(MODULES); do make -C$$i lua$(LUA_TARGET); done clean: for i in $(MODULES); do make -C$$i clean; done -host: build + +host: build hostcopy + +gcchost: gccbuild hostcopy + +luahost: luabuild hostcopy + +hostcopy: mkdir -p host for i in $(MODULES); do cp $$i/dist/* host/ -R 2>/dev/null || true; done ln -sf .$(LUCI_INSTALLDIR) host/luci hostclean: clean - rm host -rf + rm -rf host |