summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--applications/luci-app-ddns/Makefile2
-rwxr-xr-xapplications/luci-app-ddns/luasrc/controller/ddns.lua2
-rwxr-xr-xapplications/luci-app-ddns/luasrc/tools/ddns.lua16
-rw-r--r--applications/luci-app-ddns/po/templates/ddns.pot12
4 files changed, 21 insertions, 11 deletions
diff --git a/applications/luci-app-ddns/Makefile b/applications/luci-app-ddns/Makefile
index 27008166c..146560efa 100644
--- a/applications/luci-app-ddns/Makefile
+++ b/applications/luci-app-ddns/Makefile
@@ -10,7 +10,7 @@ PKG_NAME:=luci-app-ddns
# Version == major.minor.patch
# increase on new functionality (minor) or patches (patch)
-PKG_VERSION:=2.4.0
+PKG_VERSION:=2.4.1
# Release == build
# increase on changes of translation files
diff --git a/applications/luci-app-ddns/luasrc/controller/ddns.lua b/applications/luci-app-ddns/luasrc/controller/ddns.lua
index e141d07b6..7cfbc56a0 100755
--- a/applications/luci-app-ddns/luasrc/controller/ddns.lua
+++ b/applications/luci-app-ddns/luasrc/controller/ddns.lua
@@ -22,7 +22,7 @@ local srv_ver_min = "2.6.0" -- minimum version of service required
local srv_ver_cmd = [[/usr/lib/ddns/dynamic_dns_updater.sh --version | awk {'print $2'}]]
local app_name = "luci-app-ddns"
local app_title = "Dynamic DNS"
-local app_version = "2.4.0-1"
+local app_version = "2.4.1-1"
function index()
local nxfs = require "nixio.fs" -- global definitions not available
diff --git a/applications/luci-app-ddns/luasrc/tools/ddns.lua b/applications/luci-app-ddns/luasrc/tools/ddns.lua
index 8868f32bc..54791432b 100755
--- a/applications/luci-app-ddns/luasrc/tools/ddns.lua
+++ b/applications/luci-app-ddns/luasrc/tools/ddns.lua
@@ -16,16 +16,16 @@ local function _check_certs()
return (v > 0)
end
-has_wgetssl = (UTIL.exec( [[which wget-ssl]] ) ~= "") -- and true or nil
-has_curl = (UTIL.exec( [[which curl]] ) ~= "")
-has_curlssl = (SYS.call( [[$(which curl) -V | grep "Protocols:" | grep -qF "https"]] ) ~= 0)
+has_wgetssl = (SYS.call( [[which wget-ssl >/dev/null 2>&1]] ) == 0) -- and true or nil
+has_curl = (SYS.call( [[which curl >/dev/null 2>&1]] ) == 0)
+has_curlssl = (SYS.call( [[$(which curl) -V 2>&1 | grep "Protocols:" | grep -qF "https"]] ) ~= 0)
has_curlpxy = (SYS.call( [[grep -i "all_proxy" /usr/lib/libcurl.so* >/dev/null 2>&1]] ) == 0)
-has_fetch = (UTIL.exec( [[which uclient-fetch]] ) ~= "")
+has_fetch = (SYS.call( [[which uclient-fetch >/dev/null 2>&1]] ) == 0)
has_fetchssl = NXFS.access("/lib/libustream-ssl.so")
-has_bbwget = (SYS.call( [[/usr/bin/wget -V 2>&1 | grep -iqF "busybox"]] ) == 0)
-has_bindhost = (UTIL.exec( [[which host]] ) ~= "")
-has_hostip = (UTIL.exec( [[which hostip]] ) ~= "")
-has_nslookup = (SYS.call( [[$(which nslookup) 127.0.0.1 0 >/dev/null 2>&1]] ) ~= 0)
+has_bbwget = (SYS.call( [[$(which wget) -V 2>&1 | grep -iqF "busybox"]] ) == 0)
+has_bindhost = (SYS.call( [[which host >/dev/null 2>&1]] ) == 0)
+has_hostip = (SYS.call( [[which hostip >/dev/null 2>&1]] ) == 0)
+has_nslookup = (SYS.call( [[$(which nslookup) localhost 2>&1 | grep -qF "(null)"]] ) ~= 0)
has_ipv6 = (NXFS.access("/proc/net/ipv6_route") and NXFS.access("/usr/sbin/ip6tables"))
has_ssl = (has_wgetssl or has_curlssl or (has_fetch and has_fetchssl))
has_proxy = (has_wgetssl or has_curlpxy or has_fetch or has_bbwget)
diff --git a/applications/luci-app-ddns/po/templates/ddns.pot b/applications/luci-app-ddns/po/templates/ddns.pot
index dbe317d13..ba007c4f3 100644
--- a/applications/luci-app-ddns/po/templates/ddns.pot
+++ b/applications/luci-app-ddns/po/templates/ddns.pot
@@ -1,5 +1,15 @@
msgid ""
-msgstr "Content-Type: text/plain; charset=UTF-8"
+msgstr ""
+"Content-Type: text/plain; charset=UTF-8\n"
+"Project-Id-Version: luci-app-ddns 2.4.0-1\n"
+"POT-Creation-Date: 2016-01-30 10:15+0100\n"
+"PO-Revision-Date: \n"
+"Last-Translator: \n"
+"Language-Team: \n"
+"MIME-Version: 1.0\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-Generator: Poedit 1.8.4\n"
+"X-Poedit-SourceCharset: UTF-8\n"
msgid "&"
msgstr ""