summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--modules/luci-lua-runtime/src/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/luci-lua-runtime/src/Makefile b/modules/luci-lua-runtime/src/Makefile
index dcce33dc8c..9dbaff4ee0 100644
--- a/modules/luci-lua-runtime/src/Makefile
+++ b/modules/luci-lua-runtime/src/Makefile
@@ -13,7 +13,7 @@ clean:
rm -f contrib/lemon parser.so plural_formula.c plural_formula.h *.o
parser.so: template_parser.o template_utils.o template_lmo.o template_lualib.o plural_formula.o
- $(CC) $(LDFLAGS) -shared -o $@ $^
+ $(CC) $(LDFLAGS) $(FPIC) -shared -o $@ $^
version.lua:
./mkversion.sh $@ $(LUCI_VERSION) "$(LUCI_GITBRANCH)"