summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rwxr-xr-xbuild/mkversion.sh21
-rw-r--r--contrib/package/luci/Makefile5
-rw-r--r--libs/core/luasrc/init.lua13
-rw-r--r--libs/core/luasrc/version.lua12
-rw-r--r--themes/openwrt-light/luasrc/view/themes/openwrt-light/header.htm4
-rw-r--r--themes/openwrt.org-oxygen/luasrc/view/themes/openwrt.org-oxygen/header.htm4
-rw-r--r--themes/openwrt.org/htdocs/luci-static/openwrt.org/cascade.css1
-rw-r--r--themes/openwrt.org/luasrc/view/themes/openwrt.org/header.htm4
8 files changed, 54 insertions, 10 deletions
diff --git a/build/mkversion.sh b/build/mkversion.sh
new file mode 100755
index 000000000..2361e5f3b
--- /dev/null
+++ b/build/mkversion.sh
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+local variant
+
+if [ "${4%%/*}" = "branches" ]; then
+ variant="LuCI ${4##*[-/]} Branch"
+elif [ "${4%%/*}" = "tags" ]; then
+ variant="LuCI ${4##*[-/]} Release"
+else
+ variant="LuCI Trunk"
+fi
+
+cat <<EOF > $1
+module "luci.version"
+
+distname = "${2:-OpenWrt}"
+distversion = "${3:-Development Snapshot}"
+
+luciname = "$variant"
+luciversion = "${5:-svn}"
+EOF
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 3016adf73..06ec7c802 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -106,6 +106,11 @@ endef
define Package/luci-core/install
$(call Package/luci/install/template,$(1),libs/core)
+ $(PKG_BUILD_DIR)/build/mkversion.sh $(1)/usr/lib/lua/luci/version.lua \
+ "OpenWrt Firmware" \
+ "$(OPENWRTVERSION)" \
+ "$(PKG_BRANCH)" \
+ "$(PKG_VERSION)"
endef
define Package/luci-core/config
diff --git a/libs/core/luasrc/init.lua b/libs/core/luasrc/init.lua
index 2eacc6ca9..81a65b181 100644
--- a/libs/core/luasrc/init.lua
+++ b/libs/core/luasrc/init.lua
@@ -12,9 +12,9 @@ Copyright 2008 Steven Barth <steven@midlink.org>
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
+You may obtain a copy of the License at
- http://www.apache.org/licenses/LICENSE-2.0
+ http://www.apache.org/licenses/LICENSE-2.0
Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
@@ -23,7 +23,12 @@ See the License for the specific language governing permissions and
limitations under the License.
]]--
+
+local require = require
+
module "luci"
-__version__ = "0.9"
-__appname__ = "LuCI"
+local v = require "luci.version"
+
+__version__ = v.luciversion or "0.9"
+__appname__ = v.luciname or "LuCI"
diff --git a/libs/core/luasrc/version.lua b/libs/core/luasrc/version.lua
new file mode 100644
index 000000000..9e5cb719c
--- /dev/null
+++ b/libs/core/luasrc/version.lua
@@ -0,0 +1,12 @@
+--[[
+LuCI - Lua Configuration Interface
+Version definition - do not edit this file
+]]--
+
+module "luci.version"
+
+distname = "Host System"
+distversion = "SDK"
+
+luciname = "LuCI"
+luciversion = "SVN"
diff --git a/themes/openwrt-light/luasrc/view/themes/openwrt-light/header.htm b/themes/openwrt-light/luasrc/view/themes/openwrt-light/header.htm
index 7972c93f9..689353c48 100644
--- a/themes/openwrt-light/luasrc/view/themes/openwrt-light/header.htm
+++ b/themes/openwrt-light/luasrc/view/themes/openwrt-light/header.htm
@@ -59,9 +59,9 @@ require("luci.http").prepare_content("application/xhtml+xml")
</p>
<div id="header">
-<h1><%=luci.config.brand.firmware%></h1>
+<h1><%=luci.version.distname%></h1>
<p>
-(<%=luci.config.brand.distro%>) |
+: <%=luci.version.distversion%> |
<%:load%>: <%=load1%> <%=load5%> <%=load15%> |
<%:hostname%>: <%=hostname%>
</p>
diff --git a/themes/openwrt.org-oxygen/luasrc/view/themes/openwrt.org-oxygen/header.htm b/themes/openwrt.org-oxygen/luasrc/view/themes/openwrt.org-oxygen/header.htm
index a2c48b9f4..fe18214ce 100644
--- a/themes/openwrt.org-oxygen/luasrc/view/themes/openwrt.org-oxygen/header.htm
+++ b/themes/openwrt.org-oxygen/luasrc/view/themes/openwrt.org-oxygen/header.htm
@@ -61,9 +61,9 @@ require("luci.http").prepare_content("application/xhtml+xml")
</p>
<div id="header">
-<h1><%=luci.config.brand.firmware%></h1>
+<h1><%=luci.version.distname%></h1>
<p>
-<%=luci.config.brand.distro%><br />
+<%=luci.version.distversion%><br />
<%:load%>: <%=load1%> <%=load5%> <%=load15%><br />
<%:hostname%>: <%=hostname%>
</p>
diff --git a/themes/openwrt.org/htdocs/luci-static/openwrt.org/cascade.css b/themes/openwrt.org/htdocs/luci-static/openwrt.org/cascade.css
index 7fb7fc873..cf4265d6a 100644
--- a/themes/openwrt.org/htdocs/luci-static/openwrt.org/cascade.css
+++ b/themes/openwrt.org/htdocs/luci-static/openwrt.org/cascade.css
@@ -9,6 +9,7 @@ body {
background-position: bottom center;
background-repeat: repeat-x;
color: #ffffff;
+ height: 100%;
}
body {
diff --git a/themes/openwrt.org/luasrc/view/themes/openwrt.org/header.htm b/themes/openwrt.org/luasrc/view/themes/openwrt.org/header.htm
index e658bfc67..131e76722 100644
--- a/themes/openwrt.org/luasrc/view/themes/openwrt.org/header.htm
+++ b/themes/openwrt.org/luasrc/view/themes/openwrt.org/header.htm
@@ -59,9 +59,9 @@ require("luci.http").prepare_content("application/xhtml+xml")
</p>
<div id="header">
-<h1><%=luci.config.brand.firmware%></h1>
+<h1><%=luci.version.distname%></h1>
<p>
-<%=luci.config.brand.distro%><br />
+<%=luci.version.distversion%><br />
<%:load%>: <%=load1%> <%=load5%> <%=load15%><br />
<%:hostname%>: <%=hostname%>
</p>